Forums

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

l502x audio stutters

This question has suggested answer(s)

my new dell l502x, running bios a01, studders the sound whether it comes from the harddrive or internet streaming; regardless of player. It stutters for ½ second and then continues. I've noticed that it comes when the computer doesnt have much to do and the fan changes speed. When the computer is working constantly the fan is constant at a speed and the stuttering is much less. I have a theory about the fan being a problem but wanted to hear if anyone else in here has the same problem.

The computer it self doesnt freeze or halt when it studders.

Im runnning the latest drivers that dell provides at their support page.

I've contacted dell technical who recommends me to update the bios to a04 but i cant download it from the neither the danish or american site.

All Replies
  • chilly009
    I've contacted dell technical who recommends me to update the bios to a04 but i cant download it from the neither the danish or american site.

    The A04 BIOS for an XPS L502X model is here, but it does not say anything about fixing an audio or fan problem.

    If you have trouble downloading it then look at the Dell Download Manager FAQ.

    There are some apps on the internet that allow you to manually control the fan which might help in diagnosing whether or not the fan is the problem. Another thing, to get best audio performance you need to disable all power saving features on the computer. There can be several. When the fan changes speed it might be the power level shifting which can interrupt the audio stream, particularly in Vista and 7.

    Jim Coates -- senior forum member


  • I have the same problem as you, I updated to the lattest bios but it does't fix the problem, it only minimise a little, but I notice that the main problem is something with the wireless card because the problem disapear when I turn off my wireless card and play a song. I hope that Dell fix it soon because is really sad that the new and lattest laptop of dell has this kind of problems that are really annoying.

     

  • Please someone from dell could help us tu solve this problem!!!. I contacted with a support center from my country and they told me 

    to reinstall drivers, I did but it does´t work. Please someone on dell US know about this problem and how to solve it?

    I have a XPS l502x that has a audio stutters problem.

    Thanks

    bye

     

  • Hi,

    I've the same problem (XPS15 L502x , audio stutters problem). I was wondering if someone has solved this problem and how ?

    Does someone know if this is also happening with linux os ?

    Thanks and good luck!

  • Hi dude,

     

    I already solve it, the problem was that the laptop had two cores off. I just turned on using execute command msconfig.

    Click on Start->type msconfig->Click on Boot->Advanced Options->Check on Number of Processors->Now select the Processor that you want to activate->Click on Apply->OK.

    You need to active 8 cores, if you only have the option of 4 and you can't select 8, just uncheck the option, restart and go back and now you can see 8 cores.

    I hope it could help you.

    Best Regards!.

     

  • Hi dude,

    I already solve it, the problem was that the laptop had two cores off. I just turned on using execute command msconfig.

    Click on Start->type msconfig->Click on Boot->Advanced Options->Check on Number of Processors->Now select the Processor that you want to activate->Click on Apply->OK.

    You need to active 8 cores, if you only have the option of 4 and you can't select 8, just uncheck the option, restart and go back and now you can see 8 cores.

    I hope it could help you.

    Best Regards!.

  • Hi!

    I've been testing my sound for more than 25 mn and I've got no pb.

    Thanks so much!

    Best regards !

  • Try the bios update, i have A07 installed and it's working fine. If you have any gadget in your desktop try to deactivate it, i was having sttuters from a gadget that was monitoring the nvidia temps.

  • Hi,

    Thanks for your help but I just solved it. I have the same problem than edgard_cz.

     

    The problem was that the laptop had two cores off

    Have a nice week-end!

    Bye.

     

  • sorry edgard_cz, and sorry me, but your fix doesn't work.  whatever manually setting 8 cores to engage does, it doesn't fix the audio stutter.  maybe it reduces a little bit of the symptomatic stutter, but the problem is still there, and the stutter is still very much there.  i've done what you suggested twice.  thanks anyway.  maybe it's an audio driver / hardware incompatibility issue?

  • I'm also experiencing the stutter with my L502x which is very annoying especially during gamming.

    I’ve also followed edgard_cz instructions which has improved it but not removed it all together.

     

    Has any tried a clean install and still experiencing the same issues ??

    It would be great to hear some feedback from a Dell rep/Mod as it appears to be a common issue.

  • It has nothing to do with the activitated cores; the only reason that should have even been set is if you messed with it; otherwise, Windows autodetects the cores when you boot (hence why it is unchecked).

    I have the same problem, and it looks like people with the XPS 17 are having it as well (answers.yahoo.com/.../index).

    Is this the sound you are hearing: (

    )

    I have had my L502x for three months and I just started having the problem in the last two or three days. It isn't a browser or flash issue, as I have had the problem with Winamp. It does, however, appear to be a streaming issue.I had thought it might have had to do with the power management feature in RealTek, but that isn't it either. I have turned off MaxxAudio and X-Fi as well with no avail. It really beginning to piss me off as well. I have another laptop using the same network and I do not get this problem - and, until the past couple of days I did not have this problem with the L502x as well. Really quite strange. The only major changes I have made in the last couple of days has been routine Windows Updates and updating BOINC (this is my next step - disabling BOINC and seeing if that causes the problems - but, I assume that isn't it as I imagine all of you don't use BOINC).

  • Just had the problem using Windows Media Player for local files. So, it appears to not be isolated to streaming internet audio.

  • I'm thinking it has to do with audiodg.exe using more cpu power, it likely gets worse with each progressive Windows update that tweaks with it, so those of us with the nearer laptops are now feeling it: windows-exe-errors.com/fix-audiodg-exe-high-cpu-usage-in-windows-7. Don't know if you want try this solution, but it appears that it might be right. Having watched Performance Manager for a while, there does appear to be a huge CPU spike when the audio shutters - even on parked CPUs.

  • Hi frank0051

     I'm getting the same issue as described on the video.

    It becomes quite consistent when playing games like Deus EX so it defiantly has nothing to do with the streaming or flash issues.

    Have you tried disabling audiodg.exe yet?

    Have you also done a clean format/clean install since your purchased laptop and experiencing the same issues?

    It's very annoying especially when top dollar has been spent !!