Latitude D610 Windows 7 Audio

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Latitude D610 Windows 7 Audio

This question is answered

Hello everyone.Hopefully someone can really help me out as soon as possible but ofcourse no rush...but seriously its killing me lol

 

Anyway the main problem is the Audio and I believe the Video Card as well. I got a computer for a gift from my teacher who happens to work with computers and etc. He gave me this laptop, Latitude D610. He told me he installed Windows 7 on here and I checked the compatibility for my model and the test said it was compatible. But for some reason it keeps saying,"No Audio Output Is Installed." So I searched and searched my computer and it says my Multimedia Audio Controller was there which should signify I have the audio driver installed from the site.(Correct me if I'm wrong) So I clicked on the volume icon to see if it would correct the problem and it sent me to the site to download the "updated version".  I went to the Dell site and I downloaded the audio driver for my laptop but I already have all the drivers apparently. I've checked everything and it says there are no updated drivers for my Model Laptop. I tried uninstalling Windows 7 but I believe you need the disk. And I tried installing Windows XP once again, but once again I need the disk. But I don't have it. AND what makes matters worse is I'm overseas so I dont have any access.

If possible can someone please tell me a way to get Audio and Video if possible..

Verified Answer
  • APendulum
    I checked the compatibility for my model and the test said it was compatible.

    But what it didn't tell you was that 7 does not contain audio drivers for the old AC97 type of audio on the D610 motherboard, nor that Dell does not have any AC97 drivers for 7. Fortunately there is one for Vista so try this which has worked for several people:

    Download the Sigmatel audio R99254 driver. Unpack it but cancel the installation process.
    It will unpack the files and store them in a folder on the hard drive at c:\Dell\drivers\R99254, and that folder will have a subfolder named WDM.
    Open Device Manager and expand System devices near the bottom. Find the PCI Device entry with a ? next to it (or if that is not there then do this at "Multimedia Audio Controller") . Go to the properties and choose to update the driver. Choose to manually find the driver and don't let Windows look for it. Browse to c:\Dell\drivers\R99254\WDM

    It should detect some new hardware and one of them should be the Sigmatel audio system.

    I don't know about the video. I don't remember anyone saying they had difficulty with the video after installing 7.

    Jim Coates -- senior forum member


  • Hi jimco, you save my day.... keep it up it works for me sharp!!!!!!!!!!!!!!!!!

     

All Replies
  • APendulum
    I checked the compatibility for my model and the test said it was compatible.

    But what it didn't tell you was that 7 does not contain audio drivers for the old AC97 type of audio on the D610 motherboard, nor that Dell does not have any AC97 drivers for 7. Fortunately there is one for Vista so try this which has worked for several people:

    Download the Sigmatel audio R99254 driver. Unpack it but cancel the installation process.
    It will unpack the files and store them in a folder on the hard drive at c:\Dell\drivers\R99254, and that folder will have a subfolder named WDM.
    Open Device Manager and expand System devices near the bottom. Find the PCI Device entry with a ? next to it (or if that is not there then do this at "Multimedia Audio Controller") . Go to the properties and choose to update the driver. Choose to manually find the driver and don't let Windows look for it. Browse to c:\Dell\drivers\R99254\WDM

    It should detect some new hardware and one of them should be the Sigmatel audio system.

    I don't know about the video. I don't remember anyone saying they had difficulty with the video after installing 7.

    Jim Coates -- senior forum member


  • Thank you Jim. It worked perfectly right after I did it. You are a life saver and once again thank you.

  • Jim,

    I am not sure if you are still available to help but I am having this same problem; however it is with the "video controller."  I followed the instructions on audio/multimedia controller and that is now working perfectly.  However Windows 7 will not recognize "video controller" on my D610.  Any suggestions?

    Thanks!

    Brian

  • Hello Brian. This is embarrassing. Looking over my answer earlier in the thread I see that I left out a step. I forgot to say to install the driver using Vista compatibility mode (the audio driver I referred to is a Vista & XP version). But it seems to work as written so I guess it's okay.

    About the video driver I am no expert. It is out of my field but I would try this. Download the diver from the D610 downloads page. There are 3 in the Videao category so you have to determine which graphics card your model has. Then unzip the download package to its default location -- make a note of where that is -- but cancel the installation. Go to the folder on the hard drive where the files were unpacked. Find the setup.exe file and right click on it. Locate the 'compatibility' tab and click on it. Choose 'XP' (if it lists Service Packs choose SP#3  or 2). You would use XP compatibility because all 3 of those video drivers are XP versions.

    Jim Coates -- senior forum member


  • Hi jimco, you save my day.... keep it up it works for me sharp!!!!!!!!!!!!!!!!!