Multimeda Audi controller - Dell Latitude D610

Laptop

Laptop
Laptop computer Hardware and Software discussion

Multimeda Audi controller - Dell Latitude D610

This question is not answered

First post Smile.

I have just installed Vista ultimate on my Dell Latitude D610. Everything seems to work fine with the exception of the Audio.

I have tried to search for audio drivers using my service tag, and installed a Sigmatel? driver but nothing happens.

What should i try next?

Device manager shows the Multimedia audio controller at fault. Can anyone point me in the direction of which driver i need to install to sort this out?

Im not so clever at computers but why cant these drivers be named the same as being requested on Device manager? It would make life so much easier?

 

 

All Replies
  • Chipset Drivers should always be installed and then the system rebooted before audio drivers.

     

    Intel® Chipset Software Installation Utility - Intel® Chipset ...

     

    Dell D610 - Windows Vista Ultimate

     

    1.  Uninstall the device from the Device Mgr and make sure to check DELETE DRIVER option

    2.  Reboot

    3.  Install XP driver

     works on my DELL Latitude D610. 

    It also works on:

    Inspiron- 6000, 93000, 9200, 2200, 1200, XPS Gen 2

    Latitude- D610, D810, 110L, D510, D410, X1

    Precision- M20, M70

    Computers- MXG051


    http://ftp.dell.com/audio/R99254.EXE

     

    Report Unresolved Customer Service Issues here:

    Dell - Unresolved Customer Service Issues

    I do not work for Dell. I too am a user.

    The forum is primarily user to user, with Dell employees moderating.

  •  

    "why cant these drivers be named the same as being requested on Device manager?"

    The audio chip on the D610 is a Sigmatel AC'97 controller. The system cannot recognize that hardware unless the Intel Mobile Chipset software is installed. If it is not then the Device Manager can only show you a generic name for the audio controller. As a complication you installed an OS not supported by Dell, so finding the right drivers could be a problem no matter what they are named.

    Anyway, this has come up before and this is the method we have devised for getting a Sigmatel AC'97 driver to work with Vista on the D610 and the other models with AC'97 audio. This does not require the Intel Mobile Chipset driver (Dell does not offer a Vista version of it for those models).

    ***********************************************************************************************************

    Download the Sigmatel R99254 audio driver.

    Unpack it (unzip) but cancel the driver installation process. It will unpack the files and store them in a folder on the hard drive at c:\Dell\drivers\R99254, and that folder will have a subfolder named WDM.

    Open Device Manager and expand System devices near the bottom. Find the "Multimedia Audio Controller" with a ? next to it. Go to the properties and choose to update the driver. Choose to manually find the driver and don't let Windows look for it. Browse to c:\Dell\drivers\R99254\WDM.

    With any luck it should detect some new hardware and one of them should be the Sigmatel.


    Jim Coates -- senior forum member


  • Thanks All.

    Case closed. Sigmatel drivers installed and working.Smile

    Great stuff.

    Rav

     

  •  

    Good. I didn't mean to cause confusion with my post -- what happened was that while I was typing my reply SpeedStep made his own which of course I didn't see until after I posted. Good info re the Intel Chipset utility. I will add that to my notes.

     

    Jim Coates -- senior forum member


  • Dear sir......... Hi.I am facing problem of Audio and Sound.

    Type of Labtop was:DELL (LATITude D610.

    Type of windows which Installed is windows 7 ultimate.

    please can you help me  for Audio Driver  special for windows.

     

    Thanks.

    Abdelrazig Hamdan