XPS-13 M1340 not connected HDMI sound/audio connection. No sound on HDMI.

Laptop

Laptop
Laptop computer Hardware and Software discussion

XPS-13 M1340 not connected HDMI sound/audio connection. No sound on HDMI.

This question is not answered

Hello.  I just purchased a Dell SP2309W monitor and am connecting it to my XPS-13 via the HDMI connection.  The video is fine.  No sound comes from the computer.  I used the same cable to connect to a DVD player and the sound and video are fine from that.  When I go into the sound option in control panel it says that the HDMI sound is not connected.  In the IDT control panel (for the sound subsystem), there is a tab for the HDMI and that is bot able to be enabled there either. 

I am running Win 7 64-bit.  I updated all the drives and the firmware.  I even tried teh Nvidia drivers from their website.  Recently, Dell replaced my mother board because the Nvidia Ethernet port would not come on after sleep.  Replacing the motherboard fixed that problem.  I also tried plugging and un-plugging the monitor while the comptuer was on, turning monitor on/off, and restarting the computer.

Has anyone seen this issue before?  Where can I get the latest IDT update for that little sound app?

All Replies
  •  


    I don't know the answer but I can pass along what other forum members have written about this problem. All of these tips were about connecting HDMI audio to an HDMI tv, not a monitor. Not sure if it works with computer monitors

    *******************************************************************************************

    from the  Dell Technology Guide:
    1 Turn off the computer and TV.
    2 Connect the computer and TV.
    3 Then turn the TV on. Adjust its setting to receive HDMI audio.
    4 Next, turn on the computer to allow it to detect the connection to the TV.
    5 Go to Start>Control Panel>Sound>Playback tab. Select the HDMI device as the default device. Click the Set Default button, and then click OK.

    ********************************************************************************************

    HDMI uses its own audio driver separate from the Sigmatel, IDT, or Realtek audio system of the computer. It is actually included in the graphics card's driver so first make sure you have the current version of your graphics card driver.

    ********************************************************************************************

    Models with Intel Graphics

    Next, look in the Device Manager and if you see "Audio device on high definition audio bus" with an exclamation mark, you need to update it. Right click on it and point the updater to the HDMI sub-folder in the Intel graphics card folder. The path will vary depending on the name of your graphics driver but should be something like:
    C:\dell\drivers\R216914\HDMI (GM945/965)
    C:\dell\drivers\R199173\HDMI
    C:\dell\drivers\R207162\HDMI (GM945/965)
    C:\dell\drivers\R180254\HDMI  (GM965 on an Inspiron 1525)
    C:\dell\drivers\R234725 (nVidia GeForce G 210M on Studio XPS 1340)

    Several forums members have posted this tip, about laptops models Inspiron 1525 and  Latitudes E4200, E4300, & E6400.

    ****************************************************************************************************

    Models with ATI Graphics

    Forum member  pauline_hill wrote:

    > Install or update to the current ATI graphics driver.
    > In Device Manager, "update" the driver except use the option to "select from a list of available drivers"
    > Select the High Definition Audio. You will see a warning but click 'install' anyway.
    > Reboot

    The current driver is ATI Mobility Radeon™ HD 4670
    8.631.0.0000, A09, R227577
    Dated 10/07/09
    Studio Laptop 1555
    Studio Laptop 1737
    Studio XPS Laptop 1640
    Vista & 7

    ********************************************************************************************
    Forum member ptdw123 wrote:
    Don't forget to change the settings in POWERDVD DX to HDMI else the sound will still continue to come out of the laptop speakers.

    ******************************************************************

    XPS m1330

    Forum member tclhk wrote:
    Go to 'Sound' from 'Control Panel' or from right-click on the 'Desktop' and then choose 'Personalize' from the menu.
    click 'Playback' at the 'Sound' app, you should see 'Speakers/Headphones' and 'HDMI' codecs.
    If 'HDMI' is there, simply click on it and click 'Set Default'
    If you can't see 'HDMI', try right click on the 'Sound' app and check on 'Show Disabled Devices', and 'HDMI' should appear.

    ******************************************************************

    Studio 1530 (?)
    Forum member hmthomas1 wrote:
    What I found was that when I restarted whatever program (websited or audio source) it would come out through the tv. If I didn't restart it my sound control would show the hdmi default but no audio indicator on the bar levels next to the source icon. I kept thinking it wasn't working but upon restart, it did.

    *********************************************************************

    Mini 10

    Forum member camikins wrote:
    Turn on computer with HDMI plugged in
    Go to control panel -> sound / audio. This opens the Sound & Audio Device Properties window
    Go to Audio Tab. Sound Playback likely reads 'Realtec HD'.
    Unplug the HDMI cable from the computer. Wait 5 or 10 seconds and plug back in.
    Now in the same Souund Playback dropdown you'll hopefully see HDMI Device. Select that, and click Apply

    ************************************************************************

    Inspiron 1525 with Win7
    Forum member  Saad Al Haddad wrote:
    You need to connect your laptop to your TV via the HDMI
    Start window 7
    Press Crlt+Alt+F4 to switch the display to your TV only
    I hope you have an external mouse, becuase you will need to restart your PC and the laptop lid be closed. So after the restart, the bios screen and the windows startup should show on your TV
    With the laptop lid still close, navigate with the help of your external mouse (wired or wireless) to the volume speaker in the task bar and right click. Choose playback devices, then you will see a new slider called HDMI volume.
    It worked every single time with me, so you have to have the graphic card set to display on the TV while windows 7 starts up. Otherwise the driver for the HDMI will not be loaded during the start up.

    ***********************************************************************************

    Windows Media Player

    Forum member John5014 wrote:
    Dell 1530 displays video but has no audio on my TV when using WMP 11. HDMI audio has been selected and you can hear the test tone when selected. Downloaded another player and the system worked fine. The audio still did not work when using WMP. Here is the fix that I found.
    Audio/Playback device/HDMI/properties/Advance/Exclusive Mode I unchecked the Exclusive Mode and the player now has audio out.

    Jim Coates -- senior forum member


  • I have the same exact issue. My motherboard has been replaced and that did not fix the problem. I tried to set hdmi audio as default but that didn't work. Then, I updated my graphics drivers, and the audio playback properties showed that no hdmi was connected at all (although I could see the video on my TV).  I have had no luck. Basically what I ended up doing is getting a 3.5mm jack out cable to RCA audio in and connect that to my TV.

  • There is a button to switch between displays, i had this issue but cycled through this a few times and it ended up working.

  • I was able to solve this problem.  I had to uninstall AND DELETE the drivers for the HDMI audio, then reinstall.  The problem we that I was not specifiying to delete the driver during the uninstall (there is a check box on the dialog box during uninstall to delete driver).  Personally I think this is an issue with Windows 7.  Why should it behave differently when I uninstall if I don't delete the driver?  I have seen this problem before with other Win 7 drivers not function correctly if the wrong driver is uninstalled without deleting and should have known I guess.  Anyway, my problem is now solved.

  • I think i've tried that about 6000 times! But I'll try again and see how it goes. Can you tell me which graphics card you have, and which driver version you are using?

     

     

  • I got the XPS-13 M1340 laptop.  It has the nVidia 9500m SLI graphics.  I have all the latest drivers from the dell driver download site.  Try what I did.  Keep uninstalling all the installed drivers for the HDMI audio.  After you uninstall, AND DELETE, a driver, the next earlier driver will automatically install.  Uninstall, AND DELTE that one.  Keep doing it.  Then install the latest driver from Dell.  You can enable the HDMI autio from the Soudns in Control panel, and also use the IDT audio control in control panel as well.  

  • Hi Damon4.com,

    I've faced the similar problem like yours. Previously, I used the video driver from Nvidia website. When I bought my Hitachi 19" TV, I couldn't get sound from my laptop at my TV through HDMI. What I've done was, uninstall the driver from Nvidia website, and make sure you delete the driver as well. Go to device manager, at Nvidia graphic adapter, right click, uninstall, check the delete the driver checkbox. Then, I used the video driver from Dell. It works perfectly. If you still don't hear any sound at your TV, go to the sound icon at your taskbar, right click, playback devices. Select HDMI adapter, and Set Default.

    You mentioned about your nvidia ethernet didn't turned on after wake up from sleep. I believe all Dell XPS M1340's owner are facing this problem. Wow, I want to replace my motherboard/laptop again by mentioning this problem. I've just paid for my extended 2 years warranty. Could you please tell me which Dell support that you referred? US, UK or etc. ?

    Kind regards,

    Rizuan

  • I fixed the HDMI problem by uninstallaning AND DELETING the driver as you suggest by following a similar procedure as you previously.  It works fine now.

    The ethernet issue was fixed with a mother board replacement.  It was a tech support person from Philippines I think that helped me.

  • .... and the only way to fix my Bluetooth problems was to get a USB Bluetooth adapter and not use the internal card.