Now to disable internal microphone

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Now to disable internal microphone

This question is not answered

Hi all,  I am having a heck of a time trying to disable my internal micophones.  For example while trying to record an album I get ambient sound as my speakers are microphones.  I have tried to disable but no luck. I do see a driver update for my XPS M1530 however it is a Sigmatel Stac 92xx c-major HD audio, and the one installed is a Sigmatel Tel High Def Audio Codec. I have had this just about a year now and would like to fix the problem. Should I update the driver?  Any suggestions?

 I did go in to the control panel to the sound area to the recording tab and tried to disable there but the microphone / line in is telling me that it isnt plugged in. wont allow to disable..

Thanks   Stevea51

All Replies
  •  

    Try this:

    1.      Click Start.
       2.      When the menu opens, highlight either All Programs or Programs.
       3.      Click the Dell Webcam folder, then click the Dell Webcam Manager icon to open it.
       4.      In the Dell Webcam Manager, click the Dell Webcam Center.
       5.      In the lower right-hand corner of the Dell Webcam Center window, click the drop-down arrow next to Audio Source and click Digital Mic to enable/disable the microphone.

     

    If that doesn't work then look at  What is the Integrated Webcam and Digital Array Microphone. At the bottom of that page there is a link to a troubleshooting wizard named "Problem with the Integrated Web Camers" Wizard ID 297119. You will be asked to submit the model name of your computer and its operating system, then you can select the type of problem you are having, which is "The microphone is not working". This wizard is a good place to start diagnosing your problem and it will walk you through all of the steps to configure the camera. Try reversing the instructions to disable the mic.

    Jim Coates -- senior forum member


  •  

    Steve,

    I saw your message to me in the new thread you started. To keep the conversation in this thread just click the "reply" button below.

    A couple of things I don't understand. What did you mean by: "For example while trying to record an album I get ambient sound as my speakers are microphones." Any speaker will become a microphone if it is plugged into a mic jack. Speakers and mic diaphrams are essentially the same thing.

    "... the microphone / line in is telling me that it isnt plugged in. wont allow to disable." Two things I don't understand. You should not disable mic/line-in because that is the input jack that you are trying to use to record your album, isn't it? The other thing is that it should not say nothing is plugged in if your turntable is plugged into it. If it is not detecting a plug in it then the jack may be faulty. (And make sure the jacks are not configured for 5.1 sound or else the input jack might not work right.)

    "Should I update the driver?" Yes. See if doing that helps.

    "If I buy a good quality  external sound card, will this fix the problem?" I "think" it will fix it. An external sound card functions independently of the Sigmatel audio system. When there is an external card, you can choose either it or the Sigmatel as the default audio system, but not both at the same time. I am not sure how the internal mic is routed. If it is hard wired to the Sigmatel then it would not be detected by an external card and you would be all right.

     

    Jim Coates -- senior forum member