IDT HD Audio Codec and the Stereo Mix Option.

Laptop

Laptop
Laptop computer Hardware and Software discussion

IDT HD Audio Codec and the Stereo Mix Option.

This question has suggested answer(s)

Okay, So, I have that thing, but Stereo Mix doesn't show up. I need to enable that option to record sound for a video recording program. I tried downloading drivers, but they aren't compatible. How do I make this option pop up? I have an Inspiron 1545, by the by.

All Replies
  • If you are using Vista, make sure that when you are in the "Recording" tab, you are showing "disabled" devices. Under the list of microphones, etc, right click a blank space and select "Show Disconnected Devices". Then a source called "Rec. Playback" should come up. This IS stereo mix. Right click, enable it and then you can select it as your default device and use it from other applications, etc.

    If you still don't see it, you may be a victim of Dell's strange policy of disabling Stereo Mix on some laptops. I personally have a Studio 1537 with IDT and it has Stereo Mix enabled, but Dell have restricted it in the past on some computers due to copyright protection.

  • Oh, I see that option! But it reads "Currently Unavailable". It's enabled, but how do I make it available?

  • If you right click the Rec. Playback and set it as the default device (for recording), it should automatically start working and enable itself. Then you can use it in any of your other programs. The main reason it says "Currently Unavailable" is the fact that it can't monitor the mic inputs AND the stereo mix at the same time. You'll notice that when you set the Rec. Playback as the default device, a volume meter comes up next to it from which it is monitored from, and then one of the mics will then say "Currently Unavailable". It's just a vista thing.

  • Oh, but what about my Mic plugged in the Line In jack? Will it still work? Some programs, I've noticed, seem to not recognise it if it isn't set to default.

  • Hey,

    Same prob here too.. Im using inspiron n5010..  with the same IDT high def codec.. I badly need to try recording voice and background music togather.. !! when i enable the rec playback option, the mic gets to unavailable status.. is it possible to have both??? do i need to try changing to win XP?? 

  • sree72003
    with the same IDT high def codec..

    All 3 laptop models mentioned in this thread have audio chips manufactured by IDT but none is the same as either of the other 2. The N5010 has the 79B1 IDT HD chip.

    sree72003
    !! when i enable the rec playback option, the mic gets to unavailable status.. is it possible to have both???

    No. Each is a recording "source" and in computer recording you can only select one source at a time. You need a multitrack recorder program, where you record your vocal on one track while the background music is being played back on a separate track. After the vocal track is recorded the program can mix the 2 tracks together into one new track. I use a program called Sonar for this type of procedure but it is expensive. I believe the free program named Audacity will let you multitrack. You can get it from

    http://audacity.sourceforge.net/

    Edit: the "features" page on the Audacity site says "Dub over existing tracks to create multi-track recordings."  It looks like a good program for you to try.

    Jim Coates -- senior forum member


  • Sorry to resurrect an old thread. I have been having the same problem with the Rec. Playback option. Alas, when I select Rec. Playback as the default option, it does not come up with a volume level and still says "Currently Unavailable". Any ideas?

  • I also have an Inspiron 1545 and have been working on this stereo mix problem for a few hours today. Here's the solution I've found using Windows 7 and the IDT High Definition Audio. 

    1. Go to the Sound controls for recoding devices (right click on the speaker icon)

    2. Right click on Rec. Playback and enable it.

    3. Right click on your microphone and  enable it and set a a default device (mine is a Logitec Pro 9000 webcam microphone, and I've set it as the "default communication device"

    Here's the secret part:

    4.When you click on your microphone then click on the "properties" button, and then click on the "listen" tab, and then click on "listen to this device"

    Now you can hear your mic through your headphones and hear music playing through the Rec. Playback at the same time, and you should be able to then record or use it with any program to simultaneously play/record microphone and music.  

    I use it to broadcast my webcam at http://justin.tv/kq4ym  and it does work for that and should work for your use. (There is an slight echo heard through your earphones when you are using the mic but it does not show up on the recording)

  • Thanks for posting that tip.

    Jim Coates -- senior forum member


  • Well, I guess this can be closed. I've gotten a Studio XPS last christmas, and it's been serving me well. I guess it was just Camstudio unable to record the computer audio and the microphone audio simultaneously, lol.

  • hiiiii

    sorry but it doesnot work with me

    i tried to play music while iam speaking in the chat rooms for example but the song does not apper just my sound

    by the way may labdell inspiron 1545

    tahnk u so much

  • cok g├╝zel

  • selammmmm

  • Hi,

    I want to use a headset microphone while also recording the system sound.

    I tried to do what you suggested and alas it didn't work.

    First I set up my headset mic (Dock Mic) using the speech recognition tool.

    I then set the Rec. Playback as the default device and the Dock Mic as the default communication device.

    I then configured the computer to listen to both these devices.

    It seems that when the Rec. Playback is set as default the Dock mic is unavailable and vice versa.

    Is there a way to solve this so that both are available?

    Thanks,

    omer