Display, Audio, and Sound driver on Dell vostro 1400 with Windows XP Pro

Laptop

Laptop
Laptop computer Hardware and Software discussion

Display, Audio, and Sound driver on Dell vostro 1400 with Windows XP Pro

This question is not answered

Hi,

Couple of year ago I bought a Dell Vostro 1400 that came with Windows Vista. I uninstalled Vista and installed XP Pro on it. It worked fine for two years. However, couple of weeks ago it crashed and I had to do a clean install of XP on this laptop. But, I do not have the drivers CD that I used back then. So, currently I am having problems finding the display, audio, and sound driver for XP on Vostro 1400. I tried downloading drivers for XP from support.dell.com but it errors out.

How and where could I get the display, audio, and sound driver for XP on Vostro 1400 that came with Vista? Any help with be highly appreciated.

 

 

Thank you in advance.

All Replies
  •  

    These instructions are for a situation where an operating system has already been reinstalled and everything works except the audio driver will not install ... usually you get an error message, because the Notebook System Software and chipset drivers were not installed correctly and the audio chip on the motherboard is not recognized. In this situation "usually" a fresh install of the OS is not required, just re-installing the NSS and chipset correctly. If that doesn't work then a full re-installation may be necessary.

    After you have performed an Operating System re-installation, install in this order:

    a. Dell Notebook System Software (on your downloads page expand the System Utilities category). Restart.

    b. Next install the Intel Mobile Chipset driver (expand the Chipset category). Restart.

    c. Install the other drivers including the Sigmatel audio driver (expand the Audio category).

    Get these from the Vostro l400 driver downloads page. When you get on the page use the dropdown box to select your Operating System.

    Note, when you get to step c, before you install the Sigmatel driver go to your Device Manager and look for an unknown PCI device. If there remove it and then proceed with the Sigmatel driver installation.

    The graphics driver is in the Video category. I don't have specific instructions for the installation .... I concentrate on audio problems.

    **********************************************************************************************************

    If that doesn't work I can give you the method people had to use before Dell started supporting XP on the Vostro l400. It involves using an older driver from the Vostro l500, but that method should no longer be necessary.

     

    Jim Coates -- senior forum member


  • Thanks a lot Jim. I was able to resolve my problem by following the order of download specified by you. I was missing the NSS driver. Reinstalling audio and display driver after installing the NSS driver solved my problem.

    Once again, thanks a lot!!

    -Puja

  • I dont have audio sound driver for my Dell laptop( vostro 1400). I request u plz send me Audio sound driver software to my email id 

    <ADMIN NOTE : Email id removed per privacy policy>

  • http://support.dell.com/support/downloads/driverslist.aspx?c=us&l=en&s=gen&ServiceTag=&SystemID=VOS_N_1400&os=WLH&osl=en&catid=&impid=

    it can be downloaded from the above link