Dell Studio - No Sound through HDMI to TV

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Dell Studio - No Sound through HDMI to TV

This question has suggested answer(s)

I've read many many posts on many many boards talking about this problem.  None seemed to fit my circumstances, so I'll come here and try my own post.  I also called Dell and Microsoft and neither could help (for free - I may yet have to pay to get it working).

I have a studio laptop running Vista 32 and connected via HDMI cable to a Vizio LCD.  Picture is great but no sound.  Actually, with the laptop connected and shutdown and TV on, I start the computer I get the startup sounds from Vista through the TV (very encouraging) - then nothing.  I have diddled with everything related to the sound on the machine -

  • I have selected the HDMI as the default output device (it's actually already set that way when I plug the HDMI cable in)
  • I have played with every button, checkbox, and pulldown menu item (and their various combinations) in the audio configuration dialogue for HDMI
  • I have reinstalled the drivers
  • I have disabled and reanabled the device
  • I have started the machine over many times
  • I have adjusted all of the audio settings on the TV

I do NOT have the SPDIF option on the sound output that seems to solve everyone elses problem.  I don't know the audio card, but it's the default option that comes with the studio (nothing special) .

I did notice that I can't adjust the frequency of the HDMI output (which I think is the problem) it only allows 16bit 44.1 KhZ (I read somewhere HDMI needs 24 bit - I don't have that option).  I also can't connect the HDMI for picture AND the RCA for sound as the TV only takes input through HDMI OR RCA - not both at the same time.

I think if I didn't get the initial Vista sounds through the TV I would have given up long ago - but because I do, I know it should (and can) work!

Any help or insight is greatly appreciated.

All Replies
  •  

    I don't have an HDMI system, but from reading posts here about it I think that it does not pass audio to the tv through your IDT audio system's driver, but through a separate audio driver associated with the graphics card. I don't know the specifics so I can just give you suggestions of where to look.

     

    > In the Device Manager there is an "Audio device on high definition audio bus" which is the HDMI port driver located in the HDMI folder of your display driver folder, something like C:\dell\drivers\R199173\HDMI.

    > Another poster wrote:

    "... in the unzipped intel video driver (GM965) there's a folder named HDMI. It contains the driver for the audio device on high definition audio bus. To install, right click on the device in device manager (which has an exclamation mark on it), then update driver, and point to the HDMI folder.
    Once the driver is installed, the (!) exclamation should disappear in device manager. There's no need to reconfigure any audio settings. Audio will automatically be fed to the HDMI port...."

     

    Hope that is of some use.

     

     

    Jim Coates -- senior forum member


  • Thanks for your post.  HDMI stands for High Definition Multimedia Interface.  The Multimedia means audio and video.  Look here for a high level discussion of the technology.  (http://hometheater.about.com/od/hometheatervideobasics/qt/hdmifacts.htm

  •  

    My point was that I don't believe the problem/solution is to be found in the computer's integrated audio system (IDT), but in the area that I pointed you to.

     

     

    Jim Coates -- senior forum member


  •  

    Here is a thread on notebookforums that confirms that HDMI audio is associated with the graphics card's driver. The thread has an explanation of how to enable the HDMI audio output on an Inspiron 1525.

     

    Jim Coates -- senior forum member


  • I just got a Studio 1737 and had a problem with the HDMI cable too.  The picture was fantastic on my Philips LCD tv but no sound.  Fortunately, I bought two cables so as a court of last resort I switched cables and voila there was stereo sound.  I'm sure there are configuration problems on many systems but my problem was simply the HDMI cable.  I hope this helps someone.  By the way, the sound came through my laptop speakers after I unplugged the HDMI cable.  To be safe, I turned off the TV before I disconnected the cable though.  

  • I have the same problem with Dell Studio Laptop 1737 and RCA 32" high def TV - get picture but no sound.  The Control Panel / Sound / Manage Audio Devices shows the Digital Output Device (HDMI), and I set that as default, but under the Configuration button, Test does not produce a sound thru TV speakers.  Also under the device's Properties / Supported Formats, there are 3 choices: DTS Audio, Dolby Digital, MS WMA Pro Audio, and selecting each one to "test" produces the same result: Windows unable to play the tone, support will be disabled.  There is one choice under Sample Rates: 48.0 KHz, and testing this asks if I hear a sound, I click No, and nothing happens.

    To troubleshoot, I connected this same PC with same HDMI cable to a different TV, and it all worked great.  Then I tried the problem TV with the same HDMI cable connected to a DVD player and a cable box - both worked fine.  So the problem seems to be that the PC is not passing sound thru the HDMI cable to this RCA TV.  (I can set the speaker default the IDT High Def Audio CODEC option and hear the movie thru the laptop speakers while viewing on the TV, but that's not a good option.)

     

  • Sadie2,

    I have been having the same problem. I have the same laptop and a 40 inch RCA HD TV. The HDMI gives me great picture but no sound at all. I followed the same steps as you with the same results. In the past I have hooked my laptop to other HD TVs using a HDMI cable and had no problem getting sound (once I set the HDMI as the default).

    This problem is really making me upset. Have you found a solution? Any help on this issue would be greatly appreciated.

  • Welcome to the Dell Unresolved Forums.

     

    How many "I have this problem too" posts does it take to get a solution.

     

    Loving it, 1645 XPS, I too have the same problem. 

     

    How about some more people reply that don't have an HDMI port and specualte on the solution..

     

    Love you guys!

     

    mike


  • See the thread How to Enable HDMI Audio. Every tip there is from someone who got HDMI audio to work with their model of Dell laptop and an HDMI tv.

    Jim Coates -- senior forum member


  • Hello All

     

    I have a Studio 1737 Laptop also with a similar problem, however I'm going through an AVI Amplifier to the HDMI Flat panel. I'm running the IDT audio codecs that are the same as what was given to me with the purchase of the laptop. It was working great for me (with sound), until I had to replace my memory sticks and decided to reinstall my operating system and upgrade from the Vista 32 bit to the Win 7 32 bit operating system.

    Once this procedure was complete, and the drivers were all reinstalled/ replaced, the HDMI option does not show up on my IDT interface, only the headphone option and the independent option, which neither seems to be for the HDMI output on the Laptop.

    Like others, the picture is fantastic, but I cannot get the audio to play or find an answer to this problem. I think there is some kind of bug, but also a different problem, as IDT had the HDMI option on the interface before, but now does not.

    I think if somebody can explain how you tell IDT to add the HDMI output as my independent device, everything would be fine. There is no add device option on the IDT interface at all. Am I missing a driver for the HDMI output? Why does IDT not detect my HDMI cable and prompt me to use it for audio playback? It sends the picture automatically, but doesn't ask about the audio, strange!

     

    Hopefully, I'm simply missing something very simple here. Thanks a bunch for any help.

  • Hi,

    This may help you, not sure.

    I have a Dell Vostro 3500 Laptop and I also had great Video but no HDMI Audio.  Also in Control Panel > Sound,  the HDMI option for Audio did not show up.

    Dell Support helped out and told me what was happening.

    The Vostro has two integrated display cards; an ATI ( for lower power consumption) and an Nvidia.  But only the Nvidia has HDMI Audio output.  Everytime I tried the HDMI with my wide-screen TV, I took the Vostro there but had it running on its battery.    BINGO!..    The Power Option Plan switches from Nvidia to ATI when its unplugged to save power.

    So as soon as I plugged it into the wall, the screen went momentarily black and then came back with the HDMI Audio as a alternative option for sound output.

    Furthermore, I was able to go into the Control Panel > Power option and change to my own custom plan to force the laptop to stay with Nvidia even though its running on its battery.  Problem solved!

    Try it, good luck,

    Jim Calvert

     

     

  • Unfortunately Jim, that did not work for me. I kept the power plugged in and the same problem persisted.

     

    Is there anyone else out there that has this problem or may have been given a solution? When you have an extensive music collection and it's all digital, it's too bad you can't play it on your system. Sad

    You'd also think that Dell and IDT would come up with some sort of solution to this problem together, since IDT is also involved...

     

    Thanks to anyone that can help.

  • Have you tried changing the windows audio output settings ?

    You can choose the audio output device on the laptop. The detailed steps are in the links below.

    See if the steps at  fix no audio problem when connecting laptop to tv  works for you. Some more help about this problem can be found at connecting laptop to tv with hdmi port

  • Hi

    New to "posting" so hope I am doing it right.  I noticed this was a recent post and wondered if you could help.  Last night I downloaded a rental from iTunes and played it through my Dell Studio 1555 using a HDMI cable.  It worked great.  However, today I can not play music from my laptop.  Any suggestions?  I tried to change my default to the speakers but it didn't seem to work.  The HDMI device is working, but there is not movement on the speakers.

  • Oops, I just fixed my own problem.  I disabled the HDMI in the Sound options in the Control Panel.  Sorry for wasting anyone's time.  Have a great day.