SigmaTel Audio and Latitude D630


Laptop computer Forums (Audio, General Hardware, Video)

SigmaTel Audio and Latitude D630

This question is not answered

Ok, I'm remaking this topic because I posted it in the desktop section by accident.

I've searched the forums, and it seems the historic issue with SigmaTel is that it didn't have a "stereo mix" option for recording.

Well, I got the newest driver from Dell (the R171789 driver) and I have the option to record from the Stereo Mix. Unfortunately, recording doesn't seem to work very well with this driver at all.

For whatever reason, when I record I get audio for almost a second, then it fades to an almost un-registerable level. I just use SNDREC32 that comes with Windows, and the option is set to "Stereo Mix" in the Recording tab of the audio options. So... I click record, .....nothing. I click record and change the input to something else, then back to Stereo Mix and I get a second of audio that quickly fades to nothing in my recording.

As a side note: I've tried other recording programs, including MSN Video Chat, it always fades out. It happens with every program. Audacity, whatever. The sound starts when I start it and you can hear it in the recording, then it just fades away immediately. So... the problem is NOT my recording software.

Why is it doing this wonky fade thing? I've noticed it kind of does the same thing with the internal microphone, where white noise is quickly leveled out, but this is rediculous. I can't use Stereo Mix at all like this.

All Replies

    Stereo mix isn't for recording with the mic. Try recording streaming audio off the internet and see if it works.


    If it still fades out look at the recording volume control slider and see if it is moving down. The E1505/6400 models used to have a faulty noise gate that would cause such behavior. It was eventually fixed in a BIOS revision.

    Jim Coates -- 12 year forum member

  • Well, my problem has resolved itself.

    It's strange, after I installed the driver a new Windows Update showed up, the update wasn't named, but it claims to have something to do with Media Player... and now it works somehow...