Inspiron 1525 "Audio Device on High Definition Audio Bus" exclamation mark

Laptop

Laptop
Laptop computer Hardware and Software discussion

Inspiron 1525 "Audio Device on High Definition Audio Bus" exclamation mark

  • Hi All

     

    I have installed windows XP on my Inspiron 1525 using all drivers provided by dell at the driver download site.

    And still looking at the device manager shows an exclamation mark on the "Audio Device on High Definition Audio Bus" driver. :(

     

     

    If i change the view to "show hidden devices" i can see one more exclamation mark on the "serial" driver. :(

     

    I am not sure what i was doing wrong during the driver installtion.

     

    If someone run into the same issue, or have a good idea how to solve i will be happy to be informed.

     

    Thanks in advance

    glingglang.

  • These instructions are for a situation where an operating system has already been reinstalled and everything works except the audio driver will not install ... usually you get an error message, because the NSS and chipset drivers were not installed correctly and the audio chip on the motherboard is not recognized. In this situation "usually" a fresh install of the OS is not required, just re-installing the NSS and chipset correctly. If that doesn't work then a full reinstallation may be necessary.

    After you have performed an Operating System re-installation, install the audio driver following this order of installation:

    a. Install Dell Notebook System Software (on your downloads page expand the System Utilities category). Restart.

    b. Next install the Intel Mobile Chipset driver (expand the Chipset category). Restart.
    (Models with AMD cpu use the AMD processor driver.)

    c. Install the Sigmatel audio driver (expand the Audio category).

    Get these from the 1525 driver downloads page. When you get on the page use the dropdown box to select your Operating System.

    Sometimes there is still a problem with the installation at this point in XP. In that case check in the Device Manager for a "PCI Device" with a yellow question mark next to it, under the "System Devices" grouping. Hit 'update driver' it might find the driver.

    Jim

     

     

    Jim Coates -- senior forum member


  • also, install the MS KB888111 high definition audio hotfix if using WinXP SP1/SP2.  the hdaudbus.sys file (included in KB835221, KB888111 and XP SP3) is crucial for using HD Audio devices in WinXP on your inspiron 1525 laptop.  if that file is missing, hd audio devices won't work.

  • You can find the audio driver under c:\dell\drivers\R180043\HDMI.  The modem driver is out there too but in a different folder.  Hope this helps.

  • Hi, Did you found any solution for this. If so, can you please mail me the instructions to linksn@gmail.com

    Thanks in advance

    Regards

  • linksn
    Did you found any solution for this.

    Please describe the problem you are having -- you have no audio through the speakers and also none through the headphones?

    Tell us the model name of your laptop -- is it an Inspiron 1525?

    Tell us the name of your operating system.

    If you do have audio but have a mark on Audio Device on High Definition Audio Bus, you probably just have to update your graphics driver. That is because the graphics driver controls the HDMI audio and it is called Audio Device on High Definition Audio Bus or something very similar. If you think that is what you are seeing, go to the HDMI Audio FAQ for instruction on updating the graphics driver in an Inspiron 1525.

    Jim Coates -- senior forum member


  • Hi Thanks for the reply.

    Yes, it is Inspiron 1525. I have installed windows XP on my Inspiron 1525 using all drivers provided by dell at the driver download site.

    And still looking at the device manager shows an exclamation mark on the "Audio Device on High Definition Audio Bus" driver. :(

    If i change the view to "show hidden devices" i can see one more exclamation mark on the "serial" driver. :(

    Audio is fine. But when I connect to my tv with hdmi cable, audio and video is not transferring.

    Please suggest.

    Thanks in advance.

    Regards,

    Santhosh

  • linksn

    And still looking at the device manager shows an exclamation mark on the "Audio Device on High Definition Audio Bus" driver. :(

    If i change the view to "show hidden devices" i can see one more exclamation mark on the "serial" driver. :(

    Audio is fine. But when I connect to my tv with hdmi cable, audio and video is not transferring.

    Santhosh, you  need to update your graphics driver. Go to the HDMI Audio FAQ for instruction on updating the graphics driver in an Inspiron 1525. It says:

    "Look in the Device Manager and if you see "Audio device on high definition audio bus" with an exclamation mark, you need to update it. Right click on it and point the updater to the HDMI sub-folder in the Intel graphics card folder. The path will vary depending on the name of your graphics driver but should be something like:
    C:\dell\drivers\R******\HDMI

    The folder named R****** is where your graphics driver files are stored on the hard drive. The actual number varies depending on which version of the driver you have installed.  If you don't know then just download a copy of  the newest graphic (video) driver from your downloads page and make a note of the location on the hard drive to which the files are unzipped."

    Do that and read the other instructions in the FAQ about setting up HDMI.

    Jim Coates -- senior forum member