Choppy/Skipping Audio Workarounds

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Choppy/Skipping Audio Workarounds

This question is answered

 

Since February 2007 we have seen a tremendous increase in the number of posts from Dell computer owners complaining of chopping and skipping when playing audio. Forum members started working on these issues and produced a number of workaround solutions. Their "solutions" are not ideal because some of them entail disabling features, and oftentimes only reduce the problem, not eliminate it. But these workarounds have provided much relief to folks who have come to this forum looking for help that Dell was unable to provide. Because these workarounds were scattered around the Laptop Audio board I have assembled them here in one place, and tried to give credit to the forum members who posted them. There are 3 sections:

> Computers That Had Audio Noise Right Out of the Box

> Computers That Started Having Audio Noise Over Time

> Windows Media Player Skipping

 

 

 

**************************************************************************

**************************************************************************

 

Section 1

Computers That Had Audio Noise Right Out of the Box

 

Note: if you have a brand new laptop and are dissatisfied with the noise in the audio, there is a 21 day return policy that I suggest you take advantage of if the solutions below do not help. However the workaround solutions in this thread are only about noise, not about low volume or tinny sound.

 

> Wireless. The most common problem, particularly in Vista, is choppy/skipping audio when the wireless is turned on. This is easy to diagnose just by turning off the wireless. Press Fn+F2 on the keyboard, or turn off the wireless switch if your model has one. If the wireless is causing your audio problems then you will notice at least a partial improvement when the wireless is off. Sometimes switching to a different brand of wireless card can fix this.

(Forum member kakendle posted that there is a connection between the noises and the wireless on 2-26-07.)

 

> Disabling the 802.11a band. Some wireless card models still feature the "a" band. If turning off the wireless (Fn+F2) lessens the choppy/skipping on your computer then disabling the "a" band is often a permanent fix if your card has that band. I don't have a list of which models have the "a" band and which don't.

 

Go to Control Panel > Device Manager > expand Network Adapters > right click Dell Wireless (your model) > right click Properties > Advanced Tab > click "Disable Bands". In the drop-down list on the right labeled "Value" choose "Disable 802.11a". Click "OK".

 

On some models you select the "b/g" bands instead of disabling the "a" band. On some models updating to the latest driver fixes this problem.

(This workaround was posted in a different form on the "old" Laptop Audio FAQ page as FAQ #14.)

 

 

> Update Drivers. Most of the problems seemed to be caused by the wireless, video, and audio drivers being unable to work together properly. As the the manufacturers find solutions they are incorporated into the latest drivers, so it is a good idea to keep updated. Sometimes updating to the latest BIOS helps. To find most of these items go to the Dell Support/Drivers & Downloads page and either select your model & operating system or enter your Service Tag.

 For nVidia drivers go to:
http://laptopvideo2go.com or

http://www.laptopvideo2go.com/forum/index.php?showtopic=14644, or

http://www.x-drivers.com/catalog/drivers/video_cards/companies/nvidia/models/geforce_8_mobile_series/7386.html

 

> Vista Anti-Lag. This little utility program helps eliminate the wireless problem, but if the solutions above work then you don't need it. Forum member aleywwu explained it this way: "From what I understand, it somehow prevents your wireless card from looking for a new network every 3 seconds by 'optimizing' your card.  It's temporary, and you have to re-run it every time you restart your computer, but it has completely, albeit temporarily, solved my problem."

http://www.codecase.de/en/software/downloads/file/18-val-v1-1-1-setup

(Forum member poochkie posted the link to the program.)




> Power Settings: Inspiron 1501 and models with AMD Turon processor, change power plan to "Power Saver" or "High Performance" rather than "Balanced". You can do the power plan change at "Control panel > Power option". "High Performance" gives better results than "Power Saver" but drains the battery if not using the power adapter/charger. (Forum member Japan 2ch posted this tip on 4-10-07 and helped a bunch of 1501 owners.)

> Power Settings: Other models have similar options that you can try. Configure for maximum performance.

 

> nVidia Powermizer Setting: the Latitude D830 & E6400, Precision M4300 and other models should have the Powermizer turned off. "The setting is configurable via the NVidia Control Panel. You should be able to get to that via the appropriate icon on your Taskbar, via an option on the menu that appears when you right click on your desktop, or through your advanced display settings. The only option in the Mobile group is "Change Powermizer settings" and I disabled it there. I also adjusted my 3D settings for Peformance (as opposed to Quality) in the 3D settings group, as that was a recurrent, associated suggestion in posts about Powermizer problems."

(Forum member dml2912 posted this tip on 9-05-08.)

 

> Inspiron 1501 or Vostro 1000 computers with an ATi video card, go to this thread for a solution posted by forum member znalim.

 

> Studio Models with fingerprint readers can make clicking noises. Try updating to the latest driver. (Dell moderator Bill B posted this tip on 01-19-09.)

 

 

Other tips that helped a small number of people:

 

> Uninstall or Update the Dell Quickset Utility - you may wish to try uninstalling it as a test and reboot, and if that helps then update to the lastest version. (Forum member Groove75 posted this tip on 3-30-07.)



> Inspiron B130/1300  the A10 BIOS supposedly fixed intermittent pops or stutters while playing music.


> Set BIOS sound level to bypass: "I went into the BIOS and made sure that the HDD sound level was set to 'Bypass'. Usually, there are three options in the Dell BIOS's: Bypass, Quiet, and Performance. Even if your drive is set to 'Bypass', set it to 'Quiet', reboot into windows, and then set it back to 'Bypass'." (Forum member Geirskogul posted this tip.)


> New BIOS for XPS M1330, Vostro 1400, XPS M1730 (but reportedly does not help M1720 or M1710) install the newest version of BIOS and to cure crackling noise. (Forum member kingink posted this tip on 2-7-08.)


> Registry edit for M1330 and Inspiron 1720 with the nVidia 8400M GS video adapter. Open the Registry editor and navigate to

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Video\{**unique to you for nvidia**}\0000\

find PerfLevelSrc and change it from 0x3333 to 0x3332.  (Forum member stopgap posted this tip on 12-21-08.)


> Anitivirus. On a 1525 with Vista, forum member Oxceraniod found that crackling on his computer was caused by the PC-cillin Anti-Virus that came with it. The solution was to exit from the program on the taskbar. Another poster thought his AVG antivirus contributed to the problem.

> Configure for line-in. Plug a mic or headphones into the mic/line-in port on the laptop and when the pop-up box appears asking you how you would like to configure the port, choose Line-In. Doing so might resolve a problem with clicking, hissing, crackling and humming. (Forum member encrypter who has an XPS M1710 posted this tip on 8-24-07.)


> Install the generic Vista audio driver.  Although forum member rochs77 originally got some improvement by doing this, after he disabled the 802.11a band (see "wireless" above) he reverted back to the Sigmatel driver. Note: doing this will result in the loss of several important audio features.

First delete the audio driver files from your computer to ensure a clean new driver installation. Go to the "Add/Remove Programs" in the Control Panel and remove the current "Sigmatel" if it is there in the list of programs and restart the computer. (Vista users go to Computer> Uninstall or Change a Program.) Next go to the Dell folder on the hard drive, (c:\Dell\Drivers\R...Sigmatel driver file name).

"Each folder is labeled R-something and doesn't tell you what's inside it. You have to go into each, read the text file and figure out which are SigmaTel drivers. Delete all of those folders, because if you don't Vista will just find those same drivers again, reinstall them, and you'll be back to square one. Reboot your machine. When Vista boots up again it will tell you that your HD Sound Device is missing a driver and will search for one. Allow Vista to search on the computer and the internet for a driver and it will find one that is built in to Vista. It is called "Generic HD Driver" or something like that." -- posted by rochs77


> Lower Volume.  On an Inspiron 1520, maximum volume can cause skipping or freezing. Lower the volume level to below 80% of max and compensate by raising volume of external speakers.

(Forum member Eng.A7md posted this tip on 10-28-08.)


> Aero Theme. Deactivating this theme might result in less noise. (Forum member FrancoisH posted this tip on 2-2-08.)
Similarly, StereoHeathen got an improvement by ending the Desktop Window Manager (dwm.exe) which eliminated Aero.



 

 

****************************************************************************

****************************************************************************


Section 2

Computers That Started Having Audio Noise Over Time

 

 

> Updating the firmware for a TS-L462C Cd rom/burner to version DE07 chops up the audio when not playing a cd, because that firmware revision is defective. To diagnose, place a commercial music cd in the drive (not a homemade mp3 or data cd -- just use a store bought cd or a copy of one). If the problem lessens then read this thread for instructions. (Click on link.)

To see if you have a TS-L462C open Audio Properties (right click on the volume icon on the taskbar and click 'adjust audio properties', or go through the Control Panel/Sounds & Audio Devices Properties). Select the Hardware tab. Look for DVD/CDROM in the device column. The name of the drive should be there.



> Check for Ultra DMA mode. For several reasons the IDE hard drive or cd/dvd drive can stop operating in DMA mode and start using PIO mode. In PIO mode there can be crackling, popping and stuttering, and possibly generally sluggish performance. To check:

1. Go into the 'Device Manager' (in XP the path is: Start>Control Panel>System>Hardware>Device Manager).
2. Click the + sign next to 'IDE ATA/ATAPI controllers'.
3. Right click on 'Primary IDE Channel'.
4. Select 'Properties'.
5. Select the 'Advanced Settings' tab.
6. Check that the 'Current Transfer Mode' says Ultra DMA. If it says PIO then use the 'Transfer Mode' dropdown box to select for 'DMA if available'. If you can't make the change in the dropdown box then it must be done in the Registry. See the "Note" below.
7. Click 'Ok' to save your changes, or 'Cancel' to exit the Properties if you made no changes.
8. If the problem seems related to the optical drive (CD/DVD), right click on the 'Secondary IDE Channel' and repeat steps 4 through 7.

Note: If you get to step 6 and find you cannot make changes in the dropdown box, go to http://winhlp.com/node/10


They have a little script program to reset to DMA mode. Click on the link in their 1st step. (Note: you must use Internet Explorer for their vbs program to run -- it will not work using Firefox or other web browsers). Read the instructions in their steps 2-5 and then run their program. It makes edits to your Windows Registry to try to reset the drive(s) back to using DMA mode. If you want to know exactly what the program does, scroll down to "Re-enable DMA using the Registry Editor" for the full explanation.

The rest of their article describes the problem in great detail and discusses possible causes and solutions for it. You don't need to read the entire article unless running their program doesn't get your drives back into DMA mode.

(Forum member bacillus first posted this tip years ago in a basic form. Anne in Pennsylvannia found the link to http://winhlp.com/node/10.)



> Dell's PC Restore and Factory Image Restore. If your computer did not have any of the problems mentioned in this thread when it was brand new, then something has changed to cause the problem. In that case it might be easier for some people to return their computer to the exact condition it was in when new, instead of trying all of the possible fixes above. For others this should be regarded as only a last resort because it will wipe out any data and applications you have added and stored on the hard drive. In either case this will cure the problem -- but only on those computers that did not originally have the noise. If your computer did originally have the noise then it will still have it after you perform the restoration.

Dell's PC Restore for XP is an image of your original operating system in a hidden partition on the hard drive. It's like a normal reformat in that you have to save all of your data to removeable media, but it is different because it includes all of the original drivers, applications and configuration settings of the computer when it was new. Whatever was working when you got the computer will work after PC Restore, except for any hardware problems that have developed over time.

To use PC Restore you restart and press Ctrl + F11 during the restart process and it should take you to the "PC Restore" menu. Anything that doesn't work afterwards either wasn't working when the computer was shipped or is the result of hardware malfunction. For that reason PC Restore can serve as an excellent diagnostic tool for distinguishing between hardware and software problems.

On computers that were ordered with Vista preinstalled, Factory Image Restore does the same thing as PC Restore. To use it:

1. Restart the computer.
2. As the computer restarts, press F8 until the Advanced Boot Options menu appears.
3. Press <Down Arrow> to select "Repair Your Computer" and then press <Enter>.
4. Specify the language and then click Next.
5. Log in as a user who has administrative credentials, and then click OK.
6. Click Dell Factory Image Restore.
7. In the Dell Factory Image Restore window, click Next.
8. Select the Yes, reformat hard drive and restore system software to factory condition checkbox.
9. Click Next. The computer is restored to the default factory configuration.
10. When the restore operation is completed, click Finish to restart the computer.

Note: If your hard drive has been replaced or if you have ever wiped your original hard drive clean of all partitions, then you will no longer have the option to restore to factory condition. Once the restoration partition is gone there is no way to get it back.

 

 

 

 

**************************************************

**************************************************



Section 3

Windows Media Player Skipping

 



> Disable Enhancements. If you experience skipping near the end of a song while using Windows Media Player in Vista, the solution can be found in Audio FAQ #15. You have to check the box that is labeled "Disable all enhancements". Just shutting off the enhancements individually won't work. The obvious drawback is that you lose the enhancements.

(Forum member smittyofdhs posted this workaround on 2-20-07 and a moderator made it into a FAQ.)

 

 

Other tips that helped a small number of people:


> Disable Visualizations. You might get some improvement by disabling all visualizations under the Now Playing tab of Windows Media Player. (Forum member hovaslash posted this tip on 2-28-07.)

> Crossfading and Auto Volume Leveling. Along the same lines, you might get some improvement by disabling Crossfading and Auto Volume Leveling.
(Forum member wewake17 posted this tip on 4-12-07.)

> Lightfx Plugins. Similarly, tech support suggested removing the lightfx plugins completely.
(Reported by forum member fhwfhi on 2-13-08.)

Jim Coates -- senior forum member


All Replies
  • Please do not reply in this thread which is a FAQ.

    If you have comments or questions please start a new thread.

    Thanks, I appreciate it.

    Jim Coates -- senior forum member


  • Message deleted by jimco

    Jim Coates -- senior forum member


  • Thanks for compiling these.
    Message Edited by jakew8 on 08-17-2008 11:22 PM
  • You are welcome and welcome to the forum. I would appreciate it if replies to this thread were limited to additional solutions or corrections of my facts, but if you want to start a new thread I will be glad to participate.  To start a new thread click  "New Message" on the Laptop-Audio main page. Thank you.

     

    Jim Coates -- senior forum member


  • Hi. I think the choppy/skipping sounds on my comupter occurs when the wireless netwrok is activated. unluckily for me the workaround link for that isn't working anymore. Is it possible to get it working somehow, or maybe anyone could explain to me what I need to do? =) thanks

  • Edits to this thread on 11-16-08

     

    1. Tog1988, I couldn't fix the broken kink to AudioFAQ #14 so I have put the instructions for disabling the "a" band in the text, under the "Wireless" paragraph.

    2. Added a tip about disabling Powermizer.

    3. Added a tip about lowering the volume.

     

    I would appreciate it if replies to this thread were limited to additional solutions or corrections of my facts. Please start a new thread for questions specific to your computer or situation. Thanks.

     

     

    Jim Coates -- senior forum member


  • <original post - removed>

    OMG...really?

    I though I provided valuable info for community members looking for answers on this subject. For example, *I tested the system latency (using DPC Latency Checker V1.1.0 - www.thesycon.de) and see the system latency is very bad and this directly coincides with the Choppy/Stuttering/Clicking audio issue seen by certain Dell PC's and Laptops...... I guess I was wrong. They'll just have to look through the threads spread all over this board to compile information, possible solutions and feedback for this particular topic.

    I'm going to voluntarily revoke my posting privileges in Dell's Community Forums.

     


    Dell Studio XPS 1640 - Windows Vista Ultimate x64 SP1

    Dell Latitude E6500 - Windows Vista Business SP1

    Dell Latitude D620 - Windows XP (32-bit) SP3

    Dell Latitude D800 - Windows XP (32-bit) SP3

  • I would appreciate it if replies to this thread were limited to additional solutions or corrections of my facts. I will edit my posts to include solutions that I have left out. There is an earlier thread where most of these solutions were worked out, named "popping/skipping of ripped files". After it had reached 46 pages and 458 posts our moderator, Chris_B, closed it to new posts and wrote:

    "If you are having audio issues with your system, please post a *new* thread to include system type, OS and description of symptoms you are seeing. This will allow for a quicker resolution from board members and help isolate any unique issues that are encountered." (Posted by DELL-Chris_B on 6-3-08.)

    I plan to respect his request by not answering questions relating to specific problems in this thread. Please start a new thread for questions specific to your computer or situation. To start one, go to the Laptop Audio main page and click on 'Start a New Thread". Thanks.

    Jim Coates -- senior forum member


  • Hi Jim.

     

    Thanks for the informative and updated "audio problems" guide.Yes

    I don't know if you remember me, but I posted about a solution using an older firmware version for the tsl-462c cdrw/dvd drive.

    Which seemed to worked for most people here based on the number of hits, but my sound is still pop intermittently.

    I have a Inspiron B130 running Windows XP sp3.

    I've updated all drivers, bios, and firmware ... except for the ts-462c Wink .... and it still happens.

    I just tried the following workarounds ....

     

    jimco

    > Wireless. The most common problem, particularly in Vista, is choppy/skipping audio when the wireless is turned on. This is easy to diagnose by just turning off the wireless. Press Fn+F2 on the keyboard, or turn off the wireless switch if your model has one. If the wireless is causing your audio problems then you will notice at least a partial improvement when the wireless is off. Sometimes switching to a different brand of wireless card can fix this.

    (Forum member kakendle posted that there is a connection between the noises and the wireless on 2-26-07.)

     

    > Disabling the 802.11a band. Some wireless card models still feature the "a" band. If turning off the wireless (Fn+F2) lessens the choppy/skipping on your computer then disabling the "a" band is often a permanent fix if your card has that band. I don't have a list of which models have the "a" band and which don't.

     

    Go to Control Panel > Device Manager > expand Network Adapters > right click Dell Wireless (your model) > right click Properties > Advanced Tab > click "Disable Bands". In the drop-down list on the right labeled "Value" choose "Disable 802.11a". Click "OK".

    (This workaround was posted in a different form on the "old" Laptop Audio FAQ page as FAQ #14.)

     

    I disabled the "a" band, and the problem still persists, but when I disable the wireless card ...

    Dell Wireless 1470 Dual Band WLAN mini-pci card

     .... then the sound is perfect.

    Disabling the wireless card every time I want to listen to music is not a practical solution.

    Dell has posted no newer drivers for this card in the past year, but I noticed on several Drivers Websites newer drivers for this card.

    Do you think that installing these will work or harm the wireless card ... or should I just go out and by a new wireless network card????

     

    Thanks, Ed

     

     

  • Ed,

     

    Please start a new thread and I will be happy to reply. Thanks.

    Jim Coates -- senior forum member


  • As the band off "to" wireless card in 1397? there is no such option "off band" can someone help me? thanks
  • Please start a new thread for questions specific to your computer or situation. To start one, go to the Laptop Audio main page and click on 'Start a New Thread". Thanks.

    Jim Coates -- senior forum member