Dell Latitude D610 Sound

Laptop

Laptop
Laptop computer Hardware and Software discussion

Dell Latitude D610 Sound

  • If a headset is used there is sound. No sound from internal speakers. Volume is turned on.

    Is there anyway to check where the problem could be without taking the computer apart?

    Thanks.      Paul

  • Paul,

     

    Try reinstalling the Sigmatel audio driver, or delete it and download a new version.

     

    If that doesn't help run the audio test in Dell Diagnostics to determine whether it is a software or hardware problem.  

     


     

    To run Diagnostics restart the computer and as soon as it starts to boot up hold down f12. Select 'Diagnostic' from the boot menu. The computer will run its pre-boot assessment tests for 3 or 4 minutes before the Dell Diagnostic starts. These pre-boot tests play some beeps and tones through the system speaker but this doesn't test the rest of the audio hardware adequately, so you still need to let Dell Diagnostics run after the pre-boot tests finish. Dell Diagnostics plays an instrumental piece of music complete with drums, so if you only hear some tones then you have only run the pre-boot assessment test.

    When Dell Diagnostics opens, select 'custom', then the audio test. This will test your audio system independently of Windows and drivers, meaning it doesn't matter if they are working correctly or not.


    [If you have ever reformatted your hard drive then the Diagnostics partition might have been wiped off. If the Dell Diagnostics option fails to open, run it from the Drivers and Utilities (Resource) CD if you have one.]

    Dell Diagnostics will play some audio and ask you whether you heard it. If you don't hear the music during the test it definitely means there is a hardware failure somewhere in the system.

    If you do hear the audio that means the hardware is okay but there is a problem with the software or configuration.


     

     

    BUT if you have the following combination of symptoms there is another explanation:

        * Speakers don't work
        * Headphone jack does work
        * Reinstalling audio driver does not help
        * Audio test in Dell Diagnostics passes


    The Dell laptops like yours with a Sigmatel 92xx audio chip utilize IDT's Universal Jacks technology, which is somewhat complicated. In addition to the usual mechanical parts, the jack also uses current & impedance-sensing techniques to trigger software configuration and switching (to send the audio signal to the speakers). So there are three areas of potential failure: mechanical, electronic, and software. Sometimes, a little very gentle wiggle of a plug in the jack will get it to resume normal functioning, at least temporarily. There is a sensing pin in the jack (Sense_A pin) that is used to detect the presence of plugs and it can be the cause of failure to trigger the software switching.

    Normally the audio test in Dell Diagnostics would confirm that there is a hardware problem, but the Universal Jacks can cause a false positive result in Diagnostics. That is because Diagnostics operates in DOS, outside of Windows, so a Windows software misconfiguration is irrelevant to the test even though in this case it is caused by hardware. So the audio test can pass in Diagnostics, correctly signaling that software configuration is the immediate cause of the problem, but missing that a hardware problem, the bad jack or sensing pin, is the root cause. In these instances the only reliable diagnostic procedures are to try a new motherboard or to use PC Restore (called Factory Image Restore in Vista) to restore the computer to its original configuration as shipped from the factory. If the speakers still don't work after PC/Factory Image Restore then there is definitely a hardware problem even if it passes the normally infallible Dell Diagnostic audio test.


    Jim
     

    Jim Coates -- senior forum member


  • Jim Thanks for your info, I tried removing the audio drivers and when that failed to solve the problem I ran the diagnostic test.   When it reached the section asking if I heard any sound I replied no. This was listed as Intel CH6 Audio sound play. I was then given an error code to give technical support it was 1B22:061B.

    I'm out of warranty any idea what that code represents and what can be done if anything to correct it ?

    Thanks Paul

  • Paul, the test is interactive. The code 1B22:061B means that when asked if you heard the audio you answered no.

     

    Failure of the test confirms that you have a hardware failure. Because you do have audio from the hp jack you know that the audio chip works and audio gets as far as the jack, but is not passed on to the speakers. The fault could be in the jack itself or the wires to the speakers could be loose. In your model there is a simple mechanical switch in the hp jack and no switching software. When you insert the plug into the jack the plug pushes apart the spring contacts and breaks the connection to the speakers. When you pull out the plug the contacts should spring back together. If this fails to happen due to a misaligned contact for example, you won't hear sound from the internal speakers. The jack is not replaceable.

     

    As far as loose wires you can remove the keyboard to check. Reseat the cable on the motherboard. If you need help use the link on the left of this page to Support Tools/manuals to view or download a service manual.

     

    Jim 

    Jim Coates -- senior forum member