Fix for sigmatel full duplex audio

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Fix for sigmatel full duplex audio

  • Folks,

    My Latitude D520 came with the ability to monitor the input jack turned off. This means I can't hear an audio signal routed through the mic or line-in jack even though the mic in and headphone out jacks work fine individually.

    I called Dell support and they had no solution. The sigmatel hardware is capable of full duplex behavior, but the the driver does not allow for it. There is a registry hack for Inspirons to turn full duplex on; I haven't tried that on Latitude.

    I found a solution that did not involve registry changes. Other vendors use the same chipset and don't limit the full duplex feature in their drivers, so installing a different vendor's driver can work.

    I found a reference to an LG driver - I installed that and now full duplex works. I now have an "Input Monitor" option on the Playback volume control, and when this is unmuted, the mic jack input audio is blended into the output audio.

    I'm reprinting the article's content here in case it goes away in the future. The specific file I used was labeled "[Sound/2000/XP] SigmaTel Sound Driver Ver 5.10.0.4866 XNOTE(LE50)".

    ------- from http://www.ekhoury.com/2006/08/25/sigmatel-stereo-mix-support-for-dells/

    I have a Dell Inspiron 6400 E1505 Laptop! and as a music composer I wanted to sample some midi into wave audio. So, I needed the “Stereo Mix” / “Record What you head” / “Waveout mix”.

    Too bad that Dell’s sigmatel driver does not support this feature! but I found a way to fix this issue. All you need to do is install LG’s drivers for Sigmatel… They’re working like charm here ;)

    Instructions:

    * Follow this link: http://us.lgservice.com/
    * Click on: Product Support
    * Go to: Device Driver
    * In product, select “Notebook”
    * Search for “Sigmatel”
    * The download the result

    Once the download is done, unzip that folder and open Setup.exe! just follow the instructions… It will ask you to restart your PC… and BINGO!! Solved :D

    If you find this article useful, consider making a small donation:
    ---------

    Message Edited by dmmst19 on 03-22-2007 08:31 PM
  • I followed all the steps and downloaded the lg driver. When I go to download, I get all the way to reboot the system. So I reboot and as it is progressing, I then get an error stating The system does not support the driver you are attempting to install. What do I do now?
  • I tried installing the SigmaTel drivers from the LG website.  It was a very laborious process and required a few reboots before my Inspiron E1505 recognized the new driver.  Now, I do get an input on whatever is playing thru the speakers.  I can now record it using the onboard Windows sound recorder.  However, the audio quality is now absolutely horrible.  Lots of crackles and distortion.

     

    I find it amazing that such a neat looking and well designed laptop doesn’t have the ability to record onboard audio that is playing thru a cd or an audio stream, etc…

     

  • If you want to use the Dell drivers,download the R122161.exe and run it to install the files to \Dell\Drivers directory.
     
    You will need to determine the .ini file used for your setup by opening the System Control Pannel, select the Hardware tab, click on "Device Manager", expand "Sound, video and game contollers", Double Click "SigmaTel High Definition Audio CODEC" to bring up the properties window, select the Details tab. Under that tab you will find the FUNC-VEN-DEV-SUBSYS numbers. 
     
    Now open \Dell\Drivers\R122161\WDM\Sthda.ini and match the numbers to find the .INI file after the "=".
     
    Edit the .INI file in the \Dell\Drivers\R122161\WDM directory using notepad. I modified the 92XXM2-3.INI (your system might use one of the other .ini) file for my system and changed
     
    EnableInputMonitor    =  hex: 1
     
    and added the folowing:
     
    DigitalInputMonitor   =  hex: 1
    DigitalStereoMix      =  hex: 1
     
    So the section of the original file read:
    ...
    EnabledPcmCaptureBitsAndRates = dword: 0xfffffffe
    EnableInputMonitor      = hex: 0
    KeepAdcAlwaysOn         = hex: 0
    EnableHwSpeakerConfigurationSupport = hex: 0
    EnableIntSpkrMute = hex: 1
    GpioForSpdifMuteControl = hex: 1
    TurnBiasOffOnNotSelectedPin = hex: 1
    [HKR\Settings\gpio]
    ...
    now reads:
    ...
    EnabledPcmCaptureBitsAndRates = dword: 0xfffffffe
    EnableInputMonitor      = hex: 1
    KeepAdcAlwaysOn         = hex: 0
    EnableHwSpeakerConfigurationSupport = hex: 0
    EnableIntSpkrMute = hex: 1
    GpioForSpdifMuteControl = hex: 1
    TurnBiasOffOnNotSelectedPin = hex: 1
    DigitalInputMonitor     = hex: 1
    DigitalStereoMix = hex: 1
    [HKR\Settings\gpio]
    ...
     
    Just run the setup.exe file in the top directory (R122161) and you should have the "Stereo Mix" under recording devices and "Input Monitor" under playback devices.
     
    You do not need to reboot.
     
    Here is an aditional reference releted to the 92xxM2-2.INI file: http://www.togeo.com/togeo/wordpress/?p=38