How to disable Internal Speakers on a Dell Latitude D620

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

How to disable Internal Speakers on a Dell Latitude D620

  • good day folks..

    Does anyone can help me ? I need to disable internal speakers on a Dell Latitude D620. I tried everything but I cannot find any way to turn it off. In the office, it makes from time to time a very loud noise and disturbing everyone around.
     
    I updated the bios to the latest version A7 thinking there will be an option in there but found nothing.
     
    again, it is a Dell Latitude D620, Model PP18L
     
    Thanks
     
    Denis
     
     
  • Did you try going to the mixer and muting the audio? That should do it. Or you can set the volume down to zero (or to a more reasonable level).

    If you really want to totally kill the audio, you can go into the Device Manager and disable the sound devices (I haven't tried this, but it should work).

    Peter
  • Thanks for the info..
     
    I tried to mute the sound but it didn't work. But as you said, in Device manager, I tried to disable the Internal Speakers and it didn't work either.
     
    Finally, I verified the hidden devices and this time, I disabled the "beep" and it worked..
     
    Thanks again
     
     
  • Make a right-click on the desktop icon "My Computer", then click "Manage".

    Click on "Device Manager". Click on "View"-Menu then "Show hidden Devices".

    Click on "Non-Plug and Play Drivers". Then make a right-click on "Beep" and choose "disable".

    After, you must reboot your notebook. Then a have no more beep.

  • Many thanks.
     
    It fixed the problem !!!
     
    Thanks again
     
     
     
  • This loud noise you speak of --was it by any chance a really loud popping or static-type noise, at random intervals, sometimes very loud, and completely unaffected by mixer volume? Also, did it come out of the system speaker even when headphones were plugged in?

    I'm about to throw my D620 out the window because I literally can no longer use it because of the horrible noises it is making. It has gotten progressively worse, to the point that I can no longer bring it to class.

    I'll have to blacklist the pcspkr kernel module and see if it stops. I've actually heard the sounds while still at the POST screen so I'm doubtful.