Sigmatel Headphone Hiss

Laptop

Laptop
Laptop computer Hardware and Software discussion

Sigmatel Headphone Hiss

  • I've found a possible solution to the hissing problem while still using the Sigmatel drivers.  I've done a little hacking in the registry while trying to find a solution to another problem on the Latitude D610 and I've happened across settings for PCM preamp settings.  I'm just working on the best settings and will post my findings here when I'm done.
  • If you do a search for PCMVolumeFixedLevel in the registry, you will find 2 values in Hexadecimal. Set both values to 10 and either disable and re-enable your sound drivers or reboot. The hissing is significantly reduced. You can play with the settings to find the best for yourself but remember it's in Hex.

    For those who don't know what Hex is, the numbers up to h20 (32 Decimal) follow:

    01 02 03 04 05 06 07 08 09 0a 0b 0c 0d 0e 0f 10 11 12 13 14 15 16 17 18 19 1a 1b 1c 1d 1e 1f 20 etc

    This will affect the volume of the laptop's internal speakers so you might want to play around with the settings until you find a compromise you're happy with.

    Also, if you have the CD Volume enabled in your sound mixer, it's best to mute it. I don't think players like Media Player use it anyway. Just in case you can always go and set the cdrom drive to use digital sound anyway.

    Danny