Srs Premium Sound - Problem. - Audio - Laptop - Dell Community

Srs Premium Sound - Problem.


Laptop computer Forums (Audio, General Hardware, Video)

Srs Premium Sound - Problem.

This question is not answered


I've got a problem with audio drivers on my laptop.

Dell Inspiron  N5110 (Q15R) (Windows 7  64-bit)

Intel Core i7-2670QM CPU  2.20Ghz

Dell Inc. - 0HVRTT  (0 or O)   v.A09

Nvidia GeForce GT 525M (1GB)

6GB Ram


IDT High Definition Audio Codec

Bluetooth Audio

Computer is virus free.

Everything was working well till sunday. Then my microphone stopped working, and my Srs Premium Sound turned off.

I didn't made any changes, didn't installed any new drivers or updates, it happend without my participation.

When I turn on Srs Premium Sound in "Dell Audio by IDT" pannel, and I set it, when I close the pannel settings goes off.

I was searching for some Srs Premium Sound drivers, but Dell support only those drivers for Vista 32bit or Windows XP, not for Windows 7.

I decided to let it be, but working microphone is necessary for me.

I noticed that in control pannel, in audio settings of my microphone that two things was marked "Let applications take control over this device" and "Let applications take control over this device". Now when I mark them, I click apply, this pannel closes, but when I open it it's still not marked. Same like with Srs Premium sound. Any changes which I do and apply, are not done.

I tried to install new IDT drivers from Dell site, which are recommendd for my laptop in hope to make my microphone working again but after this I lose sound [with errors: cant find speakers and headphones/audio device is turned off (when I check it in services it's written that it's runned and working)/no audio device <-- one of those], and microphone is still not working and srs plug in still is turning off.

Then I can't do anything, doesn't matter what drivers I install, still the same, and I have to restore system just to get sound for now. ( I don't have restore point when everything was working well, just when the only sound works).

I tried installing and uninstalling many drivers, cleaning registry, checking services, changing registry, changing settings, but still nothing.

Could anyone from Dell Support help me? 
I don't want to reinstall the system, that's why I made this topic here. 

All Replies
  • I am sorry to read that you are having this problem.  One thing that you may try if you haven't already is to completely uninstall the audio drivers for the system.  Click start, control panel and programs and features and look for the IDT software and uninstall it.  Restart the notebook.

    Download the newest IDT drivers from the following link and install them.

    Once you have removed the old drivers and installed the new drivers check the microphone.  Just right click on the speaker icon on the task bar and choose recording devices.   How many devices are listed? You may see something like Microphone Array, IDT High Definition Audio Codec.  Make sure that this is the default device. Right click it and check set as default device. Click the configure button and then click the link for Set up Microphone. Follow the screen directions, when you are at the speaking section it should have a meter that will tell you if it detects sound.  This should tell you if the microphone is working or not.

    With the new driver installed please let me know if you now have the option for SDS.


    Specialize in Laptops, Mobile Devices

  • Really thank you for answer.

    I didn't expect it that fast.

    When only sound was working, before I applied to your commands I made a screen:

    (Just microphone wasn't working and SRS Premium Sound was turning off automaticly when I was turning it on)

    And I also made screen after I did exactly everything what you told me to do (version of those newest drivers installed

    (Sound not working, microphone not working, SRS Premium sound - TURNED ON)

    What I'm supposed to do now?

    By the way, I can't check if my microphone is working this way (I use Windows Sound Recorder to check if microphone works).

    This configuration button from microphone settings showes exactly the same when I click configuration near speakers/headphones.
    Only one thing appears "Configure to work with speech recognition", and then I'm allowed to set how fast computer speaker has to speak, nothing more.

    I'm waiting for new instructions.

  • Drivers I had installed"

    First screen: drivers 1.0.6324.0.  (Sound works, microphone doesn't work, Srs premium sound doesn't work)

    After installing those drivers from the link you gave me:

    Second screen: drivers 1.0.6365.0 (Sound doesn't work, microphone doesn't work, Srs premium sound works)

    I don't know, maybe that's something with those updates of those drivers?

    Maybe that will be helpful in finding solution.

  • Disconnect any other external speakers, head sets, and microphones from the computer.  Try to get the only sound devices to be the integrated speakers and sound card.   Restart the notebook and check the integrated microphone and speakers.   Since this all happened Sunday, do you remember installing any devices, software up updates then? Can you think of anything that you may have added to the notebook just prior to having the sound problem?


    Specialize in Laptops, Mobile Devices

  • As I said before. 

    I didn't installed any new drivers or anything, and I have no idea what happend.

    I tried everything you told me to do, still nothing.

    But i'm almost sure it's about this:

    When I click "restore default" in the microphone settings it marks two things:

    1 - "Let other applications for taking control over this device" 

    2 - "Give priority to applications in exclusive mode"

    But I have to apply it.  I apply and click "Ok", but it doesn't save, Like it should but It doesn't. 

    Doesn't work even if I mark one of those two options. I apply it, no erros, but it's not saving. 

    Before, when my microphone was working, I'm 100% sure that those 2 options were marked, and that's the only one thing which looks diffrent since then, which I remember.

    Any idea?

  • Refresh.

  • So?

  • Hello, I am also experiencing a similar problem. My microphone is not working. My computer should have SrS premium sounds installed, however i can not seem to find it when I search. I have tried to install it, but when try the 32-bit, it says i need the 64. When I try the 64 it claims my computer to not be authorised for such installation. I have tried to install the link you provided above,  but once again i am not authorised. I have an Inspiron 1764, service tag -  <ADMIN NOTE: Service tag removed per privacy policy>. Any advice?

    Kind regards,


  • please help

  • Hi, you helped my Bluetooth problem. I was pairing my Bluetooth speakers but the sound was still coming out of computer.  I did the right click thing on my volume icon and got it to come out of my Bluetooth speaker.  Thank you, I know you weren't helping me but you did.  I've tried multiple times to try and figure out why no sound was coming out of speaker when it said it was connected to Bluetooth.

    Thanks again,