Stereo mix on Vostro Windows 7

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Stereo mix on Vostro Windows 7

This question has been answered by jimco

Hello,

I have a Vostro 3550 running Windws 7 64bit.

The stereo mix option is not available in the settings for the sound card. I've updated the drivers from the Dell website but no difference.

In the recording settings the IDT High Definition Audio CODEC is marked as 'unavailable'.  

Is there any solution?

Thanks in advance

Verified Answer
  • Bob755
    Im actually trying to find a solution equivalent to stereo mix for recording audio streams.

    Rec.Playback will record streams. You can only have one recording source at a time, so make sure nothing else is the default source including mics. If it still is unavailable right click and look in "show disabled devices" to see if it is disabled.

    Jim Coates -- 12 year forum member

All Replies
  • Bob755
    The stereo mix option is not available in the settings for the sound card.

    Hello. IDT does not have "stereo mix". Only Sigmatel and Realtek have that recording source. Some of the IDT drivers have a similar function called Rec. Playback.  On the Sounds properties it would look like this:

    On the IDT Control panel it looks like this:

    Bob755
    In the recording settings the IDT High Definition Audio CODEC is marked as 'unavailable'.  

    I don't know what you mean by the codec is unavailable. If you don't see the word "IDT" on the Sounds properties that means that the IDT driver is not installed.

    Jim Coates -- 12 year forum member

  • jimco
    I don't know what you mean by the codec is unavailable.

    Okay, I see what happened. You saw on the screen the words "X Device IDT High Definition Audio CODEC Currently unavailable", but you left out which device is unavailable, making it look like the codec (the IDT audio hardware on the motherboard) is unavailable.

    Which device is unavailable?

    Jim Coates -- 12 year forum member

  • Sorry. I didn't indicate which device is marked as unavailable because I have a French version of Windows. It probably translates to something like 'Recording.Playback'. There is an icone of a sound card. The driver appears to be installed. I did see it change to 'ready' (or something lile that) but only for a few seconds.

    Im actually trying to find a solution equivalent to stereo mix for recording audio streams.

  • OK I just saw your earlier post with a screen shot. That's exactly what I have

  • Bob755
    Im actually trying to find a solution equivalent to stereo mix for recording audio streams.

    Rec.Playback will record streams. You can only have one recording source at a time, so make sure nothing else is the default source including mics. If it still is unavailable right click and look in "show disabled devices" to see if it is disabled.

    Jim Coates -- 12 year forum member

  • OK, I just made it the default source and I can now record streams.  Thanks for help.

  • im look for new stereo mix file  

  • dell 1505
    im look for new stereo mix file  

    Hello. You have to tell us the full model name of your laptop and the name of your operating system for us to be able to help you.

    Jim Coates -- 12 year forum member

  • Hy respected sir.

    i have Dell Vostro 2520 laptop. i want to use mic & stereo same time . how i can use this please help me. & reply my email address.please

  • zainsaahil
    i want to use mic & stereo same time .

    Hello. Please re-phrase your question. Please describe exactly what you want to do. Your phrase "use mic & stereo same time" is difficult to understand. Thank you.

    Jim Coates -- 12 year forum member

  • Hy. Sir my question is that. i have dell laptop model vostro 2520. i want to use in chat room stereo with mic for Hosting matches on beyluxe. i tryied my best *** i can,t able to solve this problem. so please tell me how use these both on my lapi.

  • zainsaahil
    i want to use in chat room stereo with mic

    Hello. The Vostro 2520  laptop has a Cirrus Logic CS4213D codec (audio chip). Very few Dells have that chip and I don't have much information about it or its driver, but as far as I have been able to determine the CS4213D does not have stereo mix.

    Here is a workaround that involves some external hardware.

    Connect the headphone port to the mic port with a cable. That does the same thing as basic stereo mix. To hear through the speakers, open the Sound properties (Control Panel>Sound), select the Recording tab, and make the external mic the default device. Right click on the external mic and select properties. Select the Listen tab. Check the box to "Listen to this device."

    To connect headphones, get a splitter cable (a "Y" cable).

    If you want to add an external mic, connect the headphone port to a little hardware mixer. Connect a mic to the mixer. Send the combined signal to the laptop's mic port.

    Jim Coates -- 12 year forum member

  • im useing dell vostro1015 stereo mix supporting dell vostro or not?

  • nazrul abedin
    im useing dell vostro1015 stereo mix supporting dell vostro or not?

    Hello. The Vostro 1015 model has Conexant audio, which is an odd one as far as stereo mix. Stereo mix is missing by default, but there is a hack of the Conexant driver available to implement stereo mix at

    http://forums.toshiba.com/t5/Audio-Sound/How-get-Stereo-Mix-on-Conexant-sound-card-SOLUTION/td-p/174656

    Go to the 1st page of that thread and scroll way down to the 15th post. The poster's name is AcrUsr and he found the hack. Keep reading that thread for more details from AcrUsr and screen shots.

    After you perform the hack and reboot, you may need to enable the stereo mix device. To do so, right click on the speaker icon in the system tray in the lower right hand corner of the screen,  and click "Recording Devices" In the box that shows up, right click in the white area and left-click "Show Disabled Devices"  If stereo mix wasn't there before, it should be now.  If it says it is disabled, right-click on it and left-click on Enable.

    A few Dell owners have tried the hack and the results are mixed. Works for some but not for others. An owner named SeanieOS with an Inspiron 7520 tried the hack but was getting error messages. He finally got it to work and wrote up directions which I have pasted in below.

    =====================================================================
    SeanieOS's Solution:

    Ensure you have the Conexant SmartAudio HD driver installed. You should see it under Sound, Video and Game Controllers in Device Manager. With the Conexant driver already installed and working the key is finding the exact location of the driver file. It might vary from one computer to another and also be called something else. Mine was called chdrt.inf and it was located in: C:\Windows\System32\DriverStore\FileRepository\chdrt.inf_amd64_neutral_fa34defac299c440

    If you are not sure where your .inf file is located you could do a windows search for text in files of the string: EpSettings\StereoMixEnable. It will most likely be a file with the extension .inf and be located in a sub folder of the System32 folder.

    Right click on the .inf filename and select "Open With" then choose Notepad. Hit Control+F then search for StereoMix to find the three lines:

    ;HKR,%EPattributePath%\EpSettings\StereoMixEnable,Enable,1,01

    ;HKR,%EPattributePath%\EpSettings\StereoMixEnable,MixAssocSeq,1,E0,E0

    ;HKR,%EPattributePath%\EpSettings\StereoMixEnable,MuteGainSettings,1,00,00

    Delete the semi-colons -->; and save the file. However Windows won't let you save the .inf file unless you change the files permissions. This gets complicated and a bit dangerous!

    Basically right click on the .inf and then click these tabs/buttons.. Properties> Security>Advanced>Owner. The current owner should be TrustedInstaller. Change this to an account on your computer that has Administrator rights and you can log in as. So Click on Edit and in the "Change Owner To:" field there should be an entry there such as: Administrators (Your computer name\Administrators) so choose that then Ok and apply and Ok to close out all the dialog boxes.

    Now right click on the .inf file again: Properties>Security>Edit>Select "Everyone" in "Group or User Names">Select checkbox for "Write" in the "Permissions for Everyone" section>Hit Apply and OK your way to close all the dialog boxes. Now you can save the .inf file you deleted the semi-colons from!

    This step is VERY important. You must change back the permissions to the way they were. Right click on the .inf and as before change the Write permission by deselecting the checkbox for "Write" and also then change the Ownership of the .inf file back to TrustedInstaller. This time you go Owner>Edit>Other Users or Groups and type in NT SERVICE\TrustedInstaller in the box and hit Check Names then Ok and Apply your way out of the dialog boxes.

    Now finally re-install the driver: Here I got problems with the driver not being recognised and possibly it was because Windows 7 64 bit was saying it is not digitally signed so here's what I did: Start Menu>Right click Command Prompt>Run as administrator>type in this command and hit enter... bcdedit /set nointegritychecks ON.

    To install the driver: Device Manager>Sound, Video and Game Controllers>Right click on Conexant SmartAudio HD>Update Driver Software>Browse my computer for driver software>Let me pick from a list..>Have Disk>Browse>Now in here you need to find the location of the .inf file you just edited, in my case I pasted in the path to the folder and hit enter then selected the chrdt.inf file and hit OK. When it was installed I went back to the command line as before and ran the command: bcdedit /set nointegritychecks OFF

    Now I rebooted the computer and this time Stereo Mix DID show up in Control Panel > Sound > Recording Tab after right clicking on empty space and selecting Show Disabled and Show Disconnected Devices.


    Jim Coates -- 12 year forum member