HDMI Audio FAQ

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

HDMI Audio FAQ

This question is answered

l. General Instructions for Setting Up HDMI Audio

Preliminary steps:

1. Plug the laptop into a power source. Some of the models have a power management scheme that will not allow for HDMI audio while running on batteries. Later, after you get your HDMI audio working, if you find that it still does not work on batteries you can change your power management settings in the Control Panel.

2. HDMI has its own audio driver separate from the audio driver. HDMI audio is incorporated into the graphics card's driver so make sure you have the newest version of your graphics card driver. On models with Intel graphics the HDMI audio driver will appear in the Device Manager as "Audio Device on High Definition Audio Bus" or "Intel Display Audio".

3. Turn off the computer and TV before connecting the HDMI cable. Later, after you get your HDMI audio working, if you disconnect the cable while the computer is running and lose your audio, try closing and then re-opening whichever program you were using that generates audio.

4. Every time you try a different solution you should reboot the computer. HDMI audio is extremely finicky and seems to usually need a reboot.

Make the Connection:

1. Connect the HDMI cable to the computer and TV.  If the TV has a "DVI/HDMI" port do not use it. Use a port for HDMI only.

2. Turn on the TV and select the HDMI port you are using. Adjust the TV settings to receive HDMI audio if any.

3. Turn on the computer. (Optional, some people close the laptop lid immediately after hitting the power button but I am not sure why. Most people should not need to do this.)

4. Optional. Some models do better if the TV is set to be the primary display. To set, repeatedly press Fn+F8 (or ctrl+alt+F4) to cycle through the settings (laptop display only -- laptop + TV --  TV only). Reboot the laptop.

5. Go to Start>Control Panel>Sound>Playback tab. Make "HDMI" the default device. If "HDMI" is not there, right click in the white area and look under "Show Disconnected Devices" or "Show Disabled Devices" and see if it is there. (This applies only to Vista & 7.  XP does not have "show disconnected devices". )



Post Connection Problems:

1. If there is still no option to select "HDMI' as the default audio playback device, try re-installing or updating the graphics driver, or even try an older version. The graphics driver is the driver for HDMI audio, not the regular audio driver. A few people with Intel graphics had better results by uninstalling the graphics driver, rebooting, and letting Windows look for a driver (instead of downloading the driver from the Dell support site).

2. Try disconnecting and then reconnecting the HDMI cable.

3. If you are using Windows Media Player or Windows Media Center but get no HDMI audio even after it is selected as the default playback device, go to
 Control Panel>Sound>Playback tab>Audio/Playback device>HDMI>properties>Advance>Exclusive Mode and uncheck "exclusive mode".

4. Try a different HDMI cable.

5. Try a different HDMI port on the TV.

ll. Tips for Specific Models

Frequently HDMI audio does not work properly. I have gone through hundreds of posts and gathered together the ones with solutions that worked for at least one person. I skipped the ones that were unconfirmed suggestions. Below I have listed their solutions by laptop model, operating system, and graphics card. If your model is not listed then try a solution for your OS and graphics combination.


Models with Intel Graphics

This tip was posted by a number of people with different laptop models (including  Inspiron 1525 and  Latitudes E4200, E4300, & E6400), but all with Intel graphics. Look in the Device Manager and if you see "Audio device on high definition audio bus" with an exclamation mark, you need to update it. Right click on it and point the updater to the HDMI sub-folder in the Intel graphics card folder. The path will vary depending on the name of your graphics driver but should be something like:
C:\dell\drivers\R******\HDMI

The folder named R****** is where your graphics driver files are stored on the hard drive. The actual number varies depending on which version of the driver you have installed.  If you don't know then just download a copy of  the newest graphic (video) driver from your downloads page and make a note of the location on the hard drive to which the files are unzipped.

********************************************************************************************


Inspiron 1525  (Intel GM 965 graphics)

Forum member extra hand wrote:

In the unzipped intel video driver (GM965) there's a folder named HDMI. It contains the driver for the audio device on high definition audio bus. To install, right click on the device in device manager (which has an exclamation mark on it), then update driver, and point to the HDMI folder. Once the driver is installed, the (!) exclamation should disappear in device manager. There's no need to reconfigure any audio settings. Audio will automatically be fed to the HDMI port, and when an HDMI cable is plugged into the port the laptop's speakers automatically mute.

Kevinmwest wrote:

1. Download the lastest Intel chip set and Video drivers from Dell support using your TAG on the bottom of the laptop to identify the correct drivers.
2. Uninstall using add remove programs in control panel the Intel Chip Set ( your display resolution will change to low resolution)
3. Install the intel chip set that you downloaded and also the Video (Only restart the laptop when both are installed)
4. Configure you display settings again to what you had before
5. Now connect the HDMI and try playing a song or Blue Ray movie.
6. Now when switching from HDMI to speaker and back the other way sound will stop working, so you have to close the application you were using and re-open for the sound to work. (6-23-09)



tvaudioman wrote:

Try closing the software you are using and re-opening it. Or try rebooting with the HDMI cable in place.
On my 1525 I have to restart whatever program is generating the sound after plugging in the HDMI cable for the sound to be routed thru the HDMI.



Inspiron 1525 with Vista   (Intel GM 965 graphics)

On another forum, notebookforums.com, vbdino wrote:

I just spoked to Dell support and after resuming what I have discovered, I asked if they support the audio for the hdmi port. The answer is that even though the hardware has what it takes, the design of the inspiron 1525 was for video only. The Intel chipset offers also audio but Dell had no intention of supporting it. For now, the solution is:

1- make sure there is no hdmi cable connected
2- uninstall the Intel High Definition Audio HDMI and select to remove the driver files as well
3- Click on the action menu and rescan for new hardware
4- Vista will install a different driver that supports only stereo but it will be available in your sound dialog.

 

AbernaME wrote:

My Inspiron 1525 running Vista home Premium had the same problem. I finally got audio from my digital TV by selecting "Mute Laptop Speakers" from within the Sound Control Panel. P.S. make sure you're getting video on the TV when you open the Control Panel.

 

Inspiron 1525 w/Win7   (Intel GM 965 graphics)

Saad Al Haddad wrote:

Shut down computer and connect to your TV via the HDMI.  Boot up computer.
Press Crlt+Alt+F4 to switch the display to your TV only
I hope you have an external mouse, becuase you will need to restart your PC and the laptop lid be closed. So after the restart, the bios screen and the windows startup should show on your TV
With the laptop lid still close, navigate with the help of your external mouse (wired or wireless) to the volume speaker in the task bar and right click. Choose playback devices, then you will see a new slider called HDMI volume.
It worked every single time with me, so you have to have the graphic card set to display on the TV while windows 7 starts up. Otherwise the driver for the HDMI will not be loaded during the start up.


tomurphy wrote:

Weeks ago the hdmi sound out was broken too, but I got it fixed by checking out these forums and upgrading to newer intel hdmi drivers that came out a week or two after the official release of windows 7. (Jan 2, '10)


corbryant wrote:

I had to go into the sound properties from the control panel and on the first tab you'll see HDMI Audio, Speakers/Headphones, and one or two other options.  You'll have to select HDMI Audio by clicking on it, then click "Set Default" at the bottom.

pete_spet wrote:

In reference to the 1525, one of the posters said Dell was not supporting the audio feed for the HDMI so I went to Intel. They have a driver download which will install the HDMI driver for the Mobile Intel 965 Express chipsets. Enter your OS and download. It worked like a hot damn. Once installed and rebooted as is normal with graphics drivers, it was plug in the cable and go. Its an old one from 2009, but it works.

GG_Zurich wrote:

Inspiron 1525 was having HDMI Audio issues soon after upgrading to windows 7 and cannot see HDMI option in the control panel sound settings, but followed the below link to install intel drivers again, everything is back to normal and working, hope it helps any one who is searching for a solution for HDMI audio issues with Inspiron 1525 laptop.

http://forums.pcpitstop.com/index.php?/topic/198295-hdmi-audio-not-working-on-dell-laptop/
 

**************************************************************************************


Inspiron Mini 10 with XP  (Intel graphics)

camikins wrote:

I've got it working now! Here's what I did.
Turn on computer with HDMI plugged in
Go to control panel -> sound / audio. This opens the Sound & Audio Device Properties window
Go to Audio Tab. Sound Playback likely reads 'Realtec HD'.
Unplug the HDMI cable from the computer. Wait 5 or 10 seconds and plug back in.
Now in the same Souund Playback dropdown you'll hopefully see HDMI Device. Select that, and click Apply. Now, you should have audio going through to your TV.


riotten22 wrote:

The following updated Intel video driver will allow you to pass audio and video through the HDMI port. You will need to have your Mini10 connected to an hdmi TV for the audio properties to give you the HDMI opton.
http://support.dell.com/support/downloads/download.aspx?c=us&cs=19&l=en&s=dhs&releaseid=R207162&SystemID=INSPIRON1010&servicetag=&os=WW1&osl=en&deviceid=18334&devlib=0&typecnt=0&vercnt=1&catid=-1&impid=-1&formatcnt=1&libid=6&fileid=290030


**********************************************************************************************

 Inspiron 15 M5010

dsan713 wrote:

Had problem with no hdmi audio had to go to Intels site to download latest driver for grafics card fix my problem.

**********************************************************************************************

Inspiron 17R

Abdul_Yakisoba wrote:

Go to: Start>Control Panel>Sound
-In the sound menu, right click in the area under the "Playback" tab.
-Select (Turn on, if off) "Show Disabled Devices."
On my Dell Inspiron 17r, a new option appeared titled "MStar Demo."
-Click on "MStar Demo" to select it, and then proceed to click "Set Default" in the drop-down tab next to the "Properties" select box.

*******************************************************************************************

Latitude E6410

Lenny Lee wrote:

Go to control > Sound. Open the Sound Control Panel then select Playback tab, and choose your TV as the default device. Once you done this, the sound will be sent to your TV. I am using Windows 7 on Dell E6410, and it works for me.

******************************************************************************************

Precision M4400

PAS-Chris wrote:

In order to get my audio to play through the displayport on my M4400, I have to go into the sound settings (double click speaker icon in sys tray), then click options>properties. Under Mixer device, mine has to be set to IDT Audio and not SRS Premium Sound. Press OK. Now there should be an "Advanced" button under the main Volume Control slider. In the Advanced Controls for Volume Control box, there are two boxes at the bottom. Check both of them. PC Spk Mute will turn off your PC speakers and SPDIF will allow the sound to run through the DisplayPort/HDMI connection.

*******************************************************************************************

Precision M4500

moimichelin wrote:

I've a M4500 and the first time I connected my displayport to hdmi adaptor, the audio was not working. The video was ok but the sound still comes from my laptop.

I look up in the audio properties and found something.  you need to right-click on the sound icon and select the reading option. You normaly have a list of all the peripheric (your TV, your hearphones and your normal audio output). You need to select the TV output as default output.

So when you will connect your hdmi cable, the audio will work automatically !

viz55 wrote:

Recently I bought a new Displayport to HDMIadapter from Dell and everything worked like a charm. so finally i can definitely state that M4500 does support sound from Displayport.
First of all I would check the drivers (delete the existing ones and try the ones from nVidia, if that doesnt work, delete them and try the ones from Dell).
Bear in mind that some HDMI equipments have features like auto-recognition that sends a signal to your laptop as soon as you plug your wire (in my Panasonic TV I had to enable it).


*********************************************************************************************

Studio 1537

hmthomas1 wrote:

What I found was that when I restarted whatever program (websited or audio source) it would come out through the tv. If  I didn't restart it my sound control would show the hdmi default but no audio indicator on the bar levels next to the source icon. I kept thinking it wasn't working but upon restart, it did.


********************************************************************************************

Studio 1737 with Win7

CorkStabber wrote:

This is a Studio 1737, Windows 7 Home Premium 64 bit, upgraded from Windows Vista 64 (not a clean install). I've installed all the latest drivers from Dell, and have no !'s in Device Manager.
I can use Windows Media Player or Windows Media center just fine for most content, streaming Netflix in Media Center over HDMI is fine, playing mp3's in iTunes over HDMI is fine, etc. But when Playing a DVD or a ripped .mpg, the video plays but the audio is just extremely loud static.
This was fixed by going into Control Panel and the settings for the HDMI device, and unchecking the 'Exclusive' options.

Oaxaca Bill wrote:

I just got a Studio 1737 and had a problem with the HDMI cable too. The picture was fantastic on my Philips LCD tv but no sound. Fortunately, I bought two cables so as a court of last resort I switched cables and voila there was stereo sound. I'm sure there are configuration problems on many systems but my problem was simply the HDMI cable. I hope this helps someone. By the way, the sound came through my laptop speakers after I unplugged the HDMI cable. To be safe, I turned off the TV before I disconnected the cable though.


*************************************************************************************************


Studio 1555

Bryan68426 wrote:

The solution that worked for me was simple once I found it.
First, connect the HDMI cable to the TV and your 1555 (be sure the TV is on). Then: Control Panel>Additional Options>IDT Audio Control Panel
At this point, a new window pops up. The bottom center area will have 4 vertical sliders, one for main, computer speakers, headphones, and HDMI (which is represented by a TV). Click on the image of the TV. One option will appear above the sliders (where the horizontal sliders and SRS logo were). That option sets HDMI as the default audio output. Click the radio button. This should resolve the issue, it did for me. Also, when you disconnect the HDMI from your 1555, the HDMI (TV image) option disappears from that window and your computer speakers return as the default audio. You should not have to switch this again, but even if you do, it's easy.

Studio 1555 with Win7  (Intel graphics)

bond-007 wrote:

Well, finally I got my 1555 with intel graphics to get audio out of HDMI under WIN7 64 bit ULTIMATE.
After strugling with no audio from my HDMI and reading all your posts here for the last few days, I decided to uninstall my graphics driver and reinstall the graphics driver from DELL , then I switch my power plan to HIGH PERFOMANCE - not the DELL RECOMENDED one !!!
Then I powered off my 1555 , connected to the TV with HDMI, powered on and VOILA.
YOU MUST FIRST POWER OFF TV, POWER OFF YOUR DELL, CONNECT THE HDMI CABLE, POWER ON YOUR TV IN HDMI MODE and only then POWER ON YOUR DELL and ensure it is powered by MAINS ! NOT BATTERY!.
It is importatnt to understand that the moment you will boot again with noTV connected you wil NOT SEE the HDMI in the SOUND PROPERTIES of your DELL.

Studio 1555 with Win7  (ATI graphics) -- 5.1 audio to receiver

Luciden wrote instructions on how to get 5.1 surround sound through the HDMI coonection:

1. Update Power DVD DX to the latest version, at this time it's something like 8.3.
2. Go to realtek site and download the application called: ATI HDMI Audio Device. Install it.
Try this link: http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=24&PFid=24&Level=4&Conn=3&DownTypeID=3&GetDown=false
3. Connect the laptop via HDMI to an HDMI receiver. Turn the laptop display off or it won't display the movie on an external screen.
4. In Vista go to the control panel and select Sound (i use classic mode). Make sure the the realtek HDMI option is selected. I don't have my laptop handy but in one of the tabs turn on and test Dolby Digital and DTS. Both should work. Your receiver should display that it's decoding the appropriate signal.
5. I configured the HDMI output to 5.1 speakers. I don't know if this is necessary.
6. Here's the missing link. In PowerDVD DX, DO NOT select HDMI as the audio output. Instead, choose S/PDIF. This is obviously an issue with PowerDVD since the HDMI selection with dolby digital passthrough should work fine. At the time of this writing, it won't. For whatever reason the S/PDIF setting will passthrough Dolby Digital over your HDMI output.

Studio 1555 with Win7  (unknown graphics)

foonini wrote:

I did a clean install of Win7 and after installing all drivers in Dell-recommended order, did not have an option for HDMI audio, though the video worked fine. While I tried all of the fixes here, nothing worked for me. Then I had an epiphany: Keep it Simple. I simply uninstalled the Intel High Definition Audio HDMI from Device Manager and rebooted the computer with HDMI connected, letting Win7 reinstall the drivers. After that, everything seemed to work perfectly. As a side note, my preformce settings WERE on high performance, and have not tested it on normal settings. between these two things however, the fix should work.

bobcat2558 wrote:

I was running Windows Vista Home Premium, but am now running Windows 7 Home Premium. I found was that if you see the HDMI audio device in the 'Device Manger', but do not see it under the playback devices menu, try right clicking in an open space and you should see 'Show Disabled Devices' and 'Show Disconnected Devices'. The HDMI device would be concidered a 'disconnected device' because it only work when a HDMI cable is present, unlike a sound card that is connected even when there is no speaker/headphone jack connection. Anyway, all I had to do was plug in the HDMI cable and set it as my default device. That worked for me. I didn't have to uninstall and reinstall drivers to get it to work.

**************************************************************************************************

Studio 1747 with Win7 64bit

mackbuck12 wrote:

My solution was to uninstall the video driver R271318 [AMD ATI Mobility Radeona 8.713.3.2, A02] and reinstall it. A word of caution: Before you uninstall the video driver, be sure to get the driver from the Dell Website before you delete the driver and once the driver is deleted you will need to increase the screen resolution to its highest range.

Then reinstall the sound driver R260553 [IDT HD audio driver 6.10.0.6267, A03].

I found that I get TV sound this way but If I change the configuration then it stops working. For example there are times when I want to watch TV but have the sound go thru my Blue tooth head set. That will work, but after that start playing sound via the Blue tooth I can't go back to having sound play thru the TV. My solution is this.

I will reinstall both drivers . When that's done, I created a restore point and named it  "HDMI works". After that if it stops working I just do a system restore to a point where you know that the HDMI audio works.


******************************************************************************************************

Studio XPS 1340 with Win7    (nVidia graphics)

damon4.com wrote:

Keep uninstalling all the installed drivers for the HDMI audio. After you uninstall, AND DELETE, a driver, the next earlier driver will automatically install. Uninstall, AND DELTE that one (there is a check box on the dialog box during uninstall to delete driver). Keep doing it. Then install the latest driver from Dell. You can enable the HDMI autio from the Soudns in Control panel, and also use the IDT audio control in control panel as well.


KyleCK wrote:

There is a button to switch between displays, i had this issue but cycled through this a few times and it ended up working.

alexei001 wrote;

From NVIDIA release 195 notes: "The NVIDIA driver disables HMDI audio for some displays, which have been identified as having issues with current NVIDIA graphics cards".
This was the case for my Studio XPS 13 and Philips 42' plasma - the newer driver ((8.15.11.8633) disables audio over hdmi, the older one (7.15.11.7684) works just fine.


***********************************************************************************************************

Studio XPS 1640 with Vista  (ATI graphics)

pauline_hill wrote:

> Install or update to the current ATI graphics driver.
> In Device Manager, "update" the driver except use the option to "select from a list of available drivers"
> Select the High Definition Audio. You will see a warning but click 'install' anyway.
> Reboot

There were 4 other posters who confirmed this to work on their Studio XPS 1640's.


ptdw123 wrote that he got it to work just by installing this driver:

http://support.dell.com/support/downloads/download.aspx?c=us&l=en&s=gen&releaseid=R227577&SystemID=StudioXPS16&servicetag=8C2P8K1&os=WLH&osl=en&deviceid=16674&devlib=0&typecnt=0&vercnt=3&catid=-1&impid=-1&formatcnt=0&libid=6&typeid=-1&dateid=-1&formatid=-1&source=-1&fileid=326436
He also wrote:
"Don't forget to change the settings in POWERDVD DX to HDMI else the sound will still continue to come out of the laptop speakers."

Studio XPS 1640 with Win 7 64bit

Paulko wrote:

I uninstalled ATI Catalyst software, restarted my computer and boom... there it was :) audio through HDMI.

Studio XPS 1640 with Windows Media Centre  -- to connect to receiver with 5.1 audio

cundogg wrote:

Go into Windows Media Centre setup and go to the speaker set up settings. It will show you options for 5.1. then you need to go into the dvd settings in Windows Media Centre and disable auto volume and make sure theatre mode is selected. That should do the trick. If you connect your laptop to your receiver it should output 5.1. All you need now is a program that is capable of outputting 5.1 to a receiver. I use VLC Player personally which I think is the best. to set up 5.1 properly.  in VLC Player do the following: go into VLC Player then tools, preferences audio. select output type as win32 waveout. Make sure use s/pdif when available is selected. Make sure force detection of dolby digital is auto. You should be able to play any movie file or dvd now with true 5.1. VLC Player won't play blu rays though. You should download Power DVD Ultra for that.


*****************************************************************************************************

Vostro 3500

jwcalvert wrote:

The Vostro has two integrated display cards; an ATI ( for lower power consumption) and an Nvidia. But only the Nvidia has HDMI Audio output. Every time I tried the HDMI with my wide-screen TV, I took the Vostro there but had it running on its battery. BINGO! The Power Option Plan switches from Nvidia to ATI when its unplugged to save power.
So as soon as I plugged it into the wall, the screen went momentarily black and then came back with the HDMI Audio as a alternative option for sound output. Furthermore, I was able to go into the Control Panel > Power option and change to my own custom plan to force the laptop to stay with Nvidia even though its running on its battery. Problem solved!

**************************************************************************************************

XPS M1330

tclhk wrote:

I have been able to get video and sounds from HDMI connection, but it's not as intuitive as it should be:
"Go to 'Sound' from 'Control Panel' or from right-click on the 'Desktop' and then choose 'Personalize' from the menu.
click 'Playback' at the 'Sound' app, you should see 'Speakers/Headphones' and 'HDMI' codecs.
If 'HDMI' is there, simply click on it and click 'Set Default'
If you can't see 'HDMI', try right click on the 'Sound' app and check on 'Show Disabled Devices', and 'HDMI' should appear.

S7TGG wrote:

Here is what you need to get rid of both PC speaker and HDMI sound coming out at the same time. Go to the Advanced button for volume control and check the following
1 PC Spk Mute (PC speakers): which it mute the PC speaker when checked
2 SPDIF Interface (HDMI sound and optical audio): which it mute the HDMI sound and optical audio when un-checked.


XPS M1330 with Vista

Benm2 reportyed that HDMI audio was working fine with Vista until he updated to the latest video driver. He had to install the earlier video driver to get it to work again. (July '09.)


XPS M1330 with Win7

euro888 suggested replacing the SigmaTel STAC 92xx C-Major HD A02 driver with the  IDT 92HD73C1 (version 6.10.0.6217, A15) driver.

Ridgetop did so and reported "HDMI audio streaming and local speakers both work for the first time since Windows 7 64 bit upgrade."


XPS M1330 with Win7   (nVidia graphics)

A poster had HDMI audio working on Vista but not after upgrading to 7. Forum member beeroge1020 helped get it working  with this advice:

I was having the same problem but i've figured out how to get it to work. click control panel -> hardware and sound -> sound -> click playback tab -> right click in the box and click show disabled devices. if your hdmi is disabled right click it and enable it. while you're connected to the moniter/tv via hdmi disable speakers/headphones and make sure hdmi is enabled. you should be able to hear sound through your moniter/tv speakers now.. Once you disconnect the hdmi cable just make sure you enable speakers/headphones so your laptop speakers work. You can make 2 profiles so you don't have to reset them every time but i can't remember how to do it at the moment.


XPS M1330 with Win7   (Intel graphics)

oliverortiz77 wrote:

I reinstall the Video Driver and it works, I have the Intel video card and i download the file from Intel web page because the one wich is in the Dell drivers don't work for me. And after reinstall the video driver, turn off the laptop and the TV, then turn on the TV in HDMI, then turn on the laptop and press Fn+CRT/LCD after that works OK. (12-7-09)   He got the Intel graphics driver from
http://downloadcenter.intel.com/SearchResult.aspx?lang=eng&ProductFamily=Graphics&ProductLine=Laptop+graphics+controllers&ProductProduct=Mobile+Intel%C2%AE+965+Express+Chipset+Family&ProdId=2800&LineId=1101&FamilyId=39

KGNickl wrote:

I have a XPS m1330 that has Windows 7 Pro. To switch from the standard speakers to HDMI audio I have to go to the sound icon, right click........then set HDMI as default for audio.


************************************************************************************************

XPS M1530 with Vista

audifan wrote:

I struggled with the sound however just as you have stated no sound through the HDMI cable to the TV just sound from the laptopspeakers. I selected HDMI as the default sound source by right-clicking on the speaker icon in the righthand system tray and selecting Playback Devices. You then set HDMI to default. However this is where the buggy Vista drivers start to give you bother. sometimes I get sound through the TV and sometimes I don't. When I don't the workaround is disconnect the HDMI cable at the laptop, let things settle, then re-insert the HDMI cable. This usually cures the problem and its showtime!


dmavrika wrote:
Changing the output default to HDMI from the sound program in the control panel did the trick.



John5014 wrote:

Dell 1530 displays video but has no audio on my TV when using WMP 11. HDMI audio has been selected and you can hear the test tone when selected. Downloaded another player and the system worked fine. The audio still did not work when using WMP. Here is the fix that I found.
Audio/Playback device/HDMI/properties/Advance/Exclusive Mode I unchecked the Exclusive Mode and the player now has audio out.


XPS M1530 with Win7 & Windows Media Center (connected to a Sony Home Theatre)

Spiderxps wrote:

I found the answer in Windows Media Centre.
Look for the option Settings,
then General,
Windows Media Center Setup,
Set up your speakers, next,
HDMI, next,
then selected the option for my system, next,
and then Test, and it worked.



********************************************************************************************************

XPS M1730

Oddly this model only has DVI video, not HDMI like the M1330 & M1530. DVI does not carry an audio signal.


******************************************************************************************************

XPS L511z (XPS 15z)

rniewijk wrote:

I was looking for a hard, obscure problem and solution, when the problem was actually easy:  when plugged into the TV, I needed to go into Control Panel / Sounds and set the TV to 'default device'.  That's it.

*****************************************************************************************************

XPS 12 Ultrabook (9Q23) with Win8

This model has a mini-DisplayPort instead of HDMI.

randyygibbs wrote:

"...it does carry the audio when I am connected to a Panasonic Viera HD television using the StarTech.com MiniDisplay Port to HDMI Video Converter we purchased from Dell." But, "the audio does not come through the HDMI port to the speakers connected to the (Dell) 2408W monitor."

Thistle3595 wrote:

Go to Monoprice.com and search the PID # 5969 and there you'll have what you need for $25.75 IIRC.  I ran into the same problem and was pulling out what little hair I have left and this fixes the video/audio issue ..... I've tried two without the the USB connector and neither one worked [example].  I went to the connector that has the two pigtail [example], one for miniport and the other USB and it works. [Note -- the links were added by me -- jimco]

*****************************************************************************************************

XPS L322x (XPS 13) with Win8

This model has a mini-DisplayPort instead of HDMI. The owner used a LogiLink (Vesa 1.1a) MiniDisplay Port to HDMI converter to connect to a Yamaha AV receiver, and from there to a TV.  Anomaly79 wrote:

I noticed that it depends on the HDMI cable... I tried 3 different cable (brand and length) and with 2 it works fine.. audio and video.... 3rd one only video. Unfortunately the not working cable is my 10m HDMI cable which I bought exactly for this purpose.

*****************************************************************************************************

Jim Coates -- senior forum member


Verified Answer
  • Please do not reply in this thread which is a FAQ.

    If you have comments or questions please start a new thread.

    Thanks, I appreciate it.

    Jim Coates -- senior forum member


All Replies
  • Please do not reply in this thread which is a FAQ.

    If you have comments or questions please start a new thread.

    Thanks, I appreciate it.

    Jim Coates -- senior forum member