Dimension 8300: Adding IDE with SATA - Disk Drives (HDD, CD/DVD, Blu-ray) Forum - Disk Drives - Dell Community

Dimension 8300: Adding IDE with SATA

Disk Drives

Disk Drives
Disk Drives (Floppy, USB, HDD, CD/DVD/BD) discussion

Dimension 8300: Adding IDE with SATA

  • OK, I know there are several threads on this, but I need to get it straight in my head.  Dimension 8300 came with a 120 GB SATA drive.  I attempted to add a WD 120 GB IDE drive.  The BIOS will never recognize it.  Pressing ALT - EFB causes the IDE drives to be detected, and they work, but everytime you reboot you lose that.

    After pressing ALT-EFB the drive appears fine, I can copy files to it and work with it OK, but I lose it when I reboot.

    I've tried all the usual troubleshooting; the drive works fine in another PC.  It is set to master, and the only drive on the primary IDE channel (CD and DVD are on secondary IDE channel).  Even went out and bought a new ATA-133 IDE cable.  But the BIOS won't detect the drive on its own.

    Does one have to do the ALT-EFB in BIOS setup everytime you reboot?

    I'd hate to have to spend the additional money for another Serial ATA drive, with a perfectly good IDE 120 GB drive right here!

    Thanks for the assist; great forum!


  • I assume your turning the drive on to Auto.   Dell recommends cable select, which means you would turn the Primary Master to Auto, and set the jumpers to cable select.   Connect the cable to the drive using the connector on the end.

    I had a similar problem on my XPS system which orginally had one SATA drive.  The IDE drive was not reconized by the BIOS.  I finally booted any way, the OS reconized it, so I Partitioned it and formated it with no problem.  Now when I go into setup it shows as a 111 GB Drive.  Have not had any issues since with it.

    Not sure why but a lot of people seem to have similar problems.  

  • Thanks for the prompt reply!  I will set the jumper to CS (it is on Master now), set the BIOS to Auto and do the old EFB thing.

    I'll be back :)



  • Set jumper on IDE hard drive to CS

    Set Primary to Auto

    Went back in and turned the FDD off (I don't have one) and rebooted three times.  All is well.  The BIOS now recognizes the 120 GB IDE hard drive.

    Worked like a champ!  Thank you very, very much.

  • Well it seems I am in the same situation with a Maxtor 30 Gig HD from my old PC that I wanted to get old files from then reformat for use with video editing.  My SATA 120 that came with the system is on a stand alone "ribbon" or wire that I can't share with the ribbon that came with the Maxtor hard drive.  I have set the jumpers to CS and now have them on Slave since nothing seems to work.  I have called and was switched to 3 different departments with Dell Tech Srvcs.  They don't seem to know how to fix.  I am wondering if I even have it on the right connector?  I put it on the one that came with the hard drive and it is on the center connector  as instructed by the manual, not the one on the end of the ribbon.  I am assuming any power connector that fits the pins will work?  Then I had the jumpers on CS and voila!  NOTHING!  I couldn't access BIOS for some time there and have now been able to do that successfully.  Guess I need step by step instructions.  I can put the jumpers back to CS but what about the power supply connector?  Also the ribbon...use the connector on the end or in the middle?  Once I access BIOS do I use Primary IDE Master or Slave?  I have put hard drives in Gateways and HP's along with CD drives and never had these kind of problems.  Can anyone "hold my hand"? ;-}  

    Thank you!!!!!!!

  • Here's what I did (no guarantees, since I had problems too):

    Get an IDE cable (which will fit the hard drive), connect it to the hard drive and plug it into the motherboard in the empty IDE connector, adjacent to the connector for the CD/DVD drive(s).

    Set the jumpers on the hard disk to CS.  Use the "end" (Drive 0) of the IDE cable.

    Start the PC.  Press F2 to get into BIOS setup.  Set the Primary IDE Master to AUTO.  Make sure that the NUM, SCROLL and CAPs keys are all pressed.  Then press ALT-E F B (hold down the Alt key then press E F B) and the PC should reboot and the drives should be detected properly.

    Give that a whirl.


  • Thank you!  You finalized the info I had started writing down in a sequence gathered from help TomXPS had given earlier in this string and in other message strings what everyone else had tried. I put the 30.7 Gig Maxtor HD back in cable select mode.  Attached the end connector to the hard drive and the other end connector of the ribbon to the IDE slot as shown in my manual.  I got into BIOS and set the Primary Master IDE to Auto and rebooted.  It was at this point I realized I hadn't done the Alt/E-F-B reset but thought to go ahead and check the Disk Manager and it was there with the drive letter already assigned!!!!  Thank you to all that have responded to everyone's questions!  It was a conglomeration of info gathering along with NJBB's help.  For the most part I had already tried everything but using the end connector and setting the IDE to Primary Master- I was a bit nervous about two Masters conflicting.... Thank you!


  • I am a new owner of Dimension 8300 with 120 GB SATA.  If I wanted to upgrade to RAID 0 or 1, do I need additional hardware such as a Raid PCI card?  Or if I just wanted to add a 2nd hard drive, is it probably the easiest to use a SATA drive?  I read somewhere in Dell's website that you should not mix SATA and ATA drives ... the Dell call center is no help on this? 
  • Not sure if your 8300 has onboard RAID or not, but I have mixed S-ATA & IDE hard drives without any problems on my Dell. But since I wanted a second RAID I had to install a PCI card in addition to my onboard RAID chip. In theory the S-ATA drive is faster than IDE drives, but I don't really think it's a noticable difference.

    Hope this helps

    Dimension XPS Gen2
    Win XP Home SP1
    Intel P4 3.2Ghz HT 800mhz FSB
    2Gb DDR3200 (400mhz) RAM
    2 - 120Gb S-ATA HD 7200RPM 8Mb (non RAID currently) Intel ICH5R on-board RAID
    2 - 60Gb ATA133 HD 7200RPM 2Mb (RAID 1) on a
    Promise FastTrak TX2000 PCI UltraATA/133 RAID Card
    128Mb Radeon 9800 Pro Video
    SB Audigy2 Sound
    CD-RW: 48X/48X/24X; DVD-ROM: 16X
    DVD-RW DVD-4X/2.4X/2X CD-40X/24X/10X
    Ext USB 100Mb ZipDrive
    17" 1703FP LCD Monitor
    Intel Pro 1000 Ethernet
    56K PCI Data Fax Modem


  • Not sure if the 8300 has the Intel Raid chip set like the XPS does.  But check you Setup to see if you have a SATA RAID option.  If it does you may have the chip set, but do not think you do, the specs of the 8300 do not indicate it has it.   You could buy the PCI card and set it up.   

    Installing a another SATA is fairly easy.   Each SATA drive has it own cable so it just a mater of plugging the new cable in to the motherboard and the new hard drive.    You need to set the SATA port 1 to AUTO in the setup.   For the cost difference between SATA and IDE you might just as well get the SATA drive may get a bit better performance.


  • I have an XPS GEN 2 System and I'm experiencing very similar problems as this post describes.

    I have an SATA HD that game with the system and I’m trying to add an IDE Western Digital 100 GB drive. I’ve followed the directions given here, however the old drive was a main drive in my old system and when I do the ALT-E F B and it reboots; it actually tries to boot from my IDE drive instead of my SATA drive.
    Here is what I’ve done.

    I’ve plugged the IDE drive into the open IDE connector on the board (next to where the CD Rom and DVD drives are plugged in).  I’ve set the drive to CS mode and gone into the BIOS and selected Auto for Primary IDE Hard Drive config and then done a ALT-E F B.  When it reboots it tried to boot from that IDE drive. 
    If I set the jumpers to Master then it forgets the drive on the next boot after finding it.
    Any ideas on what I should do?  Thanks!


  • I think if you press F12 on boot up you can select the drive to boot from and it will keep that drive as your hard drive to use in the boot sequence.    Next time you should not have to press F12.

    I never expereced a problem with IDE drive after adding it to my system except I had trouble with it being reconized by the BIOS, which I eventually got around.


  • OK...I give! <throws in towel...waves white flag>  I've followed all your instructions (new XPS...120 GB SATA..trying to add 100 GB UATA) and when I get to the press Alt E F B, the machine reboots and then I get a black screen that says something like "Sorry to inconvenience you but some piece of hardware or software is screwing up your machine - do you want to retry?" (obviously not a direct quote).  If I say yes, I get the same screen again.

    Took UATA off, rebooted,  and bootscreen stops at "Cannot find Primary Master drive - press F1 to continue".   Pressing F1 lets the SATA boot as it should.

    Does this have something to do with the fact that  the UATA is my old bootable C drive? (changing boot drives with F12 doesn't help).  If so, is there some way I can make it not bootable by changing some extensions?  I don't want to trash it since I'll probably have to put it back in my old machine again and I need everything on it.