Disk Drives

Disk Drives
Disk Drives (Floppy, USB, HDD, CD/DVD/BD) discussion

I/O Device Error

This question is not answered

I just upgraded from Vista 32 bit to 7 64 bit in my Dell Precision M6300 Laptop. I installed Windows 7 on a new drive and have no issues. The problem is using the old drive in an external enclosures. The old drive is a WD 320 GB 5400 RPM. It was working perfectly when I removed it. To prepare the drive I deleted the partitions, created a single partition, and formatted as NTFS. When I connect the drive via USB in the external enclosure it sees the disk as the correct size but not initialized and labeled "unknown" in disk management. When I try to initialize it I get "cannot perform the requested operation because of an I/O device error". I have tried this with another drive (Hitachi Travelstar 100 GB 7200 RPM) and get the same error. I tried a different enclosure - same error. I tried the SATA connection but it nearly freezes windows 7. I tried using the drives unpartitioned or with a single unformatted partition - same error. I tried hooking the drives to an XP 32 bit system - same error. I tried hooking to another W7 64 bit system - same error. The strange thing is I can install either of these drives directly in the laptop and load windows without a hitch. Another oddity is when I use a Seagate Momentus 80GB 5400 drive in either enclosure it works perfectly over USB or SATA. Any help with this issue would be greatly appreciated. I just wanted to use these drives for backup and storage.

External 1: Vantec NexStar3 USB 2.0 & SATA

External 2: Venus DS2 USB 2.0 & SATA

SATA: IOGEAR 2 Port 3Gbps eSATA Model GPS702e3

All Replies