Dell 4700 Drive 2 not found, Parallel ATA,PATA-0 (PRI IDE MASTER) - Disk Drives (HDD, CD/DVD, Blu-ray) Forum - Disk Drives - Dell Community

Dell 4700 Drive 2 not found, Parallel ATA,PATA-0 (PRI IDE MASTER)

Disk Drives

Disk Drives
Disk Drives (Floppy, USB, HDD, CD/DVD/BD) discussion

Dell 4700 Drive 2 not found, Parallel ATA,PATA-0 (PRI IDE MASTER)

This question is not answered

I hope someone can help I have all of a sudden developed this message and am unable to access the cd-rom & dvd writer. When going into 'My Computer' they have gone. I have ordered a new IDE cable as the cheapest way to start but whay really worries me is if that does not work how can I get pictures and videos from my hard drive when I cannot access my dvd writer? I have tried going into drivers and making sure they are enabled but still no go.. Any ideas guys. 

All Replies
  • Look in the Device Manager .........

    Start | Control Panel | System in classic view | Hardware tab | Device Manager

    Click on the (+) next to DVD/CD-ROM drives.  Right-click the drive and select Properties.
    Is there an Error Code (number) present?

    If the drives are not in the Device Manager, then shutdown the system, open it,
    and reseat the IDE connectors at the back of the drives.  Follow the cable to the
    motherboard and reseat the connector there also.

    Upon restart, enter the Set-up (BIOS) and make sure the drives are recognized there
    and and enabled or ON.

  • Hi Skybird

    Tried to find 'Device manager' Git as far as classic view and could see no hardware tab only 'Add hardware' was the closest. Anyway found device manager another way and nothing there saying DVD/CD-ROM drives. I then shut down the system and made sure all IDE connectors were reseated. On restart went into drives and had the following.

    Drive 0: SATA-0

    Drive 1: SATA-2

    Drive 2: PATA-0

    Drive 3: PATA-1

    Under drive 3 It says controller: Parallel ATA  , Port:PATA-1 (PRI IDE SLAVE)    Drive details, Drive id - CDDVDW-SH-S202N

    I have made sure that things are on or enabled and still no go! What do you think is going on with this? Do you think it maybe the IDE cable as I have ordered another one as I thought it was the cheapest option to start with. Any other ideas?


  • I think trying the IDE cable is the right direction.  Let us know the results when you do.

  • Well I changed the IDE cable and still nothing so i looked through some other posts of people not being able to access dvd drives and someone said running a diagnostic of the hard drive to see if it was a motherboard battery or the drive gone. Anyway I ran a diagnostic of the hard drive and it looked fine, Anyway went back to the my computer page and the drives are back cd-rom & dvd writer so its all fine now. Phew. Anyway I dont know whether I can post this one for you or put it somewhere else but the pc keeps crashing and up comes a blue box which says 'server busy' and in the box it says (This action cannot be completed because the other program is busy. Choose 'switch to' to activate the busy program and correct the problem'.

    You can choose either (switch to) or (retry) The retry will not do anything and the switch to just takes me to the Start menu. It will not even let me shut it down the proper way as it gets as far as saving your settings and then just stops. I then have to turn it off at the wall and this happens a lot. Any ideas. 

  • Glad you got the drives back.  As for your new problem, I suggest a new post
    in a more appropriate forum, perhaps Software & Operating Systems or something
    like that.  Best regards.

  • As you turn on your PC once you've got the same message press F2 then go to drive turf off  those drive that aren't supposed to be on and you should be ok even when it say factory on put it off

  • This thread has been locked due to it's age, if you have a similar issue, please use the 'New Post' feature at the top of this page and start a new thread.


    If my answer was helpful, please use the 'Did this answer the question' and click: Yes
    Forum Member since 2001
    I am not employed by Dell