Hi I have a dell optiplex 745 sm form factor w/ XPpro sp3. I am trying to upgrade the dvdrom in it to a dvd rw. The old drive is a teac dv-28e slim drive which had an ide interface with an adapter that converted it to sata. The board on the 745 is sata interface but the drives in it are all ide interface, even the hd. So I swapped out the old with the new (teac dv-w28e ide interface) with the adapter on the old drive too. the drive powers up but when starting up the computer it becomes really slow on boot and then says that it doesnt recognize drive 0 and to press f1 to continue. after that I check in my computer and there is no dvd drive present. I checked device manager too and no dvd drive present.

I contacted dell support and they tol dme to reset the bios to factory defualts and to clear the log. did so and saved. tried again and at boot it went to check ide connections and found nothing. the dell support guy said that I should swap the old one back in and try to get it to work again...it worked fine. He thinks it's a bad drive but I think otherwise. I think it may have something to do with the bios or 745's system not letting this drive to be recognized properly. here's my reason. When i was doing the swappping of the old drive I took the adapter of the old drive and when he restarted my computer I put in the new drive with the adapter and it recognized the new drive. everything went well until reboot.

So I'm not sure on how to make this system work with this drive but some advice or help would be really appreciated!