Seagate Barracuda 7200.11 firmware defect

Disk Drives

Disk Drives
Disk Drives (Floppy, USB, HDD, CD/DVD/BD) discussion

Seagate Barracuda 7200.11 firmware defect

This question has suggested answer(s)

As has been widely reported in the media, Seagate has confirmed a firmware defect, which can suddenly make a drive permanently inaccessible on power-up. The issue has also been labeled 'frozen drives', 'bricked drives' or 'boot of death'. The only way to prevent this from happening is to apply a firmware update before the drive freezes. Once frozen, the drive is no longer accessible and no firmware update is possible without using special equipment.

Seagate strongly recommends updating the firmware of all models affected by this bug. See the details at

Currently, Seagate offers the firmware fix for retail drives only. No fix has been published for Seagate drives built into PCs by OEMs such as DELL. Owners of such drives, which contain 'branded' OEM-versions of Seagate firmware, are referred to the respective OEM to obtain a fix.

Unfortunately, DELL has not yet issued a firmware fix for its Seagate OEM drives (mine is a "ST3500620AS" running firmware "DE12").

When will such a fix be available? I'm not comfortable waiting until the PC's primary drive fails completely.

All Replies
  • Oliver.HH, Thanks. I bought an Seagate 500GB for when Microsoft release Win 7, and it has got that bug.


    If my answer Was helpful?  Please let me know by clicking on the 'Did this answer your question' and clicking on the Yes button.  Thanks.



  • I bought a new Dell XPS 420 last September with a RAID 1 configuration : 1 x Hitachi 750gb and 1 x Seagate 750gb hard drives. Just over 2 months later, the Seagate gave up the ghost. Dell support were pretty good, but they would not listen to my request to have a different make of drive as a replacement and so I was stuck with another Seagate Barracuda (ST3750630AS, also firmware DE12)

    Yes, you've guessed it - the replacement Seagate drive has gone the way of the first ! I've done all the usual checks, like I did the first time round but there is no way this drive is going to communicate any more. Now, I was glad when I saw this post because I thought lightning doesn't strike twice and I must have a dodgey component in the motherboard.

    I will be calling Dell support yet again tomorrow and I'll let you know what sort of response I get this time ...

  • I´m one of the unlucky owner of a Seagate 1 TB drive that just died after sleep mode. Super Angry Too late to update now, so I will get a new drive on warranty from Dell. Sad that the comp was only 2 weeks old (XPS 430 replaced on warranty beacuse my 1 year old XPS 420 burnt). So here we go again with a lot to reinstall all over again. Super Angry I will get the same brand and model as replacement. I really hope this is flashed with the latest firmware.

  • According to the Seagate bulletin mentioned in my original post, your new drive should be OK if it was manufactured on January 12, 2009 or later, even without a firmware update. You can find out the date of manufacture by feeding the date code on the drive's label into a date code calculator such as (which hopefully gives accurate results).

  • @mickybhoy:

    I'm curious to know what they will offer you.

  • In less then 24 hrs, the new drive arrived at my door. Superb support I really must say! I was really surprised when I opened the box and found a Hitachi Ultrastar HUA721010KLA330 instead of a Seagate of same model as the old one. So now I can relax untill next thing will break/crash...Big Smile

  • On Wednesday, January 28, 2009, Dell has issued a firmware update DE13 for the ST3500620AS<ADMIN NOTE: Broken link has been removed / replaced from this post by Dell>



    Level of Importance: Urgent
    Dell highly recommends applying this update as soon as possible. The update contains changes to improve the reliability and availability of your Dell system.

    Fixes and Enhancements
    The DE13 firmware corrects potential hang on power up. Drive will appear not accessible after hang.


    However, I am not sure whether this is the correct firmware for the drive. The code in the update's batch file calls the firmware updater with the following set of parameters: sf -m BRINKS -f DE13-2D.BIN -s -x -b -v -a 30


    "BRINKS" is Seagate's internal model name for a different set of Barracudas (also affected by the firmware bug). The ST3500620AS drive is a member of the "MOOSE" family. Accordingly, the original Seagate firmware update is called "MooseDT-SD1A-2D-8-16-32MB.ISO".


    Has anyone successfully applied Dell's update to an ST3500620AS?

  • I called Dell with the same problem and they made me download the patch of the firmware DE13, assuring me that it would work on the DE12.


    I am trying it tonight.

  • I called Tech Support tonight and demanded (more or less) a brand other than Seagate so they are trying to get me a Hitachi or similar. I also spoke with the Supervisor and expressed my disappointment at this whole mess and have just typed up a letter to Dell hq in Berkshire, so I'm not holding back on this.

    My new hard disk should be here Friday, so I'll update progress then and let you know if they respond to the letter.

    Best of luck all.

  • Replacement hard disk on its way Friday - I told them I didn't want a 3rd Seagate disk !

  • Oliver.HH
    Has anyone successfully applied Dell's update to an ST3500620AS?

    Hello All, I downloaded, burned the firmware update to a CD, rebooted the system to the Dell Seagate firmware update and it completed successfully in about one minute. I removed the CD and rebooted, and everything seems normal.

    I had no issues before, and I still have no issues that I am aware of.

    It did list the firmware as DE12 and updated to DE13.

    I use the Seagate as a backup drive, and not the boot drive, so that may be why I didn't notice any difference.

    Just some thoughts.

  • Hello,


    I have the ST3500620AS drive with firmware DE12.  It had the bug and now, it's undetected at boot.

    Dell told me that their patch for DE13 would work on the DE12.


    So I downloaded and burned it to a CD, booted with it.

    It extracted files into RAM and began scanning.  It says:

    Scanning for controllers ...

    Scanning for devices on Intel ICH8R/ICH9R/ICH10R ....


    And it just hang there ... I guess the patch is not working IF the drive is already dead ...

    I hope they have a better solution.


    Just to let you know.

  • Thanks to everyone for the comments.

    A little update from me: Though I've received no further information from Dell about the correctness of the DE13 firmware update <ADMIN NOTE: Broken link has been removed from this post by Dell> (see my last post), I decided to stop waiting and applied the update today. The update itself worked well (I used the bootable CD method). In addition, I did extensive drive tests after the update: I made copies of all disk partitions, ran some disk tests (SMART self test, Dell's drive confidence test) and finally ran a full drive erasure (where every sector is written). No errors were detected, so I re-installed all partitions.

    So far, everything seems OK and to me the problem appears to be solved.

    @Hanspuppa: It doesn't matter if your drive is the primary one or a backup drive. Any drive affected by this bug can fail on power-up.

    @scrolaval: As I wrote in my initial post, the firmware cannot be updated once the drive is in its frozen state, as the drive is refusing to communicate to the PC. The only way to revive such a drive is to hook it up to special diagnostic equipment.

  • Right, the latest in this saga ... 2nd replacement (in other words, on to my 3rd hard drive since September) arrived Friday pm.

    Any guesses as to what make it is ? Correct. Another Seagate, this time a 1 terrabyte hd. Another Seagate, another failure. I plugged it in, checked it was identified in the BIOS and let the RAID configuration rebuild in the OS (Vista). That ran for a while, then I went back to the PC later in the day and the little RAID icon in the systray was showing red. So I hovered the mouse over it and, surprise, surprise, "A RAID volume is degraded because of missing hard drives" !

    I'm tearing my hair out over this. Why can't they just send me a different make so that we can prove once and for all whether it is Seagate that is the problem, or something else that is causing these drives to fail.

    So, I think first of all, another letter to DELL hq. But wait, though. It's getting interesting. The message now reads that this is a "failed hard drive", no longer a missing one. So I checked in the INTEL storage matrix and, sure enough it detects the Seagate drive in the array, but it has a status of "failed". What is going on ? This one appears to be China made, with date 08476 (May 2008) and firmware DE12. Does anyone recommend me trying the firmware update, or is that pointless once the drive has failed ?

    Any suggestions greatly appreciated. Meantime, I have a good mind to go out and buy a 750gb hard-drive myself (WD or Hitachi or whatever) and give that a try. If that works, invoice Dell and see what happens.

  • mickybhoy

    I plugged it in, checked it was identified in the BIOS and let the RAID configuration rebuild in the OS (Vista). That ran for a while, then I went back to the PC later in the day and the little RAID icon in the systray was showing red.


    That means the system was powered on, the drive initially worked and then failed while still powered on. Please note that the Seagate firmware bug mentioned at the beginning of this thread is about a drive failing right away when power cycled. The bug does not apply to other kinds of drive failures.

    Disk drives may fail for a number of reasons and after such a failure, they may or may not be recognised by the BIOS.


    This one appears to be China made, with date 08476 (May 2008) and firmware DE12. Does anyone recommend me trying the firmware update, or is that pointless once the drive has failed ?

    Unfortunately, it appears that the firmware update will not cure your problem as it seems to be unrelated to what the firmware patch is addressing. However, as a general guideline for every Seagate desktop drive, I would recommend using Segate's instructions (click here) to check if the particular drive is affected by the firmware bug and if it is, update the firmware immediately.