MATSHITA BD-CMB UJ-220 - Disk Drives (HDD, CD/DVD, Blu-ray) Forum - Disk Drives - Dell Community


Disk Drives

Disk Drives
Disk Drives (Floppy, USB, HDD, CD/DVD/BD) discussion


  • Got one of these in my Inspiron 1521 and It does not recognise anything in the drive, now I've also ssearched on Google and it seems there should be a firmware update to accomadate the change in the BR encryption that has just taken place on the latest disks, however there is non available on Dells website. If you go to Panasonics page (who make this drive) there is one available but it does not work as Dells Version of the drive is OEM so it's upto them to provide the firmware update. So mt question is when will this be available. and on a sub note I have a ATI 128mb graphics card in this machine with 4 GB of RAM and an AMD Turion X64 twin core processor and Nero 7 reckons that i should upgrade my CPU and I cant play movies as the GC is no good and needs more memory, so why are dell selling this configuration, any help please advise???
  • I agree.  Firmware needs updated on this.  Mine plays some blu-ray movies but not all.  There's no excuse for that, because firmware updates will easily solve the problem.  Get with it Dell and provide the update!

  • Not compatible in what respect? All optical drives use the same generic drivers.

  • The problems I experience are even stranger.  I have a Panasonic UJ-220 and an M1730 machine; normal pre-recorded BR discs work fine, but ones I've recorded aren't even detected in the drive 95% of the time!

    It seems to be a problem with both the fact that firmware is no longer produced by the company for my system, but also the overall flaw in the M1730 -- proper heat exchange, where the system's air flow is not powerful enough to maintain optimum temperature. If the disc is in the drive before it boots up and is cold enough, it will detect it without any trouble.  If it isn't, however, the media won't be detected for days at a time for no apparent reason.  I've experienced similarly odd issues with my graphics card and battery pack during my warranty because of the heating glitches...

    Don't misunderstand me, this post is not so much a complaint as it is an expression of deepest disappointment.  I love what the machine has done for me during my earlier time at University when I needed something with good memory and GPU.  I am also a long-term customer and we have many of your systems.  I just think that your company's discontinuation of hardware support along with manufacture was a bad move.

    At this point it is inappropriate for me to get it replaced as I suspect problem would resurface within six months, given that firmware makes sure compatability with the operating system.  I have since found a great USB external BR-Writer to make things run smoothly again and will probably be getting it sometime this month.

    Community Rockstar
    I answer questions here, but am not a Dell employee.

    Creative Director | Thorium Entertainment -
    Sr. Product Engineer | Rushboard Technologies -



  • It is Feb 2011 and still not update

  • Is MATSHITA BD-RE UJ-220  firmware update  possible? how and from where? I have xps M1730 which can't write on disc.

  • I'm in the same boat with the same BD-RE UJ-220 and stuck at firmware 1.0 and have the same problems????I'm thinking of replacing the BD with a DVD/CD writer like i should have gone with from the get go.

    E1705 T7400 2.16Ghz / Vista Home Premium SP2 / 17" LG WUXGA 1920 X 1200 / 4GB 667Mhz Geil Ram w/Heatspreaders / Western Digital Scorpio Black 500GB 7200RPM / 500GB 7200RPM My Book / Nvidia Geforce Go 7900GS 256MB / Toshiba DVD/CD+/-RW DL / Intel 4965 A/B/G/N / 355 Bluetooth 2.0+EDR / Pinnacle Pro HDTV USB Tuner / Pinnacle Ultimate HDTV USB Tuner / Sound Blaster Audigy Advanced MB / Sound Blaster X-Fi Extreme Audio Notebook / Logitech G51 Surround Sound Speakers / 2-NB-MA01 Notebook Coolers / 3D Mark06 5446 / Driver v.174.31 /

    XPS M1730 Saphire Blue X9000 @ 3.2 / Vista Home Premium SP2 / 17" WUXGA 1920 x 1200 / Matshita BD\DVD Combo / 8GB 800Mhz Geil RAM / 500GB>200GB 7200RPM / 9800M GTX SLI / AGEIA PhysX Accelerator / Intel 4965 / 355 Bluetooth / 5700 Mobile Broadband / 3D Mark06 16250 /Driver 275.50 beta

    XPS Gen 4 Desktop>being rebuilt

  • I have the exact same laptop and problem.

    I used Roxio to write data to a 4.7 DVD-R and it failed. I shut down the laptop and waited for about 30 minutes then booted again, and the same failed disk worked this time and I was able to write. I think it's a heating problem.

    But I I had another earlier issue with writing to a dual-layered HP DVD disk. I didn't test the 30-minutes fix on it.

    I contacted DELL and they sent me a replacement, another UJ-220. I am not sure if it will do any better, but will see.

  • Not to mimic, but I too have the exact same problem.  Nearly a year ago I called for support about this MATSHITA BD-RE UJ-220 optical drive.  Dell couldn't resolve softwarewise so they replaced the drive.  This did not correct the issue.

    I conjured the strength to call again today hoping something had changed, perhaps an update of some sorts.  After 40 mins, the tech conceded that this drive is likely a first-generation drive and just isn't compatible with some newer media (although I'm unsure how "new" a DVD+R 4.7GB blank disc is).

    Dell also offers no alternative drive (unless you go non-bluray).  No updates, firmware or otherwise, are planned for this drive to my knowledge.

    I expressed concern to the tech in that having a useless optical drive on a system which cost me $6,000 will certainly weigh on future buying decisions.  I also exclaimed that it is unfortunate that Dell allows Panasonic, the drive's manufacturer to the best of my knowledge, to fail in providing some level of resolution.

    That's my two cents!

  • Hi Donluz,

    No blu ray drive is so old that it shouldn't burn a DVD, so the tech's advice was incorrect. Did Dell replace that UJ-220 with the exact same model? Can you tell me the exact brand and speed DVD+R you are trying to burn?

  • Thanks for your reply.  I'm actually not even trying to burn... just trying to get the drive to READ a DVD or CD that I have burned previously on another computer.  

    The two examples I tried on the phone with the tech today both contained data (not audio/video) and were:

    DVD+R:  4.7GB  /  16x speed (Verbatim brand)


    CD-R:  700mb / 80min (Memorex brand).

    These discs both work fine on two other computers (one of which they were burned on) so I know it's not the media itself.

    While on the phone however, the tech had me put the Utils disc which came with the computer (black disc, stamped, not burned) and it worked fine.  I think it's a DVD, but don't know any other of its details.

  • also meant to say that the replacement drive was the exact same model to the best of my knowledge.

  • So the drive does not read the Dell utilities disc?

    By the way, you can check the model number in drive properties or device manager.

  • Perhaps re-read the last paragraph in my post?

  • Firmware needs updated on this.  Mine plays some blu-ray movies but not all.  There's no excuse for that, because firmware updates will easily solve the problem