Problem is detected with array : 1 2 - Dell Inspiron 1721 laptop. - Disk Drives (HDD, CD/DVD, Blu-ray) Forum - Disk Drives - Dell Community

Problem is detected with array : 1 2 - Dell Inspiron 1721 laptop.

Disk Drives

Disk Drives
Disk Drives (Floppy, USB, HDD, CD/DVD/BD) discussion

Problem is detected with array : 1 2 - Dell Inspiron 1721 laptop.

  • Hi everyone,


    I am new here... I am familier with computers etc... but have come across a bugger of a problem with my 2 week old laptop.


    I previously installed an updated driver for my ATI Radeon 1270 graphics card, it asked me to reboot... no the laptop wont boot up the OS at all and posts this error.


    Problem is detected with array : 1 2


    Press <Ctrl-F> to fenter FastBuld Utility...

    No bootable devices--strike F1 to retry boot, F2 for setup utility

    Press F5 to un onboard diagnostics.


    Both hard drives are flashing and status is saying offline


    I have tried everything so far, bios back to default settings, pressed F5 for diagnostics program where it passed all tests. Ran diagnostics from dell cd where laptop passed all tests, tried to restore and repair windows from OS cd but is not finding my hard drives so cannot find any OS installed! When using the windows OS disk you can find the X drive where the OS is installed on that partition but you cannot do anything with it or as far as I know you cant.


    Sorry this is a very rushed post and I hope it makes sense, I have to rush off to work now but I hope with what I have posted will help come up with some kind of answer to this stupid problem.


    I was on dells website for a short time but it falied to load up the page I wanted to the problem above.


    Looking forward to any answers or suggestions anyone has... I hope to be back home after work near to midnight so I will come on then and check replies.


    Many thanks for your help in advance



  • Is your bios set to SATA or ATA?

    CAn you enter windows in safe mode and unintsall the driver update?

  • Hi ah1f,

    Thanks for your reply... yes my bios was all set up correctly and no I could not access safe mode.

    But I have managed to sort out the problem...

    I had to enter delete the offline/corrupt arrays and set them up again whilst over writing the mbr. Then reboot and enter the bios and make both the arrays 1st and 2nd in the boot up order. Then boot up via the windows cd and load the driver for my hard drives, making them primary and then reinstalling windows.

    Spent hours working that out, could not find anything on the internet about it which I am quite surprised about.

    Thanks anyway