Boot from external USB CD-ROM using D420 laptop

Disk Drives

Disk Drives
Disk Drives (Floppy, USB, HDD, CD/DVD/BD) discussion

Boot from external USB CD-ROM using D420 laptop

  • Hi
    I had been trying to create a Dos based bootable CD-ROM for the external USB CD-ROM drive using the D420 laptop. I was able to create for the IDE version but not for the USB version.
    I had tried many combinations of device drivers, autoexec.bat, config.sys etc...from the internet but still not working.
    I would like to find out if anybody had created bootable USB CD-ROM before, any help is much appreciated.
     
     
    Thanks and regards
     


    Message Edited by JM Chen on 05-14-2007 01:24 AM
  • I am having a similar problem with the D420 and USB CD/Rom support in DOS. I have tried the driver from Dell (extcd.sys), along with other USB device drivers I have found on the web. So far, no luck. Anyone help would be appreciated.
  • Looking at the D420 Manual for Boot sequence; it appears it may not
    boot from a USB device.
  • I actually found a newer version of the extcd.sys driver that works. See below for the link. http://support.dell.com/support/downloads/download.aspx?c=us&cs=555&l=en&s=biz&releaseid=R123008&SystemID=LAT_PNT_PM_D400&servicetag=&os=DOS&osl=en&deviceid=10449&devlib=0&typecnt=0&vercnt=3&catid=-1&impid=-1&formatcnt=1&libid=7&fileid=163556 Keep in mind that this driver conflicts with some other drivers. But using it by itself works and I am now able to read the contents of the USB-cd-rom drive in DOS.

    Message Edited by KKwan on 05-17-2007 11:32 AM
  • Thanks a lot..I will try it out...
  • I had many many problems with this dumb laptop.  I had to make a bootable CD to image these things for the field.  After 3 weeks of tinkering with this thing all day long, I got the USB CD-ROM to boot by making a bootable cd using winImage (Roxio would not make an image of the DOS 6.22 install disk).  The image I used was disk one of DOS 6.22.  It booted and made the hard drive bootable to DOS.  Disk one by itself provided more than enough commands for me.  After installing DOS to the hard drive I booted to CD 2 which contained an image of an XP boot disk along with a folder of the boot files needed to automate the install process.  I made a custom Autoexec.bat to copy the files from the 2nd boot cd to the root of the hard drive.  After turning the USB emulation off in the BIOS, I put CD 1 in the drive and booted to the hard drive.  My USB driver then recognized the USB CD-ROM and everything worked out great from there.  The problem is that when the USB emulation is turned on, I couldn't find a USB driver to work because of the way the BIOS was emulating the USB.  BUT with the emulation off you cannot boot to any USB device.  SO I put DOS on the hard drive and turned the emulation off which allowed my USB drivers to work perfectly.  Guess it proves usefull at times to have DOS just laying around.
  • Oh yea!  I tried BartPE and it work fine, but the application that I used to automate and use PowerQuest Deploy Center 5.0 was not a win32 application and so will not run using BartPE as it used my XP OS files to create it's PE.
  • Just picked up a D420 and it booted no problem using my external LG DVD+/-RW AC-powered drives.  DELL Vista HP installed in a relative blink of the eye, then I wiped and did XP Pro - no problem.
     
    Kicking myself though because I thought the D420 1.8" drive would be mini IDE and not ZIF interface.  I have two 80Gb mini IDE drives pulled from screen-busted Sony VAIOs just sitting around here not doing much but I'm stuck with the 30Gb ZIF disk that came with the D420.  Such is life.
     
    --