Disc stuck in vostro 1710 - Disk Drives (HDD, CD/DVD, Blu-ray) Forum - Disk Drives - Dell Community

Disc stuck in vostro 1710

Disk Drives

Disk Drives
Disk Drives (Floppy, USB, HDD, CD/DVD/BD) discussion

Disc stuck in vostro 1710

This question has been answered by osprey4

I have a user that put a small size DVD in the slot loading drive of the vostro 1710 and now it won't eject. I have tried turning the unit so the drive is facing down and pressing the eject button a few times and that didn't work. anyone know any tricks to have it eject or will I have to take the unit apart?

Verified Answer
All Replies
  • Hi mparks_21,

    Please boot the system and try the eject command from Explorer or My Computer.

    I know of no way to "emergency eject" slot loading drives.

  • Thanks Osprey that worked after several tries, a lot of waiting through a bunch of whirling and clicking it did finally come out. I am shocked that doing eject from windows explorer does anything different than the eject button on top of the keyboard.

  • Good to hear. Hopefully your user has learned a lesson about those small discs. :)

  • The "eject" command in My Computer worked.  The CD ejected.  Thank you to the contributer.

  • Thanks for the "turn it upside down" trick. My Vostro was getting the instructions to eject just fine from everywhere - but the physical media could not clear the exit.

    This caused the machine to attempt ejection over and over with no end. Had to F2 on start up and tell it to not boot the DVD drive as a workaround...which I didn't want to leave that way in case I needed a DVD recovery boot up.....

    So thanks again for making the note about flipping it to eject!!