Inspiron 1525 Won't Detect HD in Bios

Disk Drives

Disk Drives
Disk Drives (Floppy, USB, HDD, CD/DVD/BD) discussion

Inspiron 1525 Won't Detect HD in Bios

This question is not answered

Hello All,  I am new to this so if i'm doing something wrong by posting this, please accept my apologies!

My main question is this, I was given a inspiron 1525 in sweet condition by a friend who was ready to smash it from frustration. Now I'm starting to see why. It will not detect ANY Hard Drive I put in it. One of which I know is fine because i removed it from my old laptop when i upgraded to a 500 gig HD. I tried a brand new WD 320gig, An other WD 500gig as well as the one that shipped with this machine, and no dice. I've tried changing the bios to ata from ahci and all sorts of stuff & I can't get the bios to read or detect a hard drive.  ANY HELP AT ALL will be greatly appreciated. !!!!

If this is the wrong spot to pose a question, please excuse my ignorance, i'm just opperating on overload right now & very frustrated. Thanks. Jon.

All Replies
  • Hi, johnservis66:

    When you say it's not detected by the BIOS, are you actually booting into the BIOS (F2) and checking to make sure the SATA channel is turned on? Sorry if that seems like an obvious question, but I've learned not to assume people understand the problem they're describing.

  • hi, thanks for responding. yes, after i tryed to reinstall vista on a new h.d. & it got to the part where it asks where you want to install windows. there is always at least a drive with a partition or something in the box that you can choose to install windows on, or format/partition, whatever, anyway, there is no drive found.
    I then reboot into bios and check under "devce info" where it says primary hard drive, = {none}
    Thru other "advice forums" i learned from reading other's experiances with this same problem with this same model, a devce driver must be inserted along with the boot disk in order for the machine to recognize the drive. but that doesn't seem to make sense to me because i'm useing the recovery disks that shipped with this laptop. all in all i'm totally perplexed!  john.
    oh, i've tried this on 4 dif. drives & all the same results

  • Hi, John,

    Two things. First, the SATA channel just be turned ON in the BIOS. Second, you need to either install the RAID drivers when prompted or set the controller to ATA compatible in order for the OS disc to see an SATA drive. You'll probably see AHCI as the default, so just change it to ATA.

    The Vista disc that Dell provides is not an OEM recovery disc. It's just a regular MS Vista disc.

  • Hi
    If i may jump in here John wrote in the 2 posts

    Post 1 = I've tried changing the bios to ata from ahci and all sorts of stuff & I can't get the bios to read or detect a hard drive

    Post 2 = I then reboot into bios and check under "device info" where it says primary hard drive, = {none}

    Let
    me say this if the {{bios does not see any drives after you make sure the drive is enabled}} the drive you have installed in the computer thats telling me the onboard
    raid controller may be or is bad , the ahci versus ata the only thing it controls is the switching from ahci to ata the {bios} does not need drivers for the drive
    but when you get to windows install at F6 that is when you need the raid ahci driver if the bios is set to ahci ,if the bios is set to ata you do not need a driver to install windows !

    John you say you checked or used a drives from another computer and that computer can see the drive that says the drives are good the only thing that i can see , it can only be is the onboard raid ahci\ata controller on the laptop is bad if the bios can not see the drives you have used .
    And Osprey
    With all do respect the CD\DVD that Dell does supply is a Dell OEM XP,Vista,WIN 7 disk with some changes to it you can not use it as a upgrade disk it can only be used to reinstall as a clean OS or it can be used to repair the OS that is already installed on the drive .
    The Dell disk or OEM for XP,Vista or Win 7 now the older OS versions i can not say that is fact or not i have not used any of the older OS that Dell had ! 
    John
    i do hope you can get the problem fixed but it does not sound good to me .

    Good Luck to you !

     

    Jerry\c3po5

    XPS 430 Ram 8 gigs Dell OEM Vista Ultimate 64 bit  

    Retail Windows 7 Ultimate 64 Bit Full version 

    Dimension 8400 Ram 4 gigs Retail  Vista Ultimate 64 bit

    Retail Windows 7 Ultimate 64 Bit Full version 

    Dimension E 512 Ram 4 gigs Dell OEM Vista Ultimate 64 bit

    Inspiron 1501 Ram 4 gigs Dell OEM Vista Ultimate 64 bit

    Retail Windows 7 Ultimate 64 Bit Full version on drive 2

  • Hi osprey4,

    After last nights heated exchange between the moderator of this site & myself, I didn't think I would ever be contacting anyone from Dell again let alone they contact me. All that aside, Here's the scoop: I f2 into Bios, scroll down to Onboard Devices, SATA Operation, hit enter, Default is AHCI - I change this to ATA. A message pops up that states that I must disable flash cache module, I scroll down past Module Bay Device & do this, Then go back up and change the SATA Operation Setting to ATA.  Save changes & exit. Restart,  mind you, I'm using a "blank" brand new, unpartitioned HD, I f12 into one-time boot menu, select CD/DVD/CD/RW Drive & start the OS Install process from my Reinstallation DVD - Windows Vista Home Premium 32bit SP1 disk. (which i realize is just dell's copy of vista provided for just this purpose) I hit enter, it goes to Windows is loading files, I select english as my language, and then click on install now, it tells me to please wait, I then accept the license terms, click next, It then takes me to a screen that asks which type of installation i want, I select Custom(advanced) THEN it goes to a screen that asks me where I want to install windows? and the box that should show me the HD is empty.  Thats the whole process, step by step that I go through.  NOW, This is what I know from playing around with things at this point.   It says: "No Drives Were Found. Click Load Drivers to provide a mass storage driver for installation" So I do this & take out the Vista DVD, & Insert the Dell Drivers & Utilities Disk, click OK, Browse, select CD Drive(D:)RESOURSE_CD This is where I'm lost. I have no idea where to find the driver for this process. I have selected & clicked on various things & I get the message:  No device drivers were found. Make sure that theinstallation media contains the correct drivers, and then click ok.   So this is my story. Any help or point in the right direction would be greatly appreciated!! Thanks, John.

  • Ok, C3PO5 is likely correct. If the BIOS is set to ATA and the installation disc is still not seeing the drive, then either the controller is bad, there's a bad cable, or there's a problem with the internal connection to the hard drive. Using the ATA option, you should not need any drivers.

  • Thanks guys, for giving me your valuable time.

    One thing I can add, I ran the diagnostic tests that were on the dell driver disk & all the system tests passed. Wouldn't a bad controller have come up on one of those tests? I performed them all. The Express, Extended, Custom & Symptom Tree. Every test, even the graphics ones that have to have user input to perform.

    Also, the other night, I was screwing around & I had a USB Drive hooked up as well as the HD installed, and a flash drive that had drivers loaded onto it from dell's support site for my # inspiron, & the driver disk in the Optical Drive. I was messing with the f6 / f8 buttons and came upon a screen that let me "see" all the drives connected, including the HD in the HD bay! I was never able to get back to that screen, I stumbled on it by accident. I'm thinking, if I was able to "see" the HD in that freak instance, how could something MoBo related be at fault?   I know it's alot to take in, but any ideas? Once again, thanks so much for your time.   John.Idea

  • Me again, I just found something to add to this mess. On the Dell Driver Disk, after the test sequence I exited and clicked on "return to DOS Mode" There I found this:

    Your CD/DVD Drive during this boot cycle is f:

    A RAMDISK drive is available for this boot cycle as C:

    It contains several Hard Drive setup tools. Please use these tools only under the direction of Dell Support Staff.

    F:\>_    "and the _ is blinking" 

     

    I'm going to leave it on this screen until one of you guys sees this and gets back to me.   Thanks,   John.

  • John:

    So it created a RAMDISK and designated it as C:, but I'm not sure that helps anything. 

    When you run the diagnostics, did you try the hard drive test?

  • I saw no one specific test for hard drive only, but I ran every test the disk had on it  2 & 3 times, and just now, again. Everthing Passed. All Tests Passed. Every time. ? ?

  • If you boot to the diagnostics, you'll see an option to run a custom test. That allows you to pick the specific component to test, in this case the hard drive. Give that a try.

  • I have the same problem and i have tested my hard drive successfully....Please help me out....

  • Sorry, I don't have anything more to add. I wound up selling the laptop on ebay. As parts. Got over $300 for it & the buyer never complained. Unless he just needed it for parts or knew of a quick fix, anyway he's not talking. Once again, sorry.

  • Dude, Last night i installed XP.  And the problem was solved. Now my lappy  is back to normal. If you still have that problem try to install xp i will help you:)

  • Hi guys, I am having the same issue, after I have ruined 2 hard drives because I was thinking it was not connecting properly (after my parents dropped it a couple of times), I was pressing slightly above the hardisk (near the touchpad)...The 3rd hard drive did not want to get installed...I have googled a lot and I was thinking, what if I change from BIOS, ATA to AHCI, after changing the setting, getting out of bios and re-enter the bios, and changed back from AHCI to ATA, now windows could be installed without any problems. This is not the solution, The problem I am having now is that every time I power on the PC I have to do this trick otherwise the hard drive is not detected.

    I idea why this is happening? I have updated the bios to a17 (i believe) and still the same thing...

    any other idea is highly appreciated!

    Thanks