Looking for a working driver for Matshita BD-RE UJ-225S Blu-ray device on Dell XPS M1530 with Windows 7 x32 - Disk Drives (HDD, CD/DVD, Blu-ray) Forum - Disk Drives - Dell Community

Looking for a working driver for Matshita BD-RE UJ-225S Blu-ray device on Dell XPS M1530 with Windows 7 x32

Disk Drives

Disk Drives
Disk Drives (Floppy, USB, HDD, CD/DVD/BD) discussion

Looking for a working driver for Matshita BD-RE UJ-225S Blu-ray device on Dell XPS M1530 with Windows 7 x32

This question is not answered

Hello !

I've installed Windows 7 RC 32bits on my Dell XS 1530 with success a week ago.

But, unfortunately, since then, I'm unable to use my blu-ray device correctly (which appears to be a Matshita BD-RE UJ-225S).

It's quite slow, and I can only read DVDs or CDs (I did not try a writing test, as I'm having issues with Blu-Ray feature). 

I'm unable to play any Blu-Ray original disc from Windows 7 RC or from the Mediadirect Dell's boot feature.

The real problem is that I'm unable to found any driver for this device (for Vista or for Windows 7).


Current status of my investigation is the following :

- Looking into the device manager the blu-ray disk seems to be recognized and a Microsoft driver is installed

- There is no Matshita BD-RE UJ-225S driver available for Microsoft Windows Vista on XPS 1530 Dell Support

- There is a link on a Matshita BD-RE UJ-225S driver, here http://www.bioticaindia.com/bd-re-uj-225s.html, but the registration process does not work for me - I've tried several times, with 2 different emails and with Firefox and Explorer). Never works :-(

- The Matshita is (now?) a Panasonic device which is described here : http://www.panasonic.com/industrial/computer/storage/optical/models/uj225b.asp. Unfortunately, there is no driver available for download on this page

- I've also tried to install Media Direct 4.7  but that does not fix the problem either. The blu-ray disc is not recognized. Here is the link : http://update.cyberlink.com/ftpdload/patch/DELL_MD/4_7/PCM080919-04/MediaDirect4_7.exe


Could someone help me on this ?

Thanks a lot for any hints.


My config is Dell XPS M1530, 4GB RAM, NVIDIA 8600M, Blu-ray writer.

All Replies
  • Hi again !

    I've just found a thread with a similar topic on Microsoft's forum : Windows 7 problem with Matshita bd-re uj-225s

    But no fix seems to be available yet...

  • HI again. I am not sure if you are going to read my post on Windows 7 forum or here, so I am writing on both. I found  that Nvidia release GEFORCE driver update yesterday for windows 7 32-bit and 64-bit. It helped me, I can play my blu-ray movies right now. Here is the link for 32-bit version. http://www.nvidia.com/object/notebook_winvista_win7_186.81_whql.html



  • Hi Joanna.

    Thanks a lot for your answer. Unfortunately it seems that something else is wrong with my system because it still does not work. When I launch the MediaDirect player it tells me that my " no DVD or no DVD disc detected on your computer".

    I'm now trying to install Cyberlink PowerDVD, but I guess that my problem is not a gfx driver problem but a Blu-ray driver problem.




  • Bump !


    My problem is still not solved. I can't play my Blu ray discs on my Dell XPS M1530 anymore !

    I've just replaced my Windows 7 RC system with a Windows 7 Premium 32bits and it still does not work.


    I've tried several configurations without success :

    - Install my brand new version of Windows 7 Family Edition 32bits (French Ed.) + NVIDIA Drivers + Media Direct 4.7 => Blu-ray disc not recognized

    - Re-install the ghost of my previous Windows Vista Family Edition 32bits (French Ed.) => Blu-ray disc was not recognized (that is strange)

    - Re-install the Dell factory Windows Vista Family Edition (French Ed.) => same problem

    - Install Media Direct from CD => error at 10% of install

    - Overwrite MBR with Dell utility => broke MBR, I was unable to boot again on my Windows partition

    - Install Media Direct partition DOS boot utility => completely changed my partitions. No Windows Vista backup partition anymore :-(

    - Install Windows 7 Family Edition 32bits (French Ed.) + NVIDIA Drivers+ Media Direct 3.5 (from CD) + upgrade : still does not work


    Really. I don't know what to do anymore. Could someone help please before I try to get hanged with my mouse ?

    Thanks a lot for any help :-)

  • Well I have had the problem since the first day i got my M1530. I called support they had no clue(apparently they do not test their hardware beyond the it turns on phase). I did perform several google searches and managed to install some bdpack that got it working in vista. It died again several months later because i clicked on he constant update button that pops up. So i manage to locate those same files and get it running. I recently upgraded to windows7 pro and the media direct worked fine,i was able to watch blu-ray without a problem. However just recently, it has stopped recognizing my disks. regular DVDs work fine,but pop in a blue-ray and i hear it spinning but does not recognize the disc.I have popped 5 different ones in, and none are recognized. The problem is that Dell does not care, they sold us this lame blu-ray drive that they never supported, the quality is horrible, it burns regular cds at 1x speed, that is just too slow that i don't even bother using it to burn.i would send it in for waranty service,but i know they will say that i have windows 7, and they only support it with vista. Now i did read that there was a 4.5 version of Media Direct that fixes these issues, but i have yet to locate that anywhere on the dell site

  • Hey guys,


    So I just transplanted a UJ225 into my M1530 (I bought one off of eBay because I decided I wanted Blu-Ray). Since doing so I've run into the exact same problem you have described above. I've got two different playback software (PowerDVD and WinDVD) and both tell me that there is no disc in the drive when I have a Blu-Ray inserted. DVD's work just fine and I assume CD's do as well. I'm wondering if anybody has found a solution since then? Thanks.

  • Since mine was still under waranty, and the del online tech couldnt find a solution, they dispatched a servic tech to replace the drive. So i have a new drive, same model but so far no more problems. I cant find the firmware number and for some reason first DVDs i played i had to set the region code to 1 although it was already at 1, it kept saying it was version free. its been 3-4 weeks now and no problems.

  • I see....

    Well, I've seen some people cleaned it with a laser cleaner disc so I'm going to try that before calling it DOA. I do have the option of exchangeing it, but I don't really want to mess with an eBay exchange if I don't have to. One, I just hate dealing with other people who think their product is just fine. Two, it is slightly risky and more than inconvenient to remove the drive and put the old one back in, and then do it all over again in two weeks when I get a replacement drive. It's a BIG pain. Does anybody else know something else to try before it comes to that?

  • Hi.

    Have you read my post ( calgal110). Here is the copy ------- I found  that Nvidia release GEFORCE driver update yesterday for windows 7 32-bit and 64-bit. It helped me, I can play my blu-ray movies right now. Here is the link for 32-bit version. http://www.nvidia.com/object/notebook_winvista_win7_186.81_whql.html.

    It is for 32-bit, but you can go and find for 64 , also.

    I  know it is from last year August 2009, but I bought just two months ago new Windows 7,( I used before release candidate) and I had the same problem as before. I could not play my Blu-ray movies. I tried a lot of options, update Power DVD, find new Nvidia drivers and so on... Finally I remebered what I did last year and that those- now old--Nvidia drivers work. I installed it for my Win 7 64-bit and since then I can watch my blu-ray movies.

    I hope it may help you or give you some directions to look for solution. Altough I think my Power DVD software did know that there was a disc inside the DVD slot, just requested updates. So maybe that the drive is just not working...




  • Thank you for the information, but I don't think that's it. It seems to be a hardware issue, not a software one, because even Windows Explorer won't let me see the contents of the disc because it doesn't think there is a disc inserted. I tried a lens cleaning disc to no avail. I'm just going to chalk it up to a bad blue laser in my drive. I suppose now I'll just tear apart my laptop again and send it back. Oh well :(

  • Hello I won an alienware m51 9750. I have the UJ-220S in it. When I converted to Windows 7 it stopped reading blu ray disks.  I looked at the driver and it is from 2006. I have tried looking for a newer driver and cannot find one. I have uninstalled the driver and windows 7 keeps installing the same old driver. When I go to update it it states  you are using the most up to date driver. I have read many posts like this o the web. The all state DELL is responsible to have a newer driver available.  What can I do?