XPS M1530 CD ROM drive not ejecting

Disk Drives

Disk Drives
Disk Drives (Floppy, USB, HDD, CD/DVD/BD) discussion

XPS M1530 CD ROM drive not ejecting

This question has suggested answer(s)

yes yes yes,

it finally happened. I've inserted a dvd into the rom and now it won't eject... I called tech support for help. They said they were going to get a techie to call me within 24hours. It has now been more than 3 days...


Should've bought a mac...


Gonna call them again... maybe i am not important to them...

All Replies
  • Hi, Shazeeishak:

    Your tag indicates a code 10 error. Are you getting such an error?

  • The same thing just happened to me. I have an M1530 also, and my CD/DVD drive was working fine. Like a week ago, I installed an old Star Wars game that always had trouble running under Vista, and I finally got it to work. So now I'm done playing the game, and I try to eject the cd, and it won't come out!!! I thought it was no big deal, but I've been trying to get it out, and I can't. Also while double clicking on the icon for my Star Wars game, I kept getting this error message from Securom telling me to insert a legal copy of the game and not a back-up. But I do have a legal copy of the game. Can somone help me?Sad

  • Hello all -I recently purchased an XPS 1530 and love the laptop. The only issue is the cd-dvd drive will not read or burn any file discs. I have installed the reccomended driver and each one of the burning software(s) i use seems to execute the process - however I still continue to burn "choppy" data discs, and when I insert the newly burned cd-r back into the laptop - it does not identify the disc. I also inserted a HP printer installation disc to install my printer - which did not it did not read. Is this a clearly a hardware issue? or are there any quick solutions to the problem? Im running on vista 64

    thank you -

  • Hi, I have a Vostro 1510 and have the same problem - CD drive not ejecting. Have spent hours attempting to get help from Dell and Microsoft all to no avail. I would appreciate some help please. But please try and keep it simple I am not familiar with computer jargon and need to be told exactly where to look for things. Cheers! Jim300 Germany. I haven't seen any error messages - have simply been pressing key F10 and nothing happens.

  • I finally got my cd to eject!!!Smile What I did was restart the computer, and while the operating system is loading up, press the eject button. My disk came right on out. I hope this helps you.

  • Any other ideas?  That didn't work for me Crying

  • Did not work for me either.  I am 758 in line to chat with tech support, which is the only way I can find - other than an old fassion phone call - to start a support ticket.  The slot loading drive is great EXCEPT that there is no manual eject like a tray.  Thank heaven for the 3 year warranty I bought....



  • Be glad you bought the 3 year warranty.  Odds are the drive will have to be replaced.  Before it stopped ejecting it was burning choppy disks.  I thought it was the program or something I was doing wrong.  It wasn't.  I followed all the advice here on trying to get the disk out.  I finally had to find where they tell you how to disassemble and M1530, take it all apart, take the drive out and then get the disk out.  I would rather have dental surgery or give birth than go through that again.  I had to do it twice to take two different disks out.  I finally gave up and bought an external dvd burner.  I haven't had a lick of problems with the USB burner.  As a matter of fact I've burned better disks than I ever have before and do it in record time. 

  • I have the same problem with my Dell XPS M1530 .  After inserting the samll disc i coudn't eject it so i flipped the laptop over and hit it on the back and it came out. But now it won't read or burn any CD. it keep telling me to insert  a disc. any idea why? plz any help is appriciated.

  • I'm afraid you may have voided any warranty you have.  I don't know for sure and don't construe what I'm saying to be professional advice or even in any way Dell approved.  The thing is, your manual that came with your computer states that small discs are never to be inserted.  That type of drive can not handle them.  Personally I don't think that in itself would have stopped the burner from working, the hit on the back may have.  Smacking it like that may have damaged the laser or the mechanism that controls it.

  • Even i am using dell m1530 model.Some virus affected my laptop.So i formated and installing xp os.But some files in the CD are corrupted

    and os not installed.Now i dont know how to take the CD out.There is no eject button or tray.Someone please help me to take the CD out and

    installing the os.Thank you and sorry for my bad english.

  • HI

    i have the same problem my computer: dell studio xps 1640. I just set a dvd in the drive and it say a sound like the normal sound it say but difrend like one long sound and now i stuck, i cant get it out.

    i wrote to the dell suport and they say:

    1) Turn the machine upside down and eject the disc - gravity gives you a little bit of a boost and often times will wiggle it out.

    2) If the disc is just barely visible, actually jar the machine (don't hit it on something) but shake it and stop it abruptly, and often times the disc will come flying out.

    3) You may also try this video guide:

    4) Please try to press the eject button ( or keyboard Combinations ) while in BIOS:
    Power up the PC, or if the PC is already turned on, shut it down and then power up the system.
    Press F2 during the first few seconds, while the initial Dell logo is on the screen, to enter the BIOS.
    When finished please press Esc to exit.

  • Hi, I had the same problem and this is how I fixed the problem: (I'm using Windows 7, but I'm sure it should work on previous OS's

    Right click on My Computer

    Go to Manage

    Go to Device Manager

    I then clicked on the drop down for Disk Drive

    Right Click on your disk drive and scan for new hardware

    Your cd/DVD rom drive will show up

    Open Windows Explorer, see your dvd drive, right click and select eject

    This may not fix the possiblle 'core issue' but at least you should be able to eject the disk.

    This worked for me, hopefully it will work for you as well...


  • Turn your laptop upside down and press the eject button.  It worked for me.

  • I have a similar case here but turning my laptop upside down didnt work for me.

    Here is what I did. When the eject button is pressed there is a cd blocker in the middle of the slot thats moves downwards so as to allow the cd to eject. However this cd blocker moves up prematurely before the cd ejects thus blocking cd and there's our problem, the cd wont eject. What I did was I get a small screw (flat) driver or anything that has thin point at the end. Press the eject button and try to feel the cd blocker thru the screw driver and you can feel the movement of that blocker as it glides up and down. Press the eject again and thru the screw driver try to prevent the blocker to move up before the cd ejects. It didn't work for me at first but a couple of tries I got the best technique. Good luck!