Problems with Solid State Drives on Latitude D630

Disk Drives

Disk Drives
Disk Drives (Floppy, USB, HDD, CD/DVD/BD) discussion

Problems with Solid State Drives on Latitude D630

  • We recently purchased some Latitude D630s with the new 32GB Solid State Drive option.  We have been noticing that they are all hanging quite frequently whenever there is a period of sustained access to the drive.  Basically, the hard drive light will be solid green and the system becomes completely unresponsive until whatever background task that is running is completed.
     
    This is happening with both Windows XP Professional and Windows Vista Business.  Has anyone else with solid state drives been experiencing any issues? 
     
    We have done all driver and BIOs updates without any improvement.
     
    Thanks,
    Jason
  • YES...  Huge problems.  It just goes away mosting with Outlook but occasionally with IE.  I thought is was a Outlook 2007 issue so I downgraded to 2003 but still no joy. 
     
    This is a major issue.  I have upgrade the bios to the latest & greatest.
  • Well, I just disabled the flash cache module, set the ATA controller to ATA mode instead of AHCI, and reinstalled the OS.  I will let you know if it improves anything.  That is my only thought at this point.
  • That's sounds very painful.  I have a week left before my 30 days are up.  I'll just send it back on go to back to my trusty 620
  • Any luck?  I am having these issue's as well
  • Same problem here. Very disappointing. The write speed of SSD is about 3 times *slower* than the exact same laptop with a regular 120 GB drive. The read speed is great, but the system is hanging way too often. Also, whereas XP would probably be OK with a 32 GB drive, Vista is horribly bloated, and *keep* growing each time you update it.
  • I have the 32GB on a D630 with XP sp2.  The problem is being ignored by Dell.
  • What SSD do you use? So far, I do not have any problem with my Samsung 32GB SSD in the X1. I used it for Win XP and now with Vista installed.
  • It was a Sandisk. I was not aware Dell was shipping 32 GB Samsung SSD (they weren't at that time), *but* I replaced my 32 GB Sandisk with the new 64 GB Samsung SSD, and it's working *much* better. It's about 3 times faster on write than the previous, marginally slower than a regular disk, and still about 20 times faster on read.
  • Could you please tell in what mode your SSD works (in the Device Manager select IDE ATA controllers -> Ultra ATA Channel -> Advanced Settings)? Is it Ultra DMA Mode 2 or 5?
  • There is no such setting on my Vista system. I see: + IDE ATA/ATAPI controllers - ATA Channel 0 - Intel(R) 82801HEM/HBM SATA AHCI Controller - Intel(R) ICH8M Ultra ATA Storage Controllers - 2850 None of these 3 entries provide any info about Ultra DMA settings in the Properties dialog (and/or "Advanced").
  • Double click on the ATA Channel 0 and select the Advanced Settings tab.

    Message Edited by aseasyas2x2_4 on 01-04-2008 10:19 AM
  • I probably wouldn't buy two SSD's if I didn't know how to use the Device Manager, would I? As I said. No such setting, sorry.
  • Don't worry - it is as easy as 2 x 2 = 4 (read below).

    Message Edited by aseasyas2x2_4 on 01-04-2008 11:36 AM
  • It should look something like this (if you did not connect your CD-ROM drive, you will see only one ATA Channel 0):


    Checking DMA In Windows Vista

    Message Edited by aseasyas2x2_4 on 01-04-2008 11:21 AM