DVD/CD rom drive wont play DVDS?!?

Disk Drives

Disk Drives
Disk Drives (Floppy, USB, HDD, CD/DVD/BD) discussion

DVD/CD rom drive wont play DVDS?!?

  • Well my problem started about almost a month ago..my drive would not detect DVD movies I would put in. It detects CDs and backup copies of my own collection of movies that I have made but it will NOT read rented movies or current movies that I own(not backup copies).The light continues to blink as If it was trying to do something but nothing happens. I also tried to open the movies manually but like I said the drive doesen't even detect anything in the drive. I have talked to seveal technicians and this is what they told me to do:
    1.Update my drive
    2.Update my firmware
    3.Update my cineplayer
    I did all of the above and nothing worked at all. I actually came to the Dell website and downloaded the Cineplayer update(  Sonic CinePlayer 3.x Patch.) because I noticed some people were having problems with that so I figured I would give it a shot.Still it did not work..but I did  get this error -
    Alert: This update is not designed for the application version you currently have installed.''
    What does this mean? The installation did complete all the way it said.
     Someone has mentioned that my movies might not be the right region..they are all Region 1 and my computer is set to play all region 1 movies.
    I also downloaded other software to play my DVDS but nothing has worked.
     Please keep in mind that my drive does play the follwing
    -Backup Copies of Movies
    -Audio CDs
    But will NOT play rented movies or my personal home collection movies.
    Please help me...I am willing to try any ideas you can provide to me. Here is some of my computer Information      Dell Dimension DE051 running with Windows XP home edition. My Hard Drive is
    I also ran Autoplay Repair Wizard from Microsofts help center and this it what it said.
    AutoFix [V5.2.3790.67]
    Time [2007-05-03 21:37:58]
    Microsoft Windows Version [5.1 (Service Pack 2) <2600>]
    Test [The Shell Hardware Detection service is running.] - Instance [N/A]:
        Result [AutoStart Setting]: OK
        Result [The Shell Hardware Detection service is running.]: OK
    Test [Policies] - Instance [D:\, Drive Type: 5]:
        Result [HKCU\...\Policies!NoDrives]: OK {Absent}
        Result [HKCU\...\Policies!NoDriveAutorun]: OK {Absent}
        Result [HKCU\...\Policies!NoDriveTypeAutorun]: OK {Present}
        Result [HKLM\...\Policies!NoDrives]: OK {Absent}
        Result [HKLM\...\Policies!NoDriveAutorun]: OK {Absent}
        Result [HKLM\...\Policies!NoDriveTypeAutorun]: OK {Absent}
        Result [Driver level policies]: OK {
            HKLM\...\Services\cdrom!Autorun (Present) <Allows>
            HKLM\...\Services\cdrom\Parameters!Autorun (Absent) <Allows>
            HKLM\System\CCS\Enum\...!AlwaysEnable (Absent) <Not set>
            HKLM\System\CCS\Enum\...!AlwaysDisable (Absent) <Not set> }
    Test [Drive Notification] - Instance [D:\, Drive Type: 5]:
        Result [Legacy Notification]: Problems
        Result [AutoPlay V2 Notification]: Problems {
            Service (Silent)
            Shell (Deaf) }
        >> Repair << [Legacy AutoPlay Event]
          Step: No steps to take.
          Result: This AutoPlay setting cannot be fixed. Either the device is malfunctioning, or the wizard cannot determine the problem.
        >> Repair << [Autoplay V2 Event]
          Step: No steps to take.
          Result: This AutoPlay setting cannot be fixed. Either the device is malfunctioning, or the wizard cannot determine the problem.
    >> Required action: The wizard found problems but cannot fix them -> None
    Iv'e searched the web and alot of people seem to have this problem and noone knows the solution for it. I also uninstalled my drive and rebooted my computer and it automatically reinstalls the drive and still it wont work.  Any information I would appreciate it.


    Message Edited by Mango23 on 05-03-2007 09:12 PM

  • Hi Christina,

    I have been reviewing your previous thread on this issue as well. I am assuming these back up copies you have made are on DVD`s, not CD-R discs, correct?
    Also you have tried other decoding software such as VLC but Dell did not send you the discs for the Cineplayer so uninstalling/reinstalling it is moot for now, correct?
    Have you recently updated your video card drivers or DirectX?

    Best Regards!

    God, grant me the senility to forget the people I never liked anyway,
    the good fortune to run into the ones I do and the eyesight to tell the

    CD/RW Link


    "Live Free -- Die Hard"

    Forum Member since March 1998

  • Yes, my backup copies are on DVDs and not CDs and yes I have tried several decoding software with no success.And Dell would not send me another Cineplayer disc because my warranty is over.
    I have not updated my video drivers nor Direct X. Please inform me on what these softwares are and what they do. Maybe this is the problem. Thanks again for your help,I really appreciate it.
    P.S I just remembered I do keep getting this little widow that pops up. It says that there is a Java Update available.Does this have anything to do with why my computer not being able to read DVDs?

    Message Edited by Mango23 on 05-07-2007 12:14 PM