Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)
Results for XPS 420
View more results: All Community | Desktop
  • Forum Thread: PSU Replacement

    Hey All, Apologies if this is in the wrong thread, but this evening I had a problem with my Dell XPS 420. When I turn it on, the unit keeps turning on and off even after the 10 second reset. When I push the power button the system tries to turn on as normal, but then it shuts off. The process keeps...
  • Forum Thread: XPS 420: HOW DO I INSTALL A "GT220" GRAPHICS CARD?

    Good Day: I have purchased: GeForce GT220 1 GB DDR2 PCI Express 2.0 Graphics Card, to replace my present graphics card. I understand this should be a relatively simple process. Is it? How should I proceed? I thank you, kindly.
  • Forum Thread: xps420 Q9400 error message after inserting new ram

    hi all, had just purchase a Silicon Powered Ram (DDR2 800 PC2 6400, 2GB), but after inserting the ram, the system will not start. the following error message is displayed "memory modules are detected but a memory configuration or compatibility error has occurred" am currently have...
  • Forum Thread: XPS 420 and ATI RADEON HD 5770 Questions

    Hello, I have DELL XPS 420 and I'm want to upgrade my video card. I bought this computer last year here are the specs : Core 2 Quad E6600 2,4 GHZ 4 GB RAM ATI RADEON 4650 HD Will ATI RADEON HD 5770 fit in to DELL XPS 420? If so, will the stock power supply 450w (On label it says...
  • Forum Thread: Curiosity Question - ATI Radeon HD 2600 XT

    According to CCC my XPS420 has an ATI Radeon HD 2600 XT video card, which includes 256MB of RAM. Can anyone tell me whether this card will ever use any system RAM or fooes it only ever use the on-board 256MB? I'm just curious to know if any of my 3GB of system RAM is used by the video card.
  • Forum Thread: XPS420 Possible graphics card fault

    Hi all I have been having problems with my XPS 420 PC over the last 2 weeks. First it would take a minute to boot up the PC and then it was taking 5 minutes to boot up the PC, lights 1 2 and 3 were coming up on the diagnostic panel. over the last few days, the PC failed to boot up, So i cleaned...
  • Forum Reply: Re: Sound Recorder not working

    Many thanks firebird. I got the sound recorder working. Made two fatal errors. First did not know that sound I wished to record had to input through the microphone jack on the sound card. Then I read and followed the Sony receiver instructions to get sound output from the receiver jacks to the...
  • Forum Thread: Is there a fix, driver, audio card that will give me What U Hear?

    I have been researching this issue endlessly! Other than a cable loop patch, there has been no solution given me to make STEREO MIX, WAVE OUT, or WHAT YOU HEAR an option on my audio card. I have Dell XPS_420 and a SB integrated audio card. Creative told me, after wasting time trying to troubleshoot the...
  • Forum Thread: Bluetooth Headset and poor sound quality

    I have a great Sony DR-BT22 Bluetooth headset; I know it's great as it connects immediately to my Latitude D620 and Sony Ericsson Phone and produces great sound quality from both. However, with my XPS 420 not only do I have to change some config setting (ok I can live with that), the sound quality...
  • Forum Thread: XPS 420 and 430 Vista 32 bit X-Fi card issue

    I have an XPS 420 and a 430 in different locations and both suffer the drop-outs and screeches from the OEM sound card (Soundblaster X-Fi Extreme PCI card) that many have described in these forums. Both run Vista 32 bit SP2. Indeed, though I cannot be sure, the problems seem to be associated with...
  • Forum Thread: Supreme Commander vs XPS 420 & SigmaTel

    [important] this is a copy from my blogpost on my own website, hope this helps other people with the same problem. to Dell Support, I hope you'll adopt this solution and get the updated driver on the support website! (in the right spot) As so many people have found out: the default Dell SigmaTel...
  • Forum Thread: No Sound Using XP on Dell XPS 420

    Read some posts out on cyberspace about converting operating system from Vista to Windows XP. Does anyone have a step by step procedure to resolve the issue of no sound. I have tried a number of drivers for various systems but none work. Does anyone have the answer. I need my hand held when it comes...
  • Forum Thread: google plus

    I heard that dell was thinking about using Google plus for support i think this is a great idea. The video chat feature would be like text support on steroids, making it a lot faster and easier to find a solution to your problem copy and paste this in a new forum if you think dell should use Google plus...
  • Forum Thread: Restoring an XPS420 with Norton Save and Restore, and a network disk

    Hello all I have a Dell XPS420 which came (Jan 2008, I think) with Norton Save & Restore (v2.0) pre-installed, running under the Dell-supplied Vista 32. The system includes a Dell-supplied Intel-driven RAID array - each 320gb physical disk in the array being partitioned as logical drives C, D...
  • Forum Thread: What power supply does my dell i have

    I bought a dell xps 420 from wal-mart last year http://www.walmart.com/catalog/product.do?product_id=9864593 . A friend bought me a new video card for it a ati raden hs 4650 and it says the power supply needs to be at least 400w. I looked at the specs on the dell website but it list them for the duo...
  • Forum Thread: XPS 420 very slow to boot into vista

    I apologize in advance if I have posted in the wrong place, I am new to the forums. My XPS 420 appears to function normally in every way except for its painfully long boot time. The problem started just yesterday afternoon. After power on, the Dell splash screen appears as normal. This is replaced...
  • Forum Reply: Re: Portable devices not showing on my control panel.

    You're absolutely right - this stumped me for a while until I stumbled on the solution - why Microsoft decided to do this in Windows 7 I cannot imagine. I can only think it is a mistake on their part. My solution was slightly different - In the "Folder and Search Options" panel I put...
  • Forum Thread: Startup issues with XPS 420

    Excellent machine, until last night. What happens: Power on ok, switch has a blue background. Fan runs at high speed. Diagnostics lights 1, 3 & 4 appear. The manual does not include a description for this sequence. Nothings else happens, no POST or anything on the screen. Have...
  • Forum Thread: Looking for advice on new psu for xps 420

    Explanation: xmas 2011, I bought a new graphics card for my xps 420 , not a particularly expensive new g.card but one that was a significant upgrade from the ati radeon 2600 hd that came with the system when I purchased it back in 2007. Im not exactly the biggest techy, this was the first time...
  • Forum Reply: Re: XPS 420 Error lights 1-2-3 No boot

    I am experiencing the same problem with my Dell XPS 420 . Until recently it worked fine, but now if I shut it down completely, it will not restart and displays Diagnostic Lights 1, 2, and 3 . I cannot access the BIOS as it doesn't reach that point, however I can see a blinking white cursor at the...
  • Forum Thread: Dell XPS 420 Graphics Card options

    Hi people I have a Dell XPS 420 which was shipped with a 256mb ATI 3650 GPU. First question, does dell have special editions of this card? As all the retail versions are equipped with Dual DVI and S-video, where as my card is equipped with DVI/Display Port/HDMI. Is this dell card any better at...
  • Forum Thread: Error Code 2000-0147 XPS 420

    Forgive the vague terminology i am abit of a tech newb, At first my dvd rw disc drive stopped working, disc tray worked fine but the computer wouldn't recognise that a disc drive even existed nor would it read any cd's, i searched for days for a solution with no luck, i have the original OS...
  • Forum Thread: XPS 420 Steady Amber Light (Possible Pre-Bios Failure?)

    Hello all who could possibly help. I have had a xps 420 since 1/4/08 and have never had any problems. I'm not a big "computer person" so to speak, so i need some help. The other day, my computer shut down, and whenever i try to reboot it, it goes right to a steady amber light on the...
  • Forum Thread: will this work with my XPS420?

    as above i wish to upgarde my graphics card in my dell xps with the one below ATI Radeon HD 5770 XXX Edition 1024MB GDDR5 PCI-Express Graphics Card Thing is , it says it needs 500w to run and from what i found on google the xps420 has a 425w psu. So does that need to be replaced as well or do you...
  • Forum Thread: XPS 420 - Possibe to upgrade to new Core i7 chip and mobo?

    Is the new XPS 420 still BTX or have they switched to ATX? Would it be possible to upgrade to the new Core i7 or are prices so low that is does not pay to upgrade?