Plz help gtx 670 in dell xps 8300

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

Plz help gtx 670 in dell xps 8300

This question is not answered
I got a new gtx 670 for my computer and it is a dell xps 8300 I did upgrade the power supply to a evga 750w that's the only mods I did to it I can't get any video out of the card plz help the onboard video takes over as primary video. And the new card doesn't override the onboard. Acts like there is nothing there. Also everything is hooked up, fan turning, signal out but no video. the bios there is no option to descreite video card as default
All Replies
  • There have been reported issues from others about problems with both the GTX 670 and GTX 680 not working on the XPS 8300 and I have seen no clear answer on getting them to work.  The 7900 series from AMD which offers the same performance has been confirmed to work, however.  

  • Hi guilbo31,

    You can get this video card working by updating the BIOS of computer and video card.

    Unplug the video card from the system and update the BIOS from the support website by entering your system service tag. Click Here 

    For updating the vbios of video card you can follow the steps given here : http://www.evga.com/forums/tm.aspx?&m=1703680&mpage=1 

    (For updating the vbios of your video card you might need to connect the video card to an alternate system if it doesn't work on your XPS 8300)

    Hope this helps. Do reply if you have further questions.

  • Unfortunately, Dell is not updating the XPS 8300 anymore with a new bios as mentioned by other members and I think only EVGA offered a video bios update specifically for the XPS 8300 where other manufacturers did not.  Just make sure you have the most recent system bios for any luck at all.