Blue Screen error with atikmpag.sys in Windows Vista/7 x64

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

Blue Screen error with atikmpag.sys in Windows Vista/7 x64

This question has suggested answer(s)

Hello,

My XPS 435MT system with ATI Radeon HD4850 video card is 3 years old and I can safely say I have never had a problem until now. At first I thought it was a virus, but a complete format and system reinstall haven't fixed the problem. I've tried different versions of drivers (new, old, dell factory) and the issue persists. My screen turns into a checker board so to say and then throws a blue screen with atikmpag.sys error. Sometimes I can work on my machine for days without a problem and sometimes it would come up just after a simple reboot or launching a flash video.

Upon further investigation it was determined the conflict lies between my video card and motherboard. As described by other users with a similar problem here is the cause:

"The problem was that the motherboard (which is like 2-3 years old) had a too old VGA Bios version and the solution is obviously to update it."

(full thread can be found on microsoft forums at http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/blue-screen-error-with-atikmpagsys-in-windows-7/5f0aebb6-b9b6-4a5d-a622-97c62dbb3d66)

As you can see my situation is exactly the same. I've looked for BIOS drivers for my system and the only update I found was released later in 2009 which still means that my VGA Bios version is almost 3 years old.

My question is if Dell plans on releasing any BIOS updates to fix the issue? Other motherboard manufacturers keep their products up to date and I do believe that 3 years is not enough to stop support. It is ridiculous to think that I should be upgrading my hardware even though there is absolutely nothing wrong with it. I need to know where to go with this and who I should be addressing this to. My warranty has expired but this has nothing to do with it. Thank you for your help in advance.

All Replies
  • Hi mUrZ,

    Do you have the current BIOS? What's the error?

  • It could also be an overheating GPU.  Once they get damaged there is no amount of Bios updates that will fix them.

    The microsoft post talks about a DirectX 11 video card 5XXX series not 48XX series directX 10 card.

    There is no such broad extrapolation between VBIOS.

    Overheating occurs when dust and pet hair clog the fins of the heatsink on the GPU.

    The DirectX June 2010 patch should be installed.

    The ATI Catalyst drivers are up to 12.XXX

    Report Unresolved Customer Service Issues here

    I do not work for Dell. I too am a user.

    The forum is primarily user to user, with Dell employees moderating.

  • I will post the error message once the issue reoccurs. At this point I'm not ruling out any possible issue, but my research of this error message points to outdated BIOS.

    The thread that I provided originally is just a single example since I didn't want to flood the thread with multiple links. All I have to say is that this issue occurs with 48XX series cards as well.

    I checked the fan while PC was ON and it was running at full speed and the reason why I'm not concerned about dust and pet hair is because the card was recently taken out for cleaning. I'm running both the latest ATI drivers as well as the latest Direct X

  • My experience is that you must use Hot water to flush the deadly dust bunnies out of the card.  When you do this you must then dry the card and then check the heatsink again.  Some require removing the dust buster shroud from the heatsink to expose the clogged fins.   Many take the heatsink off to clean it but I'm lazy.

    If you have Cats then the answer is overheated clogged GPU.

    Report Unresolved Customer Service Issues here

    I do not work for Dell. I too am a user.

    The forum is primarily user to user, with Dell employees moderating.

  • I would not recommend using hot water to clean a video card. Normally one of those compressed gas cans is all you need.

  • Don't EVER use water on electrical components! Only destilled water is "safe", and even then, you may end up with something in the water which leads to short circuiting.

    What I would recommend:
    1) Compressed air in a can
    2) Pure alcohol and q-tips
    3) Anti-static head for your vacuum cleaner

    Number one is the easiest to do and safest if you have no clue! ;)

  • I've done the hot water trick numerous times. That's why I mentioned that some take the heatsink off.

    I did not say Immerse in water although some have done that as well.

    YMMV

    Heatsink Cleaning (?) - Coolard|Forum

    Do you clean your heatsink. - Overclockers Forums

    Heatsink blew all the dust off then soaked it in really hot water

    Report Unresolved Customer Service Issues here

    I do not work for Dell. I too am a user.

    The forum is primarily user to user, with Dell employees moderating.

  • Sorry guys for a lengthy reply (long weekend). As mentioned previously, my VC has been recently taken out for cleaning (no water used) and yesterday I've taken it out again just to double check. The card looks like new.

    The reason why I'm skeptical about clogged GPU being the reason for my troubles is because sometimes the problem occurs even as soon as I start my PC after leaving it off for a couple of days. By the time I get to the logon screen my display turns into a checkers board and crashes. That's less than one minute of operating. I have difficulties believing that a card can overheat in about 30 secs.

    And to complicate the matter worse, at other times I can work on my PC the whole evening without any problems. Something is triggering it at completely random times. Mystery..

    What I posted originally is the only solution that seemed to work for other users with the same error message.

  • I would like to add one more thing. After a crash when I boot up in safe mode everything works just fine and I can go about doing pretty much anything I want without crashing whereas in normal mode my PC would already crash if I did any of that stuff

  • Studio XPS 435MT Vista Home Premium / i7 processor / 6gb RAM / 2.67ghz / 360 W PSU

    Radeon HD 4670 512mb

    AVG free version / Heavy Adobe CS4 user (Photoshop) / Not a gamer or heavy video user

    I have the same problem.  BSOD resulting from atikmpag.sys and dxgkrnl.sys.  I updated my BIOS driver to 1.1.4, which, as of now, is the latest available on Dell's website.  Here are my steps to date:

    1. Debugged: found atikmpag.sys dxgkrnl.sys / bsod error x116 (VIDEO TDR FAILURE).  There has been one other bsod (page error).

    2. Update Drivers:

    (a) clean boot while updating ATI's driver (with and without Catalyst Control Center);

    (b) updated BIOS to 1.1.4, and all other recommended updates on Dell;

    (c) downloaded DriverMax to confirm latest drivers and performed recommended updates

    3. GPU

    (a) cleaned GPU (and all other internal components) with compressed air (removed fans to clean);

    (b) left side panel off for several days to cool GPU: no improvement;

    (c) tested GPU performance with CPU-Z: temperatures are fine

    4. Tested memory

    (a) memtest86: no errors found in 21 passes (around 26 hours);

    (b) remove memory sticks one by one: blue screen on each stick / mobo slot

    5. Ran internal Dell diagnostic utility: no errors found

    6. Ran antivirus / anti-malware applications: nothing bad located

    7. Replaced memory to 16g Crucial sticks (4x4).

    This happened suddenly after three years of ownership without any issues.  Dust buildup was considerable, but very clean now.  I've read in forums that this problem persists even after OS reinstallations, GPU / PSU / MOBO / Memory replacement, and even switching to an Nvidia GPU—I'm not too motivated to take those steps if this is a problem that needs to be addressed by Dell or ATI. 


    Please help.

  • Yeah, nobody from Dell cared about addressing the problem. OS reinstall won't help and changing any other parts besides your video card is useless.

    I ended up replacing the card with ASUS ATI HD6450 and the problem disappeared. It's sad because now I have a perfectly working video card sitting on my shelf which I cannot use only because someone else lacks providing support for their product. Oh well... Lesson learned.

    Good luck!

  • I'm inclined not to spend any more money to support Dell's dysfunctional product.  I know Apples are expensive, but I'm really impressed that they actually function for longer than three years.  Seems worth the extra money...

  • Not a big fan of Apple. You pay the extra money for the brand and not necessarily for the quality.

    The only valuable lesson learned here that it's actually better to buy separate parts from other reputable manufacturer brands rather than Dell. Other companies that sell motherboards have listened to the community and provided respective updates to fix the issue. They care about the products that they sell.

  • I got some advice about DirectX 10 from SpeedStep (see above)—did you try to install DirectX 10?  I'm curious to know if that worked for you, and also if you tried that after or before the hot water cleaning. 

    Any suggestions as to a good motherboard replacement?  Video card?  I use Photoshop heavily...

  • If the gpu overheated and is now damaged a newer one will fix this.


    ASUS EAH6670DIS1GD5 AMD Radeon HD 6670 1024MB GDDR5 PCIe 2.1 x16 Video Card

    or

     HIS H775F1GD AMD Radeon HD 7750 1024MB GDDR5 PCIe 3.0 X16 Video Card

    Newer Apples will have the 6XXX series or worse INTEL HD graphics.

    The High end mac mini or even more expensive IMAC versions would have a 6XXX GPU.

    Apple Mac mini MC816LL/A Desktop Computer
    SKU: 742841
    Buy new $799.99

    Apple iMac MC309LL/A Desktop Computer
    SKU: 500983
    Buy new $1,199.99
    Intel® Core i5 Quad Core Processor 2.5GHz

    • Mac OS X 10.7 Lion
    • 4GB DDR3-1333 SDRAM
    • 500GB 7,200RPM Hard Drive
    • 8x SuperDrive with 4x Double Layer Burning DVD±RW Drive
    • AMD Radeon HD 6750M
    • 10/100/1000 Network
    • 802.11n Wireless
    • Bluetooth 2.1+EDR
    • 21.5" LED-backlit Widescreen TFT Display

    Dell's answer to this would be the high end XPS One 27. $1899

    XPS One 27" — All-in-One (AIO) PC | Dell

    XPS One 2710 XPS One 2710 Fast track 1322
    OPERATING SYSTEM Windows® 7 Home Premium, 64Bit, English
    PROCESSOR 3rd Generation Intel® Core™ i7-3770s processor (up to 3.90 GHz)
    HARD DRIVE 2TB 7200RPM SATA 3.0Gb/s Hard Drive + 32GB Solid State
    OPTICAL DRIVE Blu-ray Combo Drive (Reads BD and Writes to DVD/CD)
    MONITOR Non-Touch 27" Full High Definition (2560x1440) WLED Display with Webcam
    VIDEO CARD NVIDIA GeForce GT 640M 2GB GDDR5
    WIRELESS Intel© Centrino© Advanced-N 6235, 2x2 agn + Bluetooth
    KEYBOARD Dell KM713 WL KYBD and MSE English SIB
    MOUSE Mouse included with Keyboard purchase
    SOUND CARD Integrated 5.1 with WAVES MAXXAudio 4
    TV TUNERS Hybrid Digital ATSC/QAM analog TV tuner Card
    Network Card Integrated 10/1000 Ethernet
    Documentation English/French Documentation
    Adobe Reader Adobe® Acrobat® X Reader Multi-Language
    Power Cord US Power Cord
    Wireless Driver Dell SRV Software 6235
    Ship Material Shipping Material, Direct,Non-touch
    Additional Software Additional Software
    Optical SW Win7 Home Premium, Professional and Ultimate - BD-Combo
    Additional Settings Dell Offers More, Digital Delivery

    Report Unresolved Customer Service Issues here

    I do not work for Dell. I too am a user.

    The forum is primarily user to user, with Dell employees moderating.