Dell ST2420L Monitor is Blurry

Desktop

Desktop
Desktop computer Hardware and Software discussion

Dell ST2420L Monitor is Blurry

This question has suggested answer(s)

I have a brand new Dell 24 inch wide ST2420L monitor with a Dell bundled ATI Radeon HD5670 graphics card for use with my Studio 9100 XPS system.  The text is blurry and I can't seem to find any settings to clear it up.  Does anyone have any suggestions before I call Dell support.  Right now I am using a VGA cable to connect the computer to the monitor, but the HDMI cable makes it worse.  Cleartype is turned on.

Thanks in advance for any suggestions that someone might have will be greatly appeciated

All Replies
  • The first issue is to determine if it's the monitor or the video card.  Do you have another monitor that you can connect to try? or do you have another PC that you can connect the monitor to, to try and isolate which is the problem.

    Until it's verified which is the problem you are at a standstill.

    I am not a Dell Employee

    Dell forum member since 2002

    Home Built PC with Gigabyte GA-Z77X-UD5H motherboard, i7 3770 CPU,  Windows 7 64 bit Home/Win 8.1.  SSD drive.  Sonar X3c 64 bit Recordng Software.

     

    Member of Nashville based R.O.P.E.

  • Thanks for the info.  Dell replaced the video card and install a DVI cable, but still no change.  I tried my old monitor that worked perfectly using Windows XP and now with Windows 7 usingit on  my new machine I still have the same problem with blurry text.  Some internet research seems to indicate that the problem exists with Windows 7 and the Cleartype text.  I just don't seem to see a way out of the problem right now.  It looks like a Microsoft problem.

  • Have you tried adjusting the clearType text? control panel>display and in the left pane, adjust cleartype text.

  • Also, if you haven't done it, get the latest drivers for the video card.  HERE is the HD5670 Drivers download (including the Catalyst Control Center).

    I am not a Dell Employee

    Dell forum member since 2002

    Home Built PC with Gigabyte GA-Z77X-UD5H motherboard, i7 3770 CPU,  Windows 7 64 bit Home/Win 8.1.  SSD drive.  Sonar X3c 64 bit Recordng Software.

     

    Member of Nashville based R.O.P.E.

  • I have tried it.  And the cleartype text is basically blurry.  I can't seem to a setting that helps  Thanks for the suggestion.  I'll keep on trying.

  • Thanks!  I'll try them later today.  It looks like they are brand new updates. 

  • Also, if you have a low screen resolution setting the text will be blurry.  Set it to a high or relatively high screen resolution and see if that helps.

    I am not a Dell Employee

    Dell forum member since 2002

    Home Built PC with Gigabyte GA-Z77X-UD5H motherboard, i7 3770 CPU,  Windows 7 64 bit Home/Win 8.1.  SSD drive.  Sonar X3c 64 bit Recordng Software.

     

    Member of Nashville based R.O.P.E.

  • Thanks for your help.  I installed the new ATI Drivers.  Have the maximum native resolution 1980 x 1080 for a 24 inch monitor, but nothing seems to work.  I've tried adjusting color controls, shapness, contrast, brightness etc. all to no avail.  The Cleartype test is not sharp.  I guess I am stuck with fuzzy text until I can figure out how to get it clearer.  It appears more and more to be a Windows 7 problem.  Going back to my old computer using Windows XP gave me nice clear sharp text.  Thanks again,  I'll keeping on fiddling with the monitor and software controls and hope for the best.

  • We recently bought two identical systems (XPS 8300 with ATI Radeon HD 5670) with the same monitor (Dell ST2420L). We are experiencing a problem on both monitors. There appears to be a vertical section of the screen closer to the left side where text becomes blurry. If you are looking at a web page or text document on the left side, it is blurry. But if you move the window to the right side of the screen the text becomes crisp. I run Windows 7 on a different system with a different monitor and have no problem. Seems like a monitor problem.

  • I got this, quoted below, from the link at the end.  Resizing the image as described did it for me.  I have the same monitor.

     

    Peter F. on:20 December 2009 at 3:39 am

    oke, you could not find the HDMI options?
    Click the catalyst control center icon in your taskbar [or Start/ All Programs/ Catalyst Control Center/ CCC] so it will open the ccc welcome screen.
    Now dont press basic or ok , just go to the left top of the CCC (catalyst control center)screen and click on Graphics.
    A slider will open , now click on desktop and displays.
    a new screen will open which has a small LCD icon in the left bottom corner.
    Right click the icon and choose “configure”.
    Now your in the Hdmi option screen and you can choose the “scaling options”
    Set overscan to 0 and it’s all full screen hdmi again :)

    Strange Ati did not set it to 0 standard.

    Good luck!!

    Peter F.

    http://www.jrin.net/2009_12_16/dell-zino-hd-review

     

  • I have the exact same set up as <professor14> and the same issue with my monitor. I did try the solution posted by <johngaither> just above. It did help, but only a little, it did not get rid entirely of the blurry effect.

    I did call tech support about this issue last week. We uninstalled and reinstalled all video drivers, switched the cables from HDMI to VGA and made many other tests, to no avail. Dell exchanged the monitor because we came to the conclusion it must be defective. I just received today the replacement monitor and alas the issue persists.

  • Found the problem with our monitors. We had to go into the Menu settings and press Auto Adjust. This cleared up our problem. I had previously tried adjusting many other settings, but somehow that one eluded me.

  • In response to <heath100>, I think your solution must be useful to users who connect via a VGA cable, I am using HDMI, and I notice that this Auto Adjust option is greyed out in my Menu, it is not accessible.

    I managed to make the screen not too bad by scaling the display to 0 through the Catalyst Control Center as suggested above by <johngaither> AND adjusting the ClearType options of my Windows. Although text is not crisp, it is now readable.

    Although Dell tech support tried to pin this issue on Windows 7, I don't think Microsoft would deliberately build their software so it only complies with high end monitors. From my personal experience, my conclusion is, it's just a cheap monitor and the fuzzy effect is a manufacturer issue.

  • Hi,

    i'll try to explain in my poor "english" .... right clic on mouse ....go in "screen resolution" ...go to the voice "big or smal text..." and set 120% (it is good for my 22) but it is possible 130% for you....try it, maybe you can resolve the problem.

    Hi