Intel Graphics Media Accelerator Driver....in Hebrew?

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

Intel Graphics Media Accelerator Driver....in Hebrew?

This question has suggested answer(s)

I'm running a Dell Dimension 4700 Desktop with Windows XP.

I have no idea when this condition first started, but....

When I open the "Intel(R) GMA Driver" in the Control Panel, the driver dialog box comes up entirely in Hebrew. Also, when I right click on my desktop, there are a couple of options in Hebrew that look like they correspond to this driver (e.g., rotating the screen 90, 180, or 270 degrees). (All other options on that shortcut menu are in English.)

I'm completely baffled by this and don't know how to fix it. When I try installing the driver file that I downloaded from the Dell support website (after entering the correct service tag), the "Intel 915G Graphics Controller Driver" (1432KA01.EXE), the setup program comes up in Hebrew, so I have no idea what questions it's asking and I abort the update.

(Actually, it was by trying to update this driver that I originally discovered the problem.)

To my knowledge, there are no other programs on my computer that use the Hebrew language.

I went to the Control Panel and clicked on the "Regional and Language Options" item. I verified that the dialog box had my Regional Options (first tab) set to English. However, if I move to the "Languages" tab and click on the "Details..." button, it shows that I have a Hebrew "keyboard" service installed (along with one for English). What's more, when I quit that dialog and go to the third tab of the "Regional and Language Options" dialog--it's called "Advanced"--I see that I have "Hebrew" set as the "Language for non-Unicode programs." I tried setting this to English and removing the Hebrew keyboard service (then rebooting) but all it did was change all the Hebrew characters to question marks, e.g., sentences like "?????? ??? ????, ???".

I wouldn't have a problem with this situation--after all, my computer video runs fine--except for the fact that I will occasionally get Hebrew characters when typing a new email. And that gets annoying.

Does anyone have any idea what I can do to fix this problem?

Any and all responses appreciated.

Thanks,

Lawrence

 

All Replies
  • Hello, 

    Remove the following files from c:\Windows\System32:

    igfxrheb.lrc

    igfxres.dll

     

    NOW YOU CAN ENJOY INTEL GRAPHICS IN ENGLISH...!!

     

    NOTE: The 1st file is one of many language files, which you don't need. If you take a look at your SYSTEM32 folder, you'll notice there are a lot of igfx***.lrc language files. You can safely delete most of them, BUT DO NOT delete igfxrenu.lrc !! that's the English US file.

    The 2nd file is the actual GUI, and a new one will be created automatically, only now it will be in English. :-)

  • I had the same problem ie with Hebrew text instead of English.  There is a much simpler explanation and resolution.

     

    Simply go to: "Control Panel /  Clock Language and Region", and click on the "ADMINISTRATIVE TAB". 

    Mine was set on "Language for non Unicode" programs as - Hebrew.  This is the root of the problem.

    Click on "Change system Locale" and scroll down until you find the version of English that you need.  Also click on copy to "Reserved Accounts" tab below and check the boxes that appear there too.

    Restart and voila! All back to perfect English! 

    And no messing with the registry or any other settings.

     

     

  • Actually, "Language for non Unicode programs" should be set to Hebrew, otherwise you'll see many questions marks (????) instead of text in certain programs.

    Your solution is NOT good. 

    Both Intel and nVidia mostly use DLLs for applying the local language on their Video Cards' menus and settings, which is very annoying. Their installers don't even prompt the user for which language he/she prefers. They assume the user would find it more comfortable seeing his/her local language in their applications.

    Deleting (or renaming the file of) the local language DLLs solves this problem perfectly without affecting anything else on your system.

     

    So, to change the menus & settings to English on Intel Graphics:

     

    1. Go to c:\Windows\System32 and Rename the following files:

    igfxrheb.lrc (This is the Hebrew file. If your local language is different, rename your local language file: igfxrXXX.lrc.BAK)

    igfxres.dll

     

    For example: rename igfxres.dll to igfxres.dll.BAK

    2. Reboot. Smile

     

    To change the menus & settings to English on nVidia Graphics (from Hebrew):

    1. Go to C:\Windows\System32 and remove the following files:

    nvcplUIR.dll

    nvdispsr.dll

    nvgamesr.dll

    nvmccsrs.dll

    nvmccssr.dll

    nvmoblsr.dll

    nvvitvsr.dll

    nvwssr.dll

    NvRaidServerhe.dll

    NvRaidSvhe.dll

    NvRaidWizardhe.dll

    NvRCoHe.dll

    NvSataConnectionhe.dll

     

     

    2. Go to C:\Program Files (x86)\NVIDIA Corporation\nTune and remove:

    nTuneServerHE.dll

    NVMONHE.dll

    StressTestServerHE.dll

     

    3. Go to C:\WINDOWS\Help\nvcpl and remove:

    nvcplheb.chm

    nvnetHEB.chm

    nvstoheb.chm

    nvprfHEB.chm

     

    4. Go to C:\Program Files\NVIDIA Corporation\NetworkAccessManager\bin32 and remove:

    namServerResHE.dll

     

  • After I went through your exact problem after I updated my graphics driver, I checked all the postings proposed by respectable participants in this thread, and I figured out a simple solution that will avoid all the side effects that might emerge due to the proposed answers. Although this reply comes a bit late for you I guess Big Smile however, this thread shall be useful for anyone who goes through the same problem anytime Wink.

    The problem is composed of the following elements:

    1. The problem 1st appeared after we updated our Intel Graphics driver because the Intel Graphics driver update chooses our default Non-Unicode programs language as the GUI language without asking
    2. If you change the Non-Unicode programs language in the control panel you end up with some things messed up in windows programs
    3. As normal users when we change registry or system files, we often end up with unfixable windows damage. I wouldn’t mess with system files including language ones

    After analyzing the problem components, I came out with this very simple fix that won’t change anything Wink what we need to do is just go around the stupid graphics driver update problem:

    Step 1: Change the Non-Unicode programs language to “English US” and Reboot. You can do that from Control Panel > Regional and Language Options > Advanced Tab > change the language in the dropdown menu to “English US” Don’t forget to Reboot

     

    Step 2: Go the Device Manager and Update the Intel Graphics Driver again. Now when the driver is being installed, it will use the default Non-Unicode programs language which is currently English

     

    You can do that from Control Panel > Performance and Maintenance > System > Hardware Tab > Device Manager > Click the + sign next to Display > Right click on the driver and click Update Driver > Automatically.

     

    Step 3: Change back the Non-Unicode programs language to “Hebrew” and Reboot

    You will find that the problem was solved and still you haven’t changed the Non-Unicode programs language or messed up with System and Registry files Cool Yes Yes

  • Thank you ericgl, Killerheels_UK, and Khaledez for your responses.

     

    It has ceased to be an issue for me anymore, but your responses are very helpful for all the people who will encounter this problem in the future.

     

    Thanks again.

     

    NigelTufnel

  • It seems that the issue is still relevant. And the problem indeed caused by the Intel's driver "silent assumption" that the GMA UI language shall be equivalent to one chosen for non-Unicode programs.

    But many times you want to keep the non-Unicode language setting to something different from English, while the UI you want in English only!

    Here is the most clean, simple and safe resolution I found, to get rid of hebrew:

    1. in the system32 folder, make a copy of file igfxrenu.lrc - this is an english resource file of the GMA GUI

    2. rename igfxrheb.lrc to something like igfxrheb.lrc_   - this is a hebrew resource file

    3. rename the copy you made of english resource to have the file name igfxrheb.lrc  Thus the exe file will still look for the hebrew resource (by filename), but will read english strings from there Smile

    4. reboot 

    And enjoy the pure English in the Intel Graphics Media Accelerator Driver GUI !

  • I have the same problem but the language here is Finnish.

    When I right click on the desktop, all the options except two are in Finnish. Even the sub-options are in Finnish.

    What should i do?

    Which file in system32 should i delete?

    Is it igfxrfin.lrc?

    Please reply immediately...