Blank screen after installing new NVidia graphics card in my older Dell Dimension PC

Desktop

Desktop
Desktop computer Hardware and Software discussion

Blank screen after installing new NVidia graphics card in my older Dell Dimension PC

  • I have an older Dell Dimension XPS T800R which has always performed well with no issues until yesterday when the original NVidia 32mb graphics card started having problems. I decided to purchase a replacement, the NVidia GeForce 7300 GT (AGP). I went through the installation process per the install manual. The new drivers installed successfully, but after rebooting the system I ended up with a blank screen. Upon rebooting I see the Dell banner, then the Windows XP banner with the status bar. After that the screen goes blank and within a few seconds I get the notification from my 24" Dell flat screen that it's going into power save mode.

     

    I called the BFG Tech support line (the video card maker) and we went through a few options (making sure the old video device was diabled, etc.), even downloading an older driver for this video card, but end up with the same result, a blank screen when trying to boot up into windows.  The support person at BFG Tech said that I may need a BIOS update for my older Dell PC for this new video card to work properly. Does anyone here have any ideas on how to resolve this issue. Thanks, Tony

  • Hi, I've had this issue before but on a newer system but using a digital (dvi) to analog video converter for an analog flat panel monitor - i found it to be the drivers which caused the tft screen to go out of sync (rubbish monitor basically) i had to revert to very old drivers which came on the CD with the card in order for it to work. Does the computer continue to boot despite the screen being blank (i.e does the hard drive access light continue to flash, windows sound etc?). Are you using a CRT or TFT screen?
  • Thanks for the reply.

     

    When the screen goes blank it appears that nothing is happening from that point forward. The PC doesn't reboot on it's own or anything like that. I have one of those very nice 24" Dell flat panel screens. 

     

    I returned the GeForce 7300 graphics card (512 mb) and instead purchased a brand new older version of their NVidia graphics card, the GeForce 6200 OC (256 mb). This installation was successful the first time following the quick install instructions that came with the card.

  • Glad it worked out for you!