xfx geforce 7950 gx2 in gen5 crashes no matter what driver!!

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

xfx geforce 7950 gx2 in gen5 crashes no matter what driver!!

  • i just installed a xfx geforce 7950 gx2 in my gen 5 and everytime i install either the xfx 91.27 driver or nvidia's 91.31 my system gets the blue screen of death every time i try to open up the nvidia control panel or open up the internet explorer... i cant figure it, i read alot of comments from newegg from customers who already have the 7950 and they say it works great... i am totally stumped.. i am running a 3.2 extreme edition overclocked to 3.6.. would the dual core cpu be causing these problems or is it system bios.. when i send the microsoft error message it says my crash is caused by a video driver.. does anybody have any idea as to what in the video driver is causing the crash??? totally stumped...
  • first do a search in this forrm for "7950" others are having problems to get the 7950 to work on their Dell's.    Dell is not listed as having a compatible mother board {BIOS} for the 7950 at the nvidia support pages.      u and I might need a new bios from Dell in order to get the 7950 card to work in our PC's  I have a XPS600 . And as DellChris-M stated Dell does not make new bios for newer hardware , so all us XPS owners may be stuck with no upgrade option.. Dell has a Habit of not doing bios updates for older PC's after they release newer PC lines .. as the XPS700 has arrived the other Dell lines will suffer  as i have found from past experience with Dell .

    Message Edited by Toronto699 on 06-28-200611:11 PM

    Message Edited by Toronto699 on 06-28-200611:13 PM

    Message Edited by Toronto699 on 06-28-200611:15 PM

    Message Edited by Toronto699 on 06-28-200611:19 PM

    Message Edited by Toronto699 on 06-28-200611:33 PM

  • you got that right!!! dell is pretty lame on updating there drivers for older models.. the gen 5 is not even a very old model, yet no more updates.. i do believe it is a bios problem as i read in another thread about somebody trying to get a 7950 to work in there xps 600.  they reverted back to the A06 version to get it to work.. the current gen5  bios is A04, i reverted back to A03 and A02 to no success.... so take this advice everybody: every person out there who owns a gen 3,4 or 5 dont even try to waste your time on a 7950 gx2 because it wont work.. trust me been there done that.. its a shame though, i love the idea of two gpus's on one card, i think its a cool design..  well my 7950 is going back for a refund!!!  talk about irony, i purchased this card from dell's desktop accessories page on there website.. can you believe it, they sell a card that wont even work in there computers unless you own a xps 700.. go figure...

    Message Edited by whiteashcm1 on 06-29-200612:12 AM

  • what method did you use to remove the ati drivers?
  • It has nothing to do with video drivers; it is a BIOS problem and Dell abandons systems when newer models are introduced.
  • i used driver cleaner pro to remove any of the leftover registry entries... i almost positive its a bios problem.. when my computer crashes or gets the blue screen of death microsoft says my crash was caused by a video device driver which is probably true, but i believe its the lack of bios support thats causing the video driver to crash win xp...
  • Hey,

    I am also using a 7950 GX2 in a Gen5. Had all sorts of bluescreen problems, and had to disable one of the two instances that appear in Device Manager, which stopped the bluescreens but left me running on half a card.

    Just downloaded the 91.33 beta driver from nVidia at:
    http://www.nzone.com/object/nzone_downloads_rel70betadriver.html

    Was able to re-enable the second instance and run in SLI mode, and have had no problems since!

    I am using version A04 of the Phoenix BIOS for the mobo.
  • excellent....please post some benchmarks/screenshots if you can
  • it's an nvidia driver problem. that video card is still new and they have to work out the drivers for it. i think your bios is fine. nvidia does have driver problems alot with certain video cards. it's a thing i learned from when i had a geforce4 ti4600 that never did work right.

     

                                                   -jeff

  • Success!!! your info was right on the money... i have got my xfx 7950 to work in my gen 5  without crashes!!! it must have been a driver issue.. thats probably why nvidia came out with the 91.33 so quickly.. upon boot up i do have the issue of the screen going black when the win xp logo is displayed but the screen returns at the welcome sign.. that i think might be a bios issue but no big deal though.. i guess i will retract everything i said in my previous thread about a gen 3,4 or 5 no being able to make this card work.. it does work fine and game play such as farcry and COD2 is very smooth and realistic.. all settings are maxed and game resoulution is 1280x1024..  sorry about what i said earlier as i probably bummed out alot of gen 3,4 and 5 owners.. i will post my 3dmark2005 results when i get done testing.. :smileyvery-happy:

    Message Edited by whiteashcm1 on 07-04-200611:15 AM

  • well my first run with 3dmark 2005 gave me a score of 9555.. not too bad for a stock or unmodded driver.. will post more results later..
  • I too am having big problems and they are the same problems mentioned above.
     
    I downloaded every driver and the latest from Niv and XFX and no luck at all with the hardware acceleration on high. Everytime I set it on high the blue screen of death appears any help would be greatly app.
     
    Also in your Gen 5 What MB and chipset do you have cause if we have the same maybe I need to check more into this as no need for the card to sit in the box
     
     
    Thanks,
  • hello, you have to install the 91.33 driver from nvidia's beta driver section..  that will fix your blue screen of death.. i had the same problem with the other drivers as well... the 91.33 driver fixed the crash with win xp and using the intel 955x chipset on your motherboard.. my gen 5 is the same as yours, its a intel board using the 955x chipset.. the 91.33 is the only driver that you can use right now to prevent crashes having both gpu's enabled in sli.. you can use the 91.31 driver but as sonn as you reboot and get to the desktop you have to go into device manager and disable the first gpu.. your system will run fine but you will only be using a single gpu with 512mg memory.. kindof a waste since you have two gpu's... hope this helps..
  • Hi WhiteashCM1
     
    I am very interested in this Gen 5 / 7950 GX2 issue. I have trawled through the forum and noted the comments posted. It seems that the definitive answer is that the GX2 will definately work properly in a Gen 5 with Intel 955X chipset , AO4 BIOS and 91.33 Beta drivers.
    My system is as above (18 months old) but I have the 93.81 beta driver. The only game I use is Flight Simulator 2004 and I am getting intermittent but brief freezing usually when I switch aircraft to fly.  I get green and red dots and streaks on the screen during the freeze.
    I am convinced that this is a driver problem but my point is this , I am assuming that driver 93.81 includes the 91.33 structure plus improvements , am I correct ??  I do understand that the latest driver is not nessesarily the best driver but 93.81 is the only one I can find on NZone.
    Any ideas on where I can get 91.33 beta as I am noting that quite a few in the forum are reporting complete success with this driver. 
     
    Thanks , Buster.bvi
     
    Gen 5 with BOIS version AO4
    XP Home ( SP2 )
    Pentium P4 (R)  Prescot 670 , 3.8ghz
    Intel 955X Express chipset
    XFX 7950 GX2 ( 520M ) Extreme edition
    2 X 250gb SATA ( Raid 1) Maxtor H.Drives
    2 Gb DDR2 SDRAM
    S.Blaster Audigy 2 ZS
    Dell 1905 FP monitor running at 1280x1024 Res.
    Logitec Z5500 , 5.1 Speakers
    Labtec wireless keyboard & mouse .
     
     
  • I forgot to mention that my 3D Mark 06 score with this set up was 5004 . Not sure if this is good or bad . Any comments welcome !
     
    Buster.bvi