Forums

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

No Direct3D on Optiplex GX260

  • I have an Optiplex GX260 system with integrated 845G graphics. When I run "dxdiag" both DirectDraw an Direct3D are marked "Not Available". The Enable/Disable button is "greyed" out.

    Have installed the latest drivers from Intel with no effect.

    I run Windows XP Pro.

    Anyone know whats wrong?

    Eric

  • Hi Eldroy,

        Just out of curiosity i am wondering if you have installed DirectX 8.1 from microsoft in your system. If you haven't try installing it and check if that makes any difference.

  • Hi.

    Must I download DirectX 8.1 for Win2k then?

    Regards

    Eric

  • Hi Eldroy,

        If you haven't downloaded DirectX yet, download it and see if it makes any difference. Be sure to install the directX version for Win2k and not any other OS because each OS has a different version of DirectX. I hope this helps.

  • Downloaded DX8.1 for Win2k, tested new an old drivers.... no result.....

    Have upgraded to DirectX 9 and tested all drivers (Intel and Dell) still no result....

    When i run "dxdiag" "test Direct Draw" I get this error code;

    HRESULT = 0x887601c2

    Hope anybody can help

     

    Eric

  • I have the same problem. A friend of mine has the same system, with the same problem and she recently had to re-format her drive. She now has access to DirectDraw and AGP Texture. I'm beginning to think its a Dell installation issue since other people I know have not had this issue come up and they have identical equipment, except they don't have Dell boxes.

    Let me know if someone helps you figure it out without having to re-format!

  • Here's something my coworker discovered.  It may help.  Netmeeting does wierd things.

    NetMeeting and Remote Desktop
    If you quit Microsoft NetMeeting 3.01 improperly, or if Remote Desktop Sharing is turned on, Direct3D functionality is disabled. When you restart the computer, Direct3D functionality is not restored. NetMeeting 3.01 automatically disables Direct3D functionality when it starts. When you quit NetMeeting properly, it restores Direct3D functionality. To resolve this issue, start NetMeeting 3.01, and then quit it properly.

  • The Netmeeting trick worked for me!  Thanks Jcardin.

    I was having a problem with a few games (HALO and Neverwinternights) and some graphics software (3dsMax6) and it was driving me crazy!  I wound up trying different drivers, uninstalling and re-intalling and swearing and ..well you get the picture.

    I started Netmeeting the selected Exit.  After that  Iwas able to test Direct3D in DXDIAG and run my games and graphic software.

    Funny thing is I had a simular problem about a year ago with a previous version of 3dsmax.  I wound up rebuilding the machine and the problem went away.