Blue Screen error with atikmpag.sys in Windows Vista/7 x64 - Video - Desktop - Dell Community

Blue Screen error with atikmpag.sys in Windows Vista/7 x64

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

Blue Screen error with atikmpag.sys in Windows Vista/7 x64

This question has suggested answer(s)

Hello,

My XPS 435MT system with ATI Radeon HD4850 video card is 3 years old and I can safely say I have never had a problem until now. At first I thought it was a virus, but a complete format and system reinstall haven't fixed the problem. I've tried different versions of drivers (new, old, dell factory) and the issue persists. My screen turns into a checker board so to say and then throws a blue screen with atikmpag.sys error. Sometimes I can work on my machine for days without a problem and sometimes it would come up just after a simple reboot or launching a flash video.

Upon further investigation it was determined the conflict lies between my video card and motherboard. As described by other users with a similar problem here is the cause:

"The problem was that the motherboard (which is like 2-3 years old) had a too old VGA Bios version and the solution is obviously to update it."

(full thread can be found on microsoft forums at http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/blue-screen-error-with-atikmpagsys-in-windows-7/5f0aebb6-b9b6-4a5d-a622-97c62dbb3d66)

As you can see my situation is exactly the same. I've looked for BIOS drivers for my system and the only update I found was released later in 2009 which still means that my VGA Bios version is almost 3 years old.

My question is if Dell plans on releasing any BIOS updates to fix the issue? Other motherboard manufacturers keep their products up to date and I do believe that 3 years is not enough to stop support. It is ridiculous to think that I should be upgrading my hardware even though there is absolutely nothing wrong with it. I need to know where to go with this and who I should be addressing this to. My warranty has expired but this has nothing to do with it. Thank you for your help in advance.

All Replies
  • Hi mUrZ,

    Do you have the current BIOS? What's the error?

  • It could also be an overheating GPU.  Once they get damaged there is no amount of Bios updates that will fix them.

    The microsoft post talks about a DirectX 11 video card 5XXX series not 48XX series directX 10 card.

    There is no such broad extrapolation between VBIOS.

    Overheating occurs when dust and pet hair clog the fins of the heatsink on the GPU.

    The DirectX June 2010 patch should be installed.

    The ATI Catalyst drivers are up to 12.XXX

    Report Unresolved Customer Service Issues here
    I do not work for Dell. I too am a user.
    The forum is primarily user to user, with Dell employees moderating
    Contact USA Technical Support

    Get Support on Twitter @DellCaresPro

  • I will post the error message once the issue reoccurs. At this point I'm not ruling out any possible issue, but my research of this error message points to outdated BIOS.

    The thread that I provided originally is just a single example since I didn't want to flood the thread with multiple links. All I have to say is that this issue occurs with 48XX series cards as well.

    I checked the fan while PC was ON and it was running at full speed and the reason why I'm not concerned about dust and pet hair is because the card was recently taken out for cleaning. I'm running both the latest ATI drivers as well as the latest Direct X

  • My experience is that you must use Hot water to flush the deadly dust bunnies out of the card.  When you do this you must then dry the card and then check the heatsink again.  Some require removing the dust buster shroud from the heatsink to expose the clogged fins.   Many take the heatsink off to clean it but I'm lazy.

    If you have Cats then the answer is overheated clogged GPU.

    Report Unresolved Customer Service Issues here
    I do not work for Dell. I too am a user.
    The forum is primarily user to user, with Dell employees moderating
    Contact USA Technical Support

    Get Support on Twitter @DellCaresPro

  • I would not recommend using hot water to clean a video card. Normally one of those compressed gas cans is all you need.

  • Don't EVER use water on electrical components! Only destilled water is "safe", and even then, you may end up with something in the water which leads to short circuiting.

    What I would recommend:
    1) Compressed air in a can
    2) Pure alcohol and q-tips
    3) Anti-static head for your vacuum cleaner

    Number one is the easiest to do and safest if you have no clue! ;)

  • I've done the hot water trick numerous times. That's why I mentioned that some take the heatsink off.

    I did not say Immerse in water although some have done that as well.

    YMMV

    Heatsink Cleaning (?) - Coolard|Forum

    Do you clean your heatsink. - Overclockers Forums

    Heatsink blew all the dust off then soaked it in really hot water