Using PXE with GX270 and A03 BIOS - General Hardware - Desktop - Dell Community

Using PXE with GX270 and A03 BIOS


Desktop computer Forums (Audio, General Hardware, Video)

Using PXE with GX270 and A03 BIOS

  • This BIOS doesn't display a boot from PXE option (or USB Flash Device), as described in the online documentation--I just have the usual boot from Floppy, CD, HD options.  I do get something that appears to search the network, when I hold down F3 at the Dell screen at boot, but, it won't connect to my RIS server (works fine with other models of Dell).

    Is this a BIOS bug, bad documentation, or what?

    How do I get PXE to work with RIS on this model?


  • Is PXE mode enabled? Check in the BIOS, and then the settings for the NIC.
  • Thanks, but...that IS the problem...I don't seem to have anything in the BIOS to do with selecting PXE.  The ONLY boot options shown are Floppy, CD, and HD, and, I see nothing that will let me change options for the NIC.

    Have you tried this on a 270 with the A03 BIOS?


  • in BIOS go to Intergrated Devices then Network Interface Controler and change setting to "On /w PXE"

    after save and reboot you will get the option to boot from network when you hit F12


  • I have the F12 option on the screen, at boot, the options listed, there is nothing about a network boot.  I assume it should be listed as an option, right?  Also, in boot order, in the BIOS, should it list Network?

    After doing some reading, I can press F3 at boot, and, it seems to do something about trying to boot from the network, but, fails, even though I have the RIS server enabled.


  • I'm sorry I must not have been clear.

    To make the "Integrated NIC" apear as a boot option you must make a small change to the BIOS settings first. 

    Press F2 to enter the BIOS setup.  Then arrow down to Intergrated Devices and hit Enter then arrow down to Network Interface Controler and then use the side arrow -> to change the setting from "On" to "On /w PXE"

    Then save and exit BIOS.  After you reboot, the "Integrated NIC" option will appear in the list at boot when you hit F12 AND it will also appear in the boot order list in the BIOS setup.

    I guess that the network boot option is disabled by default because most people don't use it and it may add slightly to the time it takes to boot the PC.

    I hope this helps.


  • Nope, you were clear enough!  I simply don't have that option on the NIC setup in the A03 BIOS.  There IS no setting to do ANYTHING to the NIC, and, believe me...I've tried!!

    Thanks.  I think something is wrong, but, we've looked at 10 of these computers, with the A03 BIOS, and, NONE of them can be set to boot of off the network...

  • also see this thread about other recent problems with GX270 and RIS


  • Ahh...not me, Dell!


  • Bill, I also received a new batch of GX270 and didn't found the USB and PXE boot option. But this tread helped me ! please read them again or follow step by step this :
    F2 enter setup
    8th line : Integrated Device (Legacy Options)
    2nd line : Network interface controller
    Put it : On w/ PXE
    ESC ESC save config
    when reboot : F12 boot menu option
    You should see option 5 . Integrated NIC

    For the USB boot, It doesn't appear unless you really plug a usb key/harddrive

  • OK, I'll try it again!  Thanks.