External Hard drive suddenly not accessible - The Parameter is Incorrect - General Hardware - Desktop - Dell Community

External Hard drive suddenly not accessible - The Parameter is Incorrect


Desktop computer Forums (Audio, General Hardware, Video)

External Hard drive suddenly not accessible - The Parameter is Incorrect

  • Hi there,

    I've been using my 80 gig Maxtor external hardrive for a couple of months.  My computer has XP,  The plug and play kicked in immediately and connecting through the usb was easy.  However, yesterday when I turned on my computer and tried to get into my E drive (that's the external hard drive) I'm told that "E:\ is not accessible.  The parameter is incorrect."  According to my device manager the usb is working and it acknowleges the External Hard Drive is there.  I've tried powering down, disconnecting, reconnecting and restarting.  No change.  And, when I do boot up my computer windows takes a long time time start up.  Has anybody experience this and is there a simple solution?  Perhaps a step I've missed?  All suggestions and / or comments are greatly appreciated.


  • The delay on bootup indicates that the system may now be attempting to boot to your external hard drive. To disable this behavior, enter the System Setup (BIOS), open the Integrated Devices category, and change the USB Emulation option to No BOOT. Save your changes and exit the BIOS.

    If you disconnect and reconnect the drive while the system is booted into Windows, does Windows recognize and install the drive automatically?
  • Have you tried disconnecting the power to your external drive for several minutes, before reconnecting?
  • Yes, when I disconnect and reconnect windows does acknowledge the drive.  Until I'm able to resolve this I'm just disconnecting the External hard drive and the computer boots up just fine.  However, when I do connect the external hard drive, window's responds but I'm still not able to access the drive.


  • Thanks for the tip. I took your advise and kept the power disconnected for about 1/2 hour.  When I reconnected the power and then  reconnected the hard drive to the computer, nothing had changed.  Even after re-starting the computer. Now I'm scratching my head as to what to try next. 
  • I'm experiencing this EXACT problem. For no reason (appart from shutting down and restarting my laptop) my external hard-drive has ceased to function. The light flickers and so does the hard-drive on my laptop, there is "some" communication between the two but I get this

    "(drivename) is not accessible. The parameter is incorrect" error.

    Did anyone ever find a way to resolve this problem?

    Thanks in advance..