How to put desktop into 'endless sleep' mode? - General Hardware - Desktop - Dell Community

How to put desktop into 'endless sleep' mode?

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

How to put desktop into 'endless sleep' mode?

This question is not answered

I have two side-by-side computers running the same version of Windows 10 and programmed identically for sleep mode.  One machine (another brand) responds to sleep programming as I would expect.  The other computer, a Dell Inspiron 3650, will not stay in the sleep model, but goes into some sort of hibernate mode and shuts itself off completely after a few hours.

When I put the non-Dell computer to sleep, it flashes its power button and remains in that state until I wake it up manually.. days or weeks later.  Even when it's asleep, the USB ports remain powered, which is important in my application because of a USB-connected development platform that needs to be maintained 24/7.

The Dell goes to sleep, flashes its power button, but then turns off completely after a couple of hours.  When this happens the USB ports go dead as well.  For all practical purposes it's OFF, and requires a push of the power button to bring it back to life.  Windows, in the meantime, must have been blasted into some sort of memory, because when I turn the computer back on Windows is already loaded and running just as it was when I put the computer to sleep.  When I push the power button I get the Dell-logo splash screen, just as you would when booting after shutdown, but Windows shows up almost immediately, ready to go; that is, it doesn't have to load from scratch.

I went into the BIOS and disabled any auto-sleep or other power-related functions; any ideas how I can keep this computer from shutting down?  Thanks.

All Replies
  • My answer to the problem in your other thread will probably help this problem too. But with these extra steps...

    While in Device Manager, expand the list under Human Interface Devices and then double-click each HID entry. If the item has a Power Management tab, make sure "Allow PC to turn off..." is not checked.

    Then go to the Power plan and disable USB Selective Suspend, and also disable Hybrid Sleep and set Hibernation to Never.

    Reboot when done.

    If this answers your question, please click  Yes

    Ron

    Forum Member since 2004

    I am NOT a Dell employee

  • Hey, Ron,

    Thanks very much for the speedy reply to both questions.  I've answered each in its proper spot.

    With respect to the sleep issue, I followed your instructions and was dismayed to find that most settings you suggested were already set.  I went through the entire Device Manager tree and did find a couple of "Allow computer to turn off..." which I then unchecked.  One was: Intel(R) Management Engine Interface, which is Greek to me, but I unchecked the box anyway.  Sorry to say the problem is still with me, although I do have some additional information.

    In my initial post I accused the computer of going from sleep to OFF after several hours.  This is wrong.  It's consistently after 3 minutes and fifty-something seconds.  My earlier observation was just coming back after a couple of hours and finding the machine off, but it actually happens a lot quicker.

    What I notice is that the computer goes into sleep, the power button flashes, and then at 3:55 or so it wakes up... the hard drive comes alive and the tiny LED flashes, but the monitor stays dark.  After maybe 20 or 30 seconds, then the whole thing shuts off.  Oh, Windows is definitely saved in its existing state, for when I then wake it up by pushing the button, it's loaded and ready to rock 'n roll.

    So I tried something.  I went back into Device Manager and set one item to: Allow this device to wake the computer.  I allowed the keyboard to do the waking-up, even though that's not what I want.  I put it back to sleep and the same sequence repeated: sleep  -  wake-no-monitor  -   shut off.  And, of course, hitting the keyboard at that point does nothing as the USB ports are unpowered after it shuts off.

    So I'm certainly open to any further suggestions.  The way it's running, at least I can put it to sleep and get going again quickly, but I don't get constant power out of the USB holes.

  • What about just setting it to turn off monitor and HDD after "X" minutes, and setting Sleep to Never?

    Is Hibernation set to Never?

    You might also try changing PCI Express>Link State Power Management setting to OFF in the active power plan.

    Have you looked in BIOS setup to see if there's a "Wake on USB" option and making sure that's enabled?  (Don't know if this model has that option.)

    What about changing some of the power settings in BIOS?

    If this answers your question, please click  Yes

    Ron

    Forum Member since 2004

    I am NOT a Dell employee

  • Okay, I'm in the BIOS now.  The only power options are 1) Wake Up by Integrated LAN/WLAN [Disabled]  2) Deep Sleep Control [Disabled]  3) Auto Power On [Disabled], and then three date/time entries for Auto Power On, which are at default but shouldn't matter.

    There's no Wake on USB in BIOS settings, the only mention of USB is USB Emulation, which is [Disabled] by default, and USB Configuration which simply has front and rear ports [Enabled].

    So that's the BIOS.  Under Windows 10 Power Options settings, Hibernate is set to Never, and Sleep is set to Never as well.  Hmmm, I wonder if this confuses the computer?  I have the Power Button programmed to put the machine to sleep, but if it's never supposed to go to sleep by itself, could it not decide what to do?

    I have the Power Options set like this:

    Preferred plans / Balanced / Turn off the display: 1 hour; Put the computer to sleep: Never

    Then under Advanced settings (pull-down menu) the important things are:  Turn off hard disk after: Never; Sleep after: Never; Allow hybrid sleep: Off; Hibernate after: Never; Allow wake timers: Disable; USB selective suspend setting: Disabled; Power button action: Sleep; Sleep button (I don't have one) action: Do nothing; PCI Express Link State Power Management: Off; Turn off display after: 60 minutes.

    And that's everything I can find under power-related settings.  Under USB items in Device Manager, I do see one thing that I overlooked before.  It's evidently associated with the PCIe board with the extra USB ports. Under the Host Controller/Advanced there's a check box: Disable USB 3.0 power management functions, which was not checked.  I have now done so.  And now that's all I can find so I'm rebooting.

    So now the computer is up and running.  I'll hit the Power button to put it to sleep and start the stopwatch.

    Okay, the computer is asleep, the light flashing

    Well, 15 minutes into Sleep now and still snoozing soundly.  Before, at about 3:55 it would wake up for 20 seconds, but with no monitor, and then shut off.  It's behaving properly now; could it have been that check box for the aftermarket plug-in USB card, I wonder?  I'll see if 'baby sleep the night through' and report in the morning.  Thanks for your help!

  • Wasn't sure if this model has USB Wake in BIOS. Some of the newer systems have that option.

    Don't know why you have the Power button option set to "Sleep". That's typically for a laptop, not a desktop. I have my desktop's Power button set to Power Off. And I just let my PC do its own thing and go to sleep after the pre-set time.

    I would turn the HDD off after a fixed period, instead of 'never'. No point running the drive if the PC isn't being used. You'll save wear/tear on the drive and some energy too.

    Don't know if that USB setting is for the onboard USB3 ports or for your add-in PCI-e card, but hopefully that solves the problem.

    Sleep tight, don't let the (Windows) bugs bite!

    If this answers your question, please click  Yes

    Ron

    Forum Member since 2004

    I am NOT a Dell employee