Wake on LAN not working on Optiplex 9020 - General Hardware - Desktop - Dell Community

Wake on LAN not working on Optiplex 9020

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

Wake on LAN not working on Optiplex 9020

This question has been answered by AnguelS

I am not able to get Wake on LAN to work on an Optiplex 9020 (small form factor).  I have the following BIOS settings under Power Management:
- Deep Sleep Control -> Disabled- Wake on LAN -> LAN Only
- Block Sleep -> Block Sleep (S3 State)

I have the following settings for the Intel Ethernet I217-LM card:
- Wake on Magic Packet from power off state -> Enabled
- Wake on Magic Packet - > Enabled
- Wake on Pattern Match -> Enabled

When the computer is powered off, the network card has NO LIGHTS.  Does that mean that Wake on LAN is not properly configured?  What setting am I missing?

In case this is relevant: Windows 7 Pro 64-bit.
Thank you.
Jerry

Verified Answer
  • I installed A07 and now WOL works.

  • There are a few variables in your scenario I can't or won't match in testing (CAB deployment, 32-bit OS, SCCM), but, I will suggest that disabling NIC power management in the OS seems like a wrong turn.

    Also, you mention nothing about the BIOS revision (which is super important); only the (probably unavailable beta BIOS and) current version successfully supports WOL.

    As far as BIOS settings (for Win 7 targets): The only required changes from OOB are disable "deep sleep" and enable WOL.

    So, if I were you, I'd take one of your lab units, reset BIOS to defaults, set those two BIOS parameters, enable Win7 NIC power management (including checking the box to allow WOL), and test.  I bet that works.

    If not, please indicate in your reply whether the link light remains lit (on the NIC) when your test PC is turned off.

    Finally, you ARE referring to O9020 minitowers or SFF units, right?...(not all-in-ones or something).

  • Did I miss something? Where did Dell document that Deep Sleep has to be disabled? Where did they document that you need to turn off fast start in Windows 8.x? Did they at least tell us that the NIC LED must stay on in order to have a working WOL?

    Yes, I documented this instead of Dell:

    http://techie-blog.blogspot.de/2014/03/making-wake-on-lan-wol-work-in-windows.html

    And many people thanked me for that, so it was not so obvious...

    Anguel

All Replies
  • Hi,

    I've 40 dell gx9020 SFF in my laboratory and I've got this same problem, pls advice.

    Thanks.

    --william

  • I got the same problem aswell, two 9020 systems running Windows 7 Pro x64. I am guessing this is related to mailfunction of the bios from dell, because it always turns off the lan port, even in S3.

    Fix this DELL!

    Rune

  • We have many Dell Optiplex 9020s (Tower form factor), and I'm not able to get Wake on LAN working for them, either.  Have never had a problem with prior Optiplex models (GX620, 745, 755, etc), but these are the first 64-bit Windows 7 machines to go into production (the others are running 32-bit Windows XP).  Hope this gets fixed soon!!

  • After quite a bit of trouble-shooting and testing, I have discovered a way to work around the problem:

    1. Make sure the BIOS is at version A02 (downgrade, if needed).
    2. Within the BIOS - Power Management, set "Wake on LAN" to LAN only
    3. Within the BIOS - Power Management, set "Deep Sleep Control" to Disabled

    Once I made the above changes, the Optiplex 9020s now were able to be powered on remotely with the same WOL utilities I use for all of the other Dell computers on our network.  In my testing, I started with the latest BIOS version (A05) and kept backing off, and A02 was the first version where the above settings worked successfully.  Of course, I would like the ability to update to the latest BIOS, so hopefully Dell will offer an update to fix the issue.

  • Thank you - this worked for me! I was on A04 before, and after trying A05, where it also did not work, I downgraded as per your suggestion. I immediately noticed that now the network card is on when the PC is in standby mode or power off mode (blinkenlights on network card still active), and wake-on-LAN finally works.

    Note: Although the network adapter stayed on after my first poweroff, wake-on-LAN did not work until I did a complete power cycle (boot to Windows, shut-down from Windows). I assume that some things are not properly loaded unless you do a full boot sequence.

    I am surprised how painless a BIOS-Upgrade and BIOS-Downgrade is. All my previous settings are still there, which is nice.

  • I can confirm that downgrade to BIOS A02 (as long as you're not running UEFI boot) works to fix WOL both in S3 and S5 power states.  I can also say that a Dell rep has suggested to me that it takes a motherboard replacement to get WOL working with any BIOS more recent than A02.  So, that doesn't bode well for enterprise clients.  I will post back when/if I can verify or deny that the replacement motherboards for these systems that won't WOL with later BIOSes will allow WOL to work with later BIOS and new MB.

  • I pinged my Dell tech contacts about this, especially you've shown Wake on LAN works with A02, but not later versions.  Let's see what they have to say... 

    But this brings back the old adage:   Unless a new BIOS release fixes a problem you actually have, don't update to the newer version. Wink

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee

  • Fair enough about the caveat, but they've had THREE BIOS revisions since breaking WOL; I'd think they could get it right in all that revision.  Moreover, their own Dell Update (or whatever it's called) utility with default settings will automatically upgrade 9020s to BIOS A04 which also breaks WOL.  There was a time when I would have agreed with you about not updating BIOS unless there's a known problem with a known solution in an upgraded version, but I've been berated by support reps too many times about running "out-of-date" BIOS on desktops and laptops; so, I routinely update to current on brand new PCs prior to deployment.

  • Andy Kinnard
    they've had THREE BIOS revisions since breaking WOL

    Well, maybe you're the first ones to report the WOL problem in versions after A02. And if nobody told 'em WOL got broken...  Wink

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee

  • I don't want to get unnecessarily sidetracked from the main BIOS issue in this thread, but the "old adage" mentioned (about not upgrading the BIOS unless it fixes a problem you actually have) is not one that I, my co-workers, or any other IT professionals I know subscribe to.  Even in this particular case with the Optiplex 9020, there were fixes and/or enhancements offered by the later versions for functions we absolutely use and rely on (i.e. OMCI, Intel microcode / ME firmware, CCTK, etc).

    For now, the WOL functionality is more critical to us as we support 4 campuses in separate geographies and very often rely on the ability to remotely power on computers (especially with some of our departments where getting a hold of someone onsite to do it for you is next-to-impossible), so we have chosen to downgrade to BIOS A02.  But, I don't view that as an acceptable long-term solution: we should be able to upgrade in order to benefit from the fixes/enhancements in the later versions without having to sacrifice core functionality from earlier versions.

  • No response yet. I pinged them again... Embarrassed

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee

  • I have motherboard replacement scheduled for tomorrow on one of the units.  I will report back whether it actually solves the problem with current BIOS or is just a "clever" way to roll it back to A02.

  • Not sure if this qualifies as a 'ping', but I opened an incident (case number

    <ADMIN NOTE: Service tag removed per privacy policy>) with Dell support on 1/16/14.

    The last update I've had was on 1/17, saying that the issue was being escalated to the engineering department.

  • My tech contact responded that Dell is aware of the WOL issue and is working on a solution.

    Stay tuned...

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee


  • Thank you everyone for your help.  I downgraded to A02 and now the WOL works.  I also appreciate the confirmation that the network light needs to be on (or flashing) for WOL to work.

    Hopefully, Dell will fix this soon.
    Jerry