Inspiron 660, Windows 8 and PCIe card - General Hardware - Desktop - Dell Community

Inspiron 660, Windows 8 and PCIe card


Desktop computer Forums (Audio, General Hardware, Video)

Inspiron 660, Windows 8 and PCIe card

This question has been answered by Steve.Rayner

I purchased a Insprion 660 to act as my media center.  I used up all of the internal SATA ports for my hard drives and optical drive.  I wanted to add more SATA ports, so I purchased a SIIG SATA II PCIe card (SC-SAE012-S2).  When I plug the card into any of the internal PCIe ports, the operating system does not detect the card.  I can install the drivers, but Device Manager tells me that the drivers can't load.  I installed the card into another PC and it works.  I suspect that none of the PCIe ports on my machine are active.  Is there something I need to do in the BIOS to activate them?

Verified Answer
  • I fixed the issue by selling the dell and buying Lenovo.

  • absoffthewake

    I fixed the issue by selling the dell and buying Lenovo.

    WOW, that's one way to fix an issue. LOL  Stick out tongue


    If my answer was helpful, please use the 'Did this answer the question' and click: Yes
    Forum Member since 2001
    I am not employed by Dell

  • SpeedStep - You are incorrect. There is only 1 issue here - Dell's arrogance in supplying hardware that doesn't support standard add-in cards.

    I'd equate it to buying a new car without a sound system, then a couple of years later going to have one installed and the dealer says, "Sorry, there is no CD Player that will work in your car, but there is ONE PARTICULAR BRAND AND MODEL OF AM RADIO that will work"

    It really is quite unbelievable!!! I have never, ever installed a PCIe card into a computer and had the computer not even acknowledge that the card is installed!!!

    Dell should hang their heads in shame!!!!

    BTW: I'm using Windows 7 64 bit, not Windows 8

All Replies
  • Hi Gadgetvic,

    You said the OS does not detect the card. Did you check device manager and look for a question mark? Did you look through the BIOS?

  • Device manager does not detect the card.  If I install the drivers, then install the card, Device Manager shows the question mark.  I looked through the UEFI BIOS and didn't see anything related to PCIe slots.  Perhaps I'm missing something?

  • I think the problem is similar to these people's:  I too am trying to use SIL3132 based card and my mobo is not detecting it.  In the threads listed above, a BIOS upgrade fixed it.

    @Dell is a BIOS upgrade in the future so I can use this card?

  • Did you check? In downloads, I found BIOS A05. Is that an upgrade for your system?

  • @Osprey, thanks for the link.  However, that is my current BIOS.    Do you know why it didn't show up when I search for drivers via my Service Tag?

  • I always search by model, not service tag.

    I'm really out of ideas. Did Siig tech support have any suggestions?

  • That is my next step.  I'm concerned that when I tell them that the card works in another machine (a HP), they will point the finger back at Dell.  Still, it's worth a shot.  Thanks for all your help.

  • any luck..i have a avermedia PCI-E tv tuner and the new inspiron 660 does not detect it.. it was detected fine on my old dell E510

  • Unfortunately, no. My next step is contact the maker of my card, SIIG. I don't know how much help they will be because the card works on another machine. I truly believe it is something with the BIOS of my Inspiron. I think we may be out of luck until Dell updates their BIOS. If you search these forums, you'll see others who had problems with their PCI-e cards and UEFI machines. It was only resolved with a new BIOS.
  • Hi, did you ever have any luck correcting this problem?  I have a PCI tuner card that is not detected in any of the slots, even with drivers downloaded, and even though it works fine on a different computer.  After talking with Microsoft, Dell and the manufacturer, I also believe it also may come down to the BIOS (suggested by the manufacturer, not Dell of course).  Dell customer support doesn't seem to be particularly interested in trying to figure this out with me.  They passed me around in circles of 10 yesterday, a complete waste of time as they only offered the obvious things that I had already tried or passed me on.  They were supposed to have called back this morning, but of course that didn't happen....:(

    Anyway, If you had any success with your card, please respond!



  • Still no success w/my card. I keep checking this URL: to see if a new BIOS has been posted.

  • Thanks, I guess I'll just have to keep doing the same :(  As I recall the last one was version A5...but that doesn't do the trick.

  • Just curious, what is your tuner card? I've a Hauppage 1250 that is having the same problem. Works fine in my old inspiron 530 (still does), but my new 660 doesn't know it's there. Working through support, but they don't have any ideas so far.

  • Mine was a Hauppage 1800.  Dell technical support is ridicuous and it took me countless hours (days really...) and a lot of frustation to finally get to the bottom.  Apparently there s a compatibility problem with these older model PCIe cards that were made with a 1st generation chipset.  The slots on this board can only handle cards using a 2nd generation chipset.  Hauppage customer service seemed to back this up. 

    I don’t know if there is any way to correct this problem with a BIOS update.

    I hope I have saved you hours and hours with a bunch of Dell tech support people that don’t have a clue.  You’d think they would disseminate this information a little better….

  • Thanks for the reply, though I was hoping for a little happier news. :(  But I *definitely* appreciate the time-savings all the same!

    In your discussions with Hauppage, did they give any hope for this working in other PC's, Dell or otherwise? I hate going through the trouble of returning my Dell just to get another incompatible PC, but I hate having to buy a second tuner when this one still works perfectly well.