eSATA port not working on XPS 8300 (or is eSATA port supposed to work if you have SATA Mode in BIOS set to "RAID")

Desktop

Desktop
Desktop computer Hardware and Software discussion

eSATA port not working on XPS 8300 (or is eSATA port supposed to work if you have SATA Mode in BIOS set to "RAID")

This question is answered

Using Vantec NexStar 3 with USB/eSATA. Tried connecting the external enclosure to the eSATA port on the back of the computer, but the drive is not recognized in Windows 7.  (Yes, I connected the eSATA cable to the eSATA port first, then connect the USB cable on the enclosure to the USB port on the back for power - didn't help).  I verified the external drive eSATA port works by connecting it to another desktop (Alienware) and the drive works (as eSATA).

I've tried updating the BIOS to A06. No help.

I connected the external drive (using the sequence above) and rebooted the server, and press F2 to the BIOS, the BIOS doesn't even see that there's any drive connected to the eSATA port.

I don't think this is related to any Windows 7 driver because at least the disk should show up on the BIOS menu as connected to the eSATA port and it didn't.

My system have 2 SATA drives configured in RAID 1 (mirror), so if I go to the BIOS > Advanced > System Configuration, I see "SATA MODE   [RAID]".  I also see that "ESATA Port" setting is "[ENABLED].

My question is will the eSATA port on the back of the desktop work if my "SATA MODE" setting in the BIOS is set to [RAID] (instead of AHCI)?  I believe the answer to this is "yes, it is supposed to", because I vaguely remember having another desktop (non-DELL) also having the SATA set to RAID mode and I was able to use it's eSATA port just fine.

I think the last resort to this issue is to have the motherboard replaced.

Any hints/advice appreciated.

Verified Answer
  • Hi resumurof,

    With an eSATA drive attached, ATA mode enabled, and eSATA enabled in BIOS, AHCI/RAID mode must be enabled as eSATA is not supported in ATA mode. You can also try connecting the eSATA drive with a different cable and check if it is detected. Please let us know about the status.

    Thanks and Regards,
    Rajath N
    #iworkfordell
    To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region US / India  . For Dell support videos click here.

All Replies
  • Hi resumurof,

    With an eSATA drive attached, ATA mode enabled, and eSATA enabled in BIOS, AHCI/RAID mode must be enabled as eSATA is not supported in ATA mode. You can also try connecting the eSATA drive with a different cable and check if it is detected. Please let us know about the status.

    Thanks and Regards,
    Rajath N
    #iworkfordell
    To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region US / India  . For Dell support videos click here.

  • Rajath - thank you very much for taking the time to reply.

    As I indicated in my post, here is the BIOS setting:

       SATA MODE is  [RAID]

       ESATA Port   is "[ENABLED]

    The eSATA cable is good - (because I connected the drive to another computer and it worked in the other computer - an Alienware desktop).  

    UPDATE [SOLVED!], after writing the above sentece, I went ahead and retried connecting the drive to the Alienware again and was not able to connect the drive (in SATA mode) this time - it only connects in USB mode (the drive enclosure has both eSATA and USB port).  So, I tried another cable, like you suggested. And, voila!!!  It works.  So, it looks like it was really a flaky cable and when I tested it yesterday with a different computer, it happened to work.  Should've known better and tried a different cable anyway.

    So the eSATA cable is BAD, or flaky .

    For the benefits of others, here are some troubleshooting tips I've used while trying to resolve this issue.

    - If your external enclosure has both eSATA and USB interface and you want to connect the external enclosure to your computer in SATA mode, always connect the eSATA cable to the computer first, THEN connect the USB cable to the computer.  

    Q: How can you tell if the drive is indeed connected to your computer as SATA mode or USB?

    A: There are several ways you can do this.

     1) Use a free tool like HotSwap!  The tool allows you to hotswap a SATA-connected drive (in similar style as using the Windows "Safely Remove and Eject Media". When your drive is connected in SATA mode, it will show up in the HotSwap list when you click on the HotSwap icon on the system notification area (bottom-right of your screen).

    When your drive is connected in USB mode, it will not show up in HotSwap! list as a hot-swappable device.

    2) Use the standard Windows Device Manager.

       Expands the "Disk drives.

       If your external drive is connected as USB, you will see a device there called "Generic External USB Device"

       If your external drive is connected as a SATA drive, you will see the Hard Drive Make/Model listed there (e.g. WDC WD3200XXXX-xxxx, etc.)

  • Hi resumurof,

    Thank you for providing  the status of the issue and for providing the workaround that would help others with the same issue. I am glad to know that the issue has been resolved.

    Thanks and Regards,
    Rajath N
    #iworkfordell
    To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region US / India  . For Dell support videos click here.

  • Thanks, resumurof-

    I have the same NexStar enclosure, and have been having the same issues with my 8100 XPS. Sometimes is would work, other times, not, and finally stopped working. However, I assumed the hard drive was bad, since it had always worked like a champ. Put the new HDD in and nothing! I just ordered a new cable, and am hoping that's all it is, but will check my BIOS settings to be sure their all OK. Hoping it's just the cable....

    Rob

  • I was not so lucky. A new cable did not solve this same issue for me.

  • GOOD NEWS! It wasn't the drive, it wasn't the cable, and it wasn't my PC! It was the NexStar 3 Enclosure!

    I didn't have another PC with an eSATA port to test the enclosure, and I didn't have another eSATA device to test the PC, but I had a hunch it was the enclosure, so I bought a new enclosure (same NexStar 3 model), plugged it in, and it spun right up and Windows immediately recognized it!

    This process of elimination took some time, but I'm glad my eSATA port on my 8100 Studio XPS is OK. The lesson here is that if you're having similar issues, don't discount the enclosure as the culprit, even if it still works through USB, because in my case, clearly the enclosure's eSATA mode was dead.

    I hope I get more than 2 years out of the new enclosure!