Dimension 8400 Windows 8 install issue - General Hardware - Desktop - Dell Community

Dimension 8400 Windows 8 install issue


Desktop computer Forums (Audio, General Hardware, Video)

Dimension 8400 Windows 8 install issue

This question has been answered by SpeedStep

Hi forums,

I've been trying to install my Windows 8 upgrade on my Dell Dimension 8400 (it's my backup pc pls don't laugh)

It get's most of the way through and then comes up with the following errors:

Error Code: 0x0000005D





I have Windows 7 installed currently, and Ubuntu set for dual-boot.  Upon rebooting I get around 5 entries pop up in my boot selector, and choosing windows 7 returns everything to normal.

Any suggestion?  I read others have gotten Win8 on this machine successfully and others had trouble with the sound drivers, so I have to assume the trouble is on my end..

Verified Answer
  • INTEL clearly states that the 530 = DOES NOT HAVE and the 530J DOES HAVE




    Multimedia Instruction

       MMX, SSE, SSE2, SSE3

    NX only with the J version.

    Starting with Windows XP Service Pack 2 and Windows Server 2003 Service Pack 1, the NX features were implemented for the first time on the x86 architecture.

    Enabling Execute Disable Bit functionality requires a PC with a processor with Execute Disable Bit capability , BIOS Execute Disable Bit functionality and a supporting operating system. (XP Sevice Pack 2 and Higher)

    Report Unresolved Customer Service Issues here
    I do not work for Dell. I too am a user.
    The forum is primarily user to user, with Dell employees moderating
    Contact USA Technical Support

    Get Support on Twitter @DellCaresPro

All Replies
  • CPU in your D8400 may not be compatible with Win 8.  The CPU must support the following : 

    Physical Address Extension (PAE), NX, and SSE2.  Most CPUs have support for these features, so if you receive this error, it is likely because the NX feature is not enabled on your system.

    If others have successfully installed Win 8 on D8400, you may be able to upgrade the CPU to one that is compatible.

    If this answers your question, please click  Yes


    Forum Member since 2004

    I am NOT a Dell employee

  • Do you have an option to enable the "No Execute" bit in your BIOS?

  • rdunnill

    Do you have an option to enable the "No Execute" bit in your BIOS?

    Not in BIOS A09 on my 8400.

    If this answers your question, please click  Yes


    Forum Member since 2004

    I am NOT a Dell employee

  • no, I'm struggling right now as to how to update this bios.  I got the A09 final bios installed fine, but that one still doesn't add the 'no execute' option..  So Dell has made an updated version of bios A09 here: downloads.dell.com/.../GXa_A09.exe

    but It's in DOS.. so I'm having trouble.

    Finally got it running in DosBox and DosShell but i'm getting an error "unrecognized system"

    At least these little breaks shall afford me time to tie a proper noose for myself, as DOS bios flashes are best solved by one of these devices

  • if anyone knows how to install a dos bios wants to give this a try..

    It's a recent revision that (I think)  adds the 'no execute' option to the A09 bios

  • www.dell.com/.../DriverDetails  here's the info and link to the revision

  • There's a utility to make bootable USB flash drives, if that will work. Otherwise, I'd suggest a bootable floppy.

  • I just checked with "Coreinfo"   technet.microsoft.com/.../cc835722.aspx , a free cpu parameter reader and the Dimension 8400 DOES SUPPORT NO-EXECUTE PAGE PROTECTION.

    So this should work.

  • Why do you think the version of BIOS at your link should install on your Dimension 8400??  Compatibility for the version you linked is for Optiplex GXa and OptiPlex NX.

    The last version of BIOS (A09) for the Dimension 8400 was released in 2006, but the one you're trying to install was released 6 years earlier, in 2000.  Your CPU may support the functions needed for Win 8, but if Dell didn't implement all of them in BIOS, it still ain't gonna work.

    If you install that Optiplex BIOS, assuming it allows you to install it, you're likely going to brick your motherboard.

    If this answers your question, please click  Yes


    Forum Member since 2004

    I am NOT a Dell employee

  • duh.hunh, before you do anything else, you must verify the processor in your Dell Dimension 8400 has 'NX Bit'.

    If it does not there is no point arguing about whether the BIOS can or cannot do it.

    If you don't know the processor in your Dell Dimension 8400, use the program CPU-Z which can tell you www.cpuid.com/.../cpu-z.html

    On Wikipedia there is a list of Pentium 4 processors which have NX Bit. en.wikipedia.org/.../List_of_Intel_Pentium_4_microprocessors

    Then make sure you have the latest official bios (A09) installed.

    I can contribute the following findings:-

    I have a Dell Dimension 8400 with the Pentium 4 670 Processor. This has NX Bit. I also have the A09 bios installed.

    I have run the Windows 8 Upgrade Advisor (official one from Microsoft) and according to the Microsoft site, this should give an error message if WIndows 8 cannot be installed. It specifically says, on the site, that NX Bit (and SSE2) is required. Anyway this upgrade advisor did not give me an error message - in fact it invited me to buy Windows 8, it said Windows 8 would work on my PC (so, if it's true the Dimension 8400 cannot run Windows 8, Microsoft has a real problem on its hands here - the official upgrade advisor is giving out false info)

    One issue that has come up with Windows 8 is that the requirement for NX Bit was added only for the final release version, preview versions didn't require it (so this might have caused some confusion about whether certain processors can handles Windows 8)

    Anyway I do intend to install Windows 8 on my Dimension 8400 within the next 12-18 months, so I'm very interested if anyone can confirm it is possible (or, impossible...)

  • @ 2-J :  I tried CPU-Z and I have the Pentium 4 530 (Prescott).  There appears to be 2 models, 1 allows 'no execute' one does not.  Can't tell which I have, although like you - Windows Upgrade Advisor tested my pc and said I could run Windows 8 and prompted me to buy (which I did).

    As well, 'the 'CoreInfo' App tells me I have the 'no execute' function on my cpu.

    @RoHe :  Sorry about the confusion, I saw it says 2000 but thought there might be a mistake.  Upon re-reading it I think you're right though, although someone said they got it to work (somewhere on the internet?)  I guess I need to be more diligent in my references when throwing up bios' for people to 'try' in official hardware forums..

    I have read a number of people have successfully installed Win8 on their Dimension 8400's though, and as 2-J and I both passed the Windows test and cpuid says I have the function I have to assume there's a chance.

  • Thanks for the reply, duh.hunh. Well, it's really disappointing news for me, because it seems you meet the hardware requirements (like me) but then I guess something else is preventing Windows 8 recognising or using the feature, I would guess it is the BIOS then after all.

    It would be great to read about someone successfully installing Windows 8 on their Dimension 8400. However as I said above, someone installing the preview versions doesn't count, because Microsoft added in the NX Bit requirement almost at the last minute, for the release version.

    Real shame if it is the BIOS, because even back in 2006 surely Dell should have realised this was a feature in the processors they were supporting through the A09 update.

  • Well, since it seems to be a simple matter of PC semantics I think we have a little hope.  If it's just a question of Windows, Dell or a 3rd party developer  changing half a line of code then there is a chance.

    Luckily I grabbed my copy of Win8 from the Windows website for $40 and with a discount code applied it came to $14.99 + tax so I'm not too deep into this, yet.  Not upgrading the cpu though.

  • Just to add, I looked up the official Microsoft advice again.

    The official program is called 'Windows 8 Upgrade Assistant' at least in the UK.

    Microsoft provides this info on its site " If your PC doesn't support PAE, NX, and SSE2 you won’t be able to install Windows 8. Upgrade Assistant will provide you with an error message if your processor doesn't support PAE and SSE2. You'll also see a notice if the processor might not support NX or if NX is turned off in the PC BIOS." windows.microsoft.com/.../what-is-pae-nx-sse2

    So according to that if NX support is not available or NX is turned off, there should be a notice. I got no notice at all. Well, I haven't tried to install Windows 8 yet but still if the Upgrade Assistant is not giving errors when it should, that's frustrating.

  • Just a thought (sorry to reply to this thread again)

    What is "Execute Disable Memory Protection Technology" in the Dimension 8400 A09 bios? Is that related to hardware Data Execution Prevention?

    That is the only thing that sounded remotely relevant, when I went and checked the bios again.

    Someone in some old thread on this forum claimed "Windows calls it DEP, Bios calls it Execute Disable Memory Protection Technology)" en.community.dell.com/.../18018677.aspx

    Probably barking up the wrong tree, just wondered if that was relevant.