Magellan Roadmate won't fully connect to Dell 4600. Sees as Flash rom with zero capacity. - General Hardware - Desktop - Dell Community

Magellan Roadmate won't fully connect to Dell 4600. Sees as Flash rom with zero capacity.

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

Magellan Roadmate won't fully connect to Dell 4600. Sees as Flash rom with zero capacity.

This question has suggested answer(s)

I have a Dell 4600 series with Xp Prof Sp3.

Trying to Fully connect a Magellan Roadmate GPS, using USB. Connects, but ONLY as a Flash rom External drive, with Zero total capacity. Magellan software (Content Manager and VantagePoint) don't detect a GPS. Tried different USB ports (off a Hub AND direct off pc box). Pc supports USB 2.0. Sometimes comes up with "Hardware may not be fully functional". Sometimes, NO errors. Just shows an H or J drive. Even had them send me a replacement (under warranty). Replacement had problem keeping connection, even to Car Power Adapter (kept going on/off battery power, when any movement). Got ANOTHER replacement. Same detection problem (connection stable). Was able to try it on someone's laptop (Windows 7 Home Premium, Usb 1.x). Connected (!!), and was able to update it. So, something with my computer; most likely software, because can use other Usb devices.

Magellan says that once USB connected, it should come up as a Magellan drive, with the program files visible in Windows Explorer. I haven't had problems with other Usb devices (external hard-drive, camera, flash drives, printer).

I am wondering if some Magellan driver file, may have gotten "stuck" from the FIRST try at connection. I uninstalled some External Storage devices from Device Manager, hoping that the USB connection would try to re-install and get ALL the correct files back in.

Trying to think what files/services/devices could be removed, that would allow a working set of files to re-install, Correctly (if that is the problem).

I tried re-doing my Chipset drivers. No later chipset or Bios available.

I have tried connecting the GPS while other Usb devices (hubs, etc) have been unplugged. No difference. Firewall/AV disabled. No difference.

Is there a Driver Library that I can edit, to remove Roadmate entries, so the Roadmate connection can start from scratch?

Any hints, advice would be appreciated

All Replies
  • Hi RandMrk,

    You may try re-installing the USB root hub. To reinstall, please perform the following steps:

    1. Click on Start.
    2. Click Run.
    3. Type devmgmt.msc in the Run box and press enter. The device manager will open.
    4. Right click on + sign next to ‘USB Universal Bus Controllers’ to expand the category.
    5. Right click on each entry listed under USB Universal Bus Controllers and click on ‘Uninstall’.
    6. Click on ‘Yes’ on the security warning.
    7. Once all the USB hubs have been uninstalled, close the device manager and restart the system.

    I would also suggest that you download and install the software for the device from Magellan website. The link is given below:

    http://bit.ly/Qom57B

    If you continue to face the issue, try the following steps to connect the device to the system:

    1. Turn on the Magellan RoadMate device.
    2. Wait for it to be completely powered on (main menu displayed).
    3. Connect it to your computer using the supplied USB cable.
    4. Wait until the “USB connected” message appears on your RoadMate.
    5. If the Microsoft found new wizard appears:

    a. Select “No, not this time” and press “Next” button.
    b. Select the “Recommended” installation and press “Next” button.
    c. If the “Windows Signature” window appears, press “Continue” button.
    d. When the hardware wizard has finished, press “Finish” button.

    6. Wait up to 60 seconds.
    7. Right click on the “My Computer” icon on your Desktop and select “Explore” to open the Windows file explorer.
    8. If you see “Magellan or TFAT” drive, your RoadMate is properly connected to your computer.
    9. If you do not see a “Magellan or TFAT” drive, disconnect the receiver from the USB cable and reboot your computer.
    10. Return to step 1.

    Hope this helps. Let me know if you have any further questions. I will be glad to help.

    Thanks and regards,
    GauravS
    #iworkfordell

  • Tried uninstalling the USB controllers (ALL items in Device Manager, under USB). They came back, but, no change to Roadmate Gps.

    Having it attached and on, while re-booting doesn't help. Tried re-booting to Safe Mode. No change. Tried disabling Anti-virus and Firewall (Norton Internet Security). No change.

    Tried looking at the Removable Storage Library settings.

    Re-loaded my Chipset (was latest). Re-flashed my Bios (also was the latest). NO change.

    No problems with other Usb devices. Was able to update it from another pc. It connected and loaded its drivers. Was able to see its system files, in Windows Explorer.

    There Must be Some setting, in Registry that somehow got "stuck", and won't let the GPS load its software (????). Any hints??

    Thanks

  • As other USB devices work with the system, the system is working fine. Your Magellan Roadmate device might require software to be installed on the system. I would suggest that you get in touch with Magellan for obtaining the latest software.

    You may also try re-installing the Windows to eliminate any software related issues. Please back up the data before performing a Windows re-install.

    Let me know if you need any information or assistance. I will be glad to help.

    Thanks and regards,
    GauravS
    #iworkfordell

  • The software, to be installed, is on the GPS. Except for the Connection Manager, that DID install, on my computer, but does NOT detect the USB connected GPS.

    Magellan says that I have to talk with Dell (for the computer), or maybe Microsoft, since it is probably a problem with conflicting software settings.

    I am trying to see, if there is something I can do, or run, that can give me a hint as to what is "in the way". I was looking at my Event Viewer logs, but, didn't see anything (maybe missed something).

    I had, as per Magellan, tried to connect with my Firewall and Anti-virus disabled. Tried in Safe Mode.

    It doesn't come up with Found Hardware, anymore. Trying to think how to Remove whatever is loaded in there now, ONLY for the Roadmate, and then have it "re-find" itself. Probably needs a search for Roadmate, in Registry.

    To do a Windows "Fix" might be a Bigger thing to try. Would probably have to have over an few Hours worth of Updates re-done, after.   And, would it actually remove, whatever is "stuck" in there, since, a Windows re-install (not from scratch), usually leaves program settings there, so they don't have to be re-installed also.

    Thanks

    Mark

  • I have a Magellan Roadmate 3045. Since updating 3 Dell PCs to Windows 7 ( 2 are 64 bit; 1 32 bit), I have been unable to get ANY to recognize my gps EXCEPT in safe mode. Trying to update the software and maps using Content Manager in safe mode, I eventually bricked the unit. Magellan sent me a (refurbished) replacement. 

    SAME SYMPTOMS!!!

    None of the PCs can recognize the gps EXCEPT in safe mode. I am not going to attempt to run Content Manager with this unit in safe mode, since I will probably brick it as well. Not sure whether it is Windows 7 or Dell PCs. Magellan tech says units and Content Manager are compatible with Windows 7. 

    For me, lifetime maps are useless, since the only way to update is via Content Manager.

    On another note, I bought a Roadmate 9055 for bluetooth connectivity. BT does not work with either of my 2 BT phones.

    I WILL NEVER BUY ANOTHER MAGELLAN PRODUCT.

    Next time - Garmin.

    TJLee089

  • My problem was Not actually a Magellan problem; though I only had it with my Magellan usb connection.  It turned out to be my Acronis TrueImage Home backup software. When I looked at the Drivers running for my Usb, there were Four drivers there; Two from Microsoft, and Two from Acronis. When I Completely uninstalled TrueImage, I was able to update my Magellan. When I Re-installed. Didn't work again. They then came out with an Upgrade. I was told that they did Not have a patch for my problem, and that my 30 days, after purchase, support had been up for a few months (so I would need to pay). They suggested that I could get the Upgrade, that Might solve the problem. If it didn't, I at least had Free support that I could use.

    The Upgrade did NOT fix the problem, and after a few months, did NOT get a fix, so I got a Refund of TrueImage. Too bad, because I think that TrueImage, otherwise, was a good backup/imaging utility.

    I had been Trying to see if there was a way, for them to give me a way to, temporarily, disable/remove their Extra Usb driver files. They could Not (did NOT) do that.

    So, the question is.... Are you using Acronis, or some other backup software, that may have made changes to the way your computer connects to Usb devices?? Other devices that I was using Did work. Another backup program that I am currently using Does work, Along with the Magellan gps.

    Look at your Device Libraries. See what files are attached to your USB devices. Are there extra driver files, from some other program?

  • WOW!!!

    I have Acronis TrueImage Home 2011 on all 3 PCs. Removed it from laptop and voila, Magellan Roadmate appears as a drive when connected. I’ve spent hours and hours on this – mostly blaming Magellan! I owe them an apology.

    Ironically, Windows 7 Ultimate includes a backup component which makes Acronis TI unnecessary.

    THANKS A MILLION!!!

  • Glad to help.

    Just keep this in mind.. TrueImage Home 2012 AND 2013, also have the SAME problem... So, if you hear anyone suggesting that Upgrading might "Fix" the problem... It will NOT.

    Wow!! I Started this thread... And may have Ended it (??)

    Don't know why Acronis has to have those extra Usb drivers Added to the system. Not sure what extra abilities it gives to TrueImage. If they had them as Optional (don't load these, unless you Need these extra options), then it might have solved the problem, and I would still be a customer.

    I'm currently using a Western Digital external drive, with its own, continuous backup. With 2tb of space, I can get a Complete (uncompressed) backup. No problems with other devices either.

  • I had same issue on a Dell laptop with 64 bit Windows 7. Magellan GPS Roadmate 1424. Everything used to work fine. I had used their Content Manager application to update the maps on the GPS etc. Then during trying to do the latest map update, it stopped working. The GPS unit stopped showing up as a drive in explorer. After several attempts of disconnect/reconnect USB, reinstall Content Manager etc etc, it all came down to changing the USB cable! For whatever reason, the cable I was using was good enough for the GPS unit to draw power from the laptop but not for the laptop to see the unit. I tried a different cable on a hunch and the device was recognized and everything worked fine. I don't believe you need the exact same cable that you got when you bought the GPS but try different cables before going down the path of reinstalls and reboots. Smile