Optiplex 755 shuts down after waking it from sleep

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

Optiplex 755 shuts down after waking it from sleep

This question is answered

I have an OptiPlex 755 machine, Desktop model, that I recently got from work as a freebie. There was no hard drive, so I bought a WD 500GB 3.5” for it and I’m running Windows 7 Professional. Everything works great except after I wake it from sleep. It always just spontaneously shuts down a minute or two after waking it. I can work for an hour or two straight with no issue whatsoever. However, every single time I let it go to sleep and then awaken it, it shuts down within a minute or two.

Anyone have any ideas what might be causing that? Many thanks in advance!

Verified Answer
  • Changing BIOS sleep from S3 to S1 solves the issue, without affecting Wake Timers or anything else in Windows.

All Replies
  • Hi Weigelt,

    Do you see any events in event viewer at the time of the shutdown that would indicate an OS problem? Have you got automatic shutdown disabled?

  • I do see multiple events in the event viewer (not sure where in there to look specifically). There are multiple Critical and Error entries which would correspond to the shutdowns. They are all kernel power entries, Event ID 41. But from googling, it looks like that's just logging the reboot without shutting the system down first. So I guess no real entry as far as what cause the crash? I’m not sure where to find that.

    And I don’t have automatic shutdown disabled. Should I disable that?

  • And just to follow up, I disabled automatically restart and it's still occurring.

  • Disabling automatic restart is not intended to fix anything, but it allows you to see certain critical errors before Windows shuts the system down.

    You might want to check for an updated BIOS.

  • There was a more recent BIOS, which I updated. Still getting the unexpected shut down. Also, I'm also not seeing any errors before the shut down.

    One note: originally my system was simply shutting down and I would have to manually restart it. However now (even before the BIOS update) I've noticed that it is actually shutting down and restarting.

  • I'd like to bump this. This is my only problem with my Optiplex 755. I'm completely out of ideas. I've tried everything.

    I'd also like to add that I've narrowed down what's causing the restart to the S3 state. If the computer sleeps in S1, it doesn't restart. I'm thinking I may need to start praying for a bios fix...?

  • You might try restoring the Dell HD image.

  • The original image is based on Windows XP.

    The hardware is very capable of running Windows 7 and that's what I'm currently doing. It runs quite well aside from the sleep issue.

  • So this never happened with an XP image? That would appear to implicate Win 7.

  • After some more research, I did get partial solution to my original issue--I changed my power settings and set 'Allow Hybrid Sleep' to OFF. I'm not sure how that translates to any state, though, so not sure if you've tried that or not. But my machine doesn't shut off anymore like it did.

    However, now I'm left with another minor problem. My machine will go to sleep, but at some point it will wake up (usually after a few hours) and display the login screen. Once it does that, it'll just display the login screen until I either login again or shut it down.

  • I have the same problem with two Optiplex 755 systems all with clean installs of Windows 7 x64 Enterprise.

    If I type on the keyboard to bring the system out of sleep and do nothing else, it will reboot within ~30s without ever bringing the display out of standby. If I type on the keyboard a second time during this ~30s countdown, it will show the lock screen and appear to function normally. I can then proceed to use the system until the ~30s countdown elapses and the system reboots immediately to the BIOS splash screen without any intervening error or warning.

    I've found two additional possible solutions, but have not yet tested them.

    Disables Wake Timers
    http://answers.microsoft.com/en-us/windows/forum/windows_7-performance/optiplex-755-windows-7-64-bit-the-computer/63f0a8b7-10a2-4588-ab17-6b8b4ded563d

    Changes BIOS sleep from S3 to S1
    http://windowssecrets.com/forums/showthread.php/125166-Spontaneous-Rebooting-Solved  

  • Changing BIOS sleep from S3 to S1 solves the issue, without affecting Wake Timers or anything else in Windows.

  • <edited>